質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.70%

pipのパッケージインストールが失敗する

受付中

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 831

sumrin

score 4

Amazon EC2でLinuxサーバを利用しています。
ここで、pip(v18.1)を使ってパッケージ(LinkChecker)をインストールしようとすると、
下記のようなエラーが出て、インストールできません。

$ sudo /usr/local/bin/pip install LinkChecker
Collecting LinkChecker
  Using cached https://files.pythonhosted.org/packages/43/59/31baf302792306bde0825e8631a74c7f668bc47b3748fc4471c281885bb6/LinkChecker-9.3.tar.gz
Requirement already satisfied: requests>=2.2.0 in /usr/local/lib/python2.7/site-packages (from LinkChecker) (2.19.1)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python2.7/site-packages (from requests>=2.2.0->LinkChecker) (3.0.4)
Requirement already satisfied: urllib3<1.24,>=1.21.1 in /usr/local/lib/python2.7/site-packages (from requests>=2.2.0->LinkChecker) (1.23)
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python2.7/site-packages (from requests>=2.2.0->LinkChecker) (2018.8.24)
Requirement already satisfied: idna<2.8,>=2.5 in /usr/local/lib/python2.7/site-packages (from requests>=2.2.0->LinkChecker) (2.7)
Building wheels for collected packages: LinkChecker
  Running setup.py bdist_wheel for LinkChecker ... error
  Complete output from command /usr/bin/python2.7 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-9jEuz_/LinkChecker/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/pip-wheel-mKcoia --python-tag cp27:
  creating /tmp/pip-install-9jEuz_/LinkChecker/_LinkChecker_configdata.py
(中略)
  copying third_party/dnspython/dns/rdtypes/IN/APL.py -> build/lib.linux-x86_64-2.7/linkcheck_dns/dns/rdtypes/IN
  running build_ext
  error: [Errno 2] No such file or directory

  ----------------------------------------
  Failed building wheel for LinkChecker
  Running setup.py clean for LinkChecker
Failed to build LinkChecker
Installing collected packages: LinkChecker
  Running setup.py install for LinkChecker ... error
    Complete output from command /usr/bin/python2.7 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-9jEuz_/LinkChecker/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-JSxuq5/install-record.txt --single-version-externally-managed --compile:
    creating /tmp/pip-install-9jEuz_/LinkChecker/_LinkChecker_configdata.py
(中略)

    copying third_party/dnspython/dns/rdtypes/IN/APL.py -> build/lib.linux-x86_64-2.7/linkcheck_dns/dns/rdtypes/IN
    running build_ext
    error: [Errno 2] No such file or directory

    ----------------------------------------
Command "/usr/bin/python2.7 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-9jEuz_/LinkChecker/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-JSxuq5/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-install-9jEuz_/LinkChecker/
  • ローカル環境(Mac)で試してみたところ、問題なくインストールできました。
  • この方(http://blog.songs-inside.com/entry/diary/925)も同じ状況のようです。

解決方法についてご存知の方がいらっしゃいましたら、よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

ご提示のログは情報がすくないですね。(質問者様の落ち度ではなく、インストールスクリプトが情報を出してくれてないと言う意味で)

現状、何かしらのネイティブエクステンションをビルドしようとして、何かのファイルが無い、としか読めません。

まずは、verboseオプションをつけて再度インストールを試み、何か有用な情報が出るかを試すのが良さそうです。

$ sudo /usr/local/bin/pip install -v LinkChecker

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.70%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る