質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.57%

monaca cordovaプラグインを使用できるようにしたい

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 855

tips2000

score 15

 前提・実現したいこと

・monacaでビルド時にエラーが発生してしまう(解決)
・monacaでビルドされたapkファイルにサードパーティー製プラグインが含まれない状況になってしまう。
・上記の問題を解決するためGradle,Plugin.xmlファイルの編集方法を教えてほしい。
どうぞよろしくお願いいたします。

 発生している問題・エラーメッセージ

「sunmi-card-reader」というCordovaプラグイン(URL:https://github.com/PirataFrancis/sunmi-card-reader)を使用してビルドしようとした時に下記のエラーが発生しました。(解決)

ビルドされたapkファイルを起動(カスタムデバッガーで起動します)すると、『デバッガーに含まれていないプラグインがあります。sunmi-card-reader』と表示されます。

apkファイルの内容物を確認したところ、sunmi-card-readerに関連するディレクトリ、ファイルが含まれていないことが分かりました。

GradleファイルとPlugin.xmlファイルの編集が必要という事で、編集を行ってみましたが、勝手がわからず問題を解決する事ができません。

 試したこと

GradleファイルとPlugin.xmlファイルの編集が必要という事で、編集を行ってみましたが
問題が解決できません。ビルド時のエラーが表示されなくなっても、デバッグ時にプラグインが含まれていない旨メッセージが表示されてしまいます。

以下にそれぞれの編集内容を記載いたします。
Gradleファイル ---------- ---------- ----------
repositories{
google()  ←追加箇所
jcenter()
flatDir{
dirs 'src/main/libs'
}
}
dependencies {
compile(name:'rel', ext:'aar')
compile(name:'jc_rel', ext:'aar')←追加箇所
compile(name:'mv_rel', ext:'aar')←追加箇所
}
android {
packagingOptions {
exclude 'META-INF/NOTICE'
exclude 'META-INF/LICENSE'
}
}

Plugin.xmlファイル(一部抜粋) ---------- ---------- ----------
<framework src="src/android/sunmicardreader.gradle" custom="true" type="gradleReference" />
<resource-file src="libs/rel.aar" target="libs/rel.aar" />
<resource-file src="https://jcenter.bintray.com//rel//rel-.aar" target="libs/jc_rel.aar" />←追加箇所
<resource-file src="https://maven.google.com//rel//rel-.aar" target="libs/mv_rel.aar" />←追加箇所

 補足情報(FW/ツールのバージョンなど)

Cordova CLI 7.1.0

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

MonacaでCordovaプラグインを追加する場合、基本的にはGradle、plugin.xmlの編集はいらないはずです。
一度、Monacaで新しいプロジェクトを作成し、「設定」メニューの「Cordovaプラグインの追加と管理」画面から対象のプラグインのインポートを行い、「カスタムビルドデバッガー」を作成してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/10/30 01:04

    回答ありがとうございます。
    おっしゃる通り、おおよそのプラグインであれば、インポート&カスタムデバッガーで対応可能だと思われます。
    しかし、今回についてはaarファイルの参照がうまく出来なかったため、参照先を変更して指定してやる必要が出てきてしまい、結果としてGradleファイルは変更が発生しました。

    Gradleファイル変更後もビルドはできるものの、アプリ起動時に強制終了してしまう現象が発生しました。問い合わせを行ってみたところ、Androidプラットフォームのバージョンの不整合の可能性を指摘されました。

    万が一バージョン不整合だった場合、Monaca内でのこれ以上の対応は難しそうに思えたため、急きょcordovaの開発環境を用意して、cordovaでの開発を試してみることにしました。

    その為、こちらの回答をBAとさせて頂きました。
    ありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.57%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る