質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
Heroku

HerokuはHeroku社が開発と運営を行っているPaaSの名称です。RubyやNode.js、Python、そしてJVMベース(Java、Scala、Clojureなど)の複数のプログラミング言語をサポートしている。

Laravel 5

Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

Q&A

解決済

1回答

7343閲覧

herokuのデプロイ時にエラーが発生する(Class 'Barryvdh\Debugbar\ServiceProvider' not found)

supermaruetsu

総合スコア148

Heroku

HerokuはHeroku社が開発と運営を行っているPaaSの名称です。RubyやNode.js、Python、そしてJVMベース(Java、Scala、Clojureなど)の複数のプログラミング言語をサポートしている。

Laravel 5

Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

0グッド

0クリップ

投稿2018/10/18 12:29

herokuへのデプロイ時に下記のようなエラーが発生し、デプロイが出来ない状態です。
対策が全く分からず、どのようなアプローチをすべきかご教示頂けないでしょうか。
よろしくお願いいたします。
composer updateをした後にデプロイする、という方法のみ思いついた為やりましたが、エラー内容は変わりませんでした。

//composer.json "require": { "php": ">=7.1.3", "doctrine/dbal": "^2.6", "encore/laravel-admin": "^1.5", "fideloper/proxy": "~4.0", "intervention/image": "^2.4", "jenssegers/agent": "^2.6", "laravel/framework": "5.6.*", "laravel/passport": "^5.0", "laravel/socialite": "^3.0", "laravel/tinker": "~1.0", "league/flysystem-aws-s3-v3": "^1.0" }, "require-dev": { "barryvdh/laravel-debugbar": "^3.2", "filp/whoops": "~2.0", "fzaninotto/faker": "~1.4", "mockery/mockery": "~1.0", "nunomaduro/collision": "~1.1", "phpunit/phpunit": "~7.0", "symfony/thanks": "^1.0" },
-----> PHP app detected -----> Bootstrapping... -----> Installing platform packages... - php (7.2.11) - ext-mbstring (bundled with php) - nginx (1.8.1) - apache (2.4.34) -----> Installing dependencies... Composer version 1.7.2 2018-08-16 16:57:12 Loading composer repositories with package information Installing dependencies from lock file Package operations: 65 installs, 0 updates, 0 removals - Installing doctrine/cache (v1.8.0): Downloading (100%) - Installing doctrine/event-manager (v1.0.0): Downloading (100%) - Installing doctrine/inflector (v1.3.0): Downloading (100%) - Installing doctrine/lexer (v1.0.1): Downloading (100%) - Installing dragonmantank/cron-expression (v2.2.0): Downloading (100%) - Installing symfony/polyfill-mbstring (v1.9.0): Downloading (100%) - Installing symfony/polyfill-ctype (v1.9.0): Downloading (100%) - Installing symfony/dom-crawler (v4.1.6): Downloading (100%) - Installing vlucas/phpdotenv (v2.5.1): Downloading (100%) - Installing symfony/css-selector (v4.1.6): Downloading (100%) - Installing tijsverkoyen/css-to-inline-styles (2.2.1): Downloading (100%) - Installing symfony/polyfill-php72 (v1.9.0): Downloading (100%) - Installing symfony/var-dumper (v4.1.6): Downloading (100%) - Installing symfony/routing (v4.1.6): Downloading (100%) - Installing symfony/process (v4.1.6): Downloading (100%) - Installing symfony/http-foundation (v4.1.6): Downloading (100%) - Installing symfony/event-dispatcher (v4.1.6): Downloading (100%) - Installing psr/log (1.0.2): Downloading (100%) - Installing symfony/debug (v4.1.6): Downloading (100%) - Installing symfony/http-kernel (v4.1.6): Downloading (100%) - Installing symfony/finder (v4.1.6): Downloading (100%) - Installing symfony/console (v4.1.6): Downloading (100%) - Installing egulias/email-validator (2.1.6): Downloading (100%) - Installing swiftmailer/swiftmailer (v6.1.3): Downloading (100%) - Installing paragonie/random_compat (v2.0.17): Downloading (100%) - Installing ramsey/uuid (3.8.0): Downloading (100%) - Installing psr/simple-cache (1.0.1): Downloading (100%) - Installing psr/container (1.0.0): Downloading (100%) - Installing symfony/translation (v4.1.6): Downloading (100%) - Installing nesbot/carbon (1.25.0): Downloading (100%) - Installing monolog/monolog (1.23.0): Downloading (100%) - Installing league/flysystem (1.0.47): Downloading (100%) - Installing erusev/parsedown (1.7.1): Downloading (100%) - Installing laravel/framework (v5.6.39): Downloading (100%) - Installing doctrine/dbal (v2.8.0): Downloading (100%) - Installing encore/laravel-admin (v1.6.3): Downloading (100%) - Installing fideloper/proxy (4.0.0): Downloading (100%) - Installing guzzlehttp/promises (v1.3.1): Downloading (100%) - Installing psr/http-message (1.0.1): Downloading (100%) - Installing guzzlehttp/psr7 (1.4.2): Downloading (100%) - Installing intervention/image (2.4.2): Downloading (100%) - Installing jakub-onderka/php-console-color (v0.2): Downloading (100%) - Installing mobiledetect/mobiledetectlib (2.8.33): Downloading (100%) - Installing jaybizzle/crawler-detect (v1.2.69): Downloading (100%) - Installing jenssegers/agent (v2.6.0): Downloading (100%) - Installing zendframework/zend-diactoros (1.8.6): Downloading (100%) - Installing symfony/psr-http-message-bridge (v1.1.0): Downloading (100%) - Installing phpseclib/phpseclib (2.0.11): Downloading (100%) - Installing league/event (2.1.2): Downloading (100%) - Installing lcobucci/jwt (3.2.4): Downloading (100%) - Installing defuse/php-encryption (v2.2.1): Downloading (100%) - Installing league/oauth2-server (6.1.1): Downloading (100%) - Installing guzzlehttp/guzzle (6.3.3): Downloading (100%) - Installing firebase/php-jwt (v5.0.0): Downloading (100%) - Installing laravel/passport (v5.0.3): Downloading (100%) - Installing league/oauth1-client (1.7.0): Downloading (100%) - Installing laravel/socialite (v3.1.1): Downloading (100%) - Installing nikic/php-parser (v4.1.0): Downloading (100%) - Installing jakub-onderka/php-console-highlighter (v0.3.2): Downloading (100%) - Installing dnoegel/php-xdg-base-dir (0.1): Downloading (100%) - Installing psy/psysh (v0.9.8): Downloading (100%) - Installing laravel/tinker (v1.0.7): Downloading (100%) - Installing mtdowling/jmespath.php (2.4.0): Downloading (100%) - Installing aws/aws-sdk-php (3.69.3): Downloading (100%) - Installing league/flysystem-aws-s3-v3 (1.0.21): Downloading (100%) Generating optimized autoload files > Illuminate\Foundation\ComposerScripts::postAutoloadDump > @php artisan package:discover In ProviderRepository.php line 208: Class 'Barryvdh\Debugbar\ServiceProvider' not found Script @php artisan package:discover handling the post-autoload-dump event returned with error code 1 ! WARNING: There was a class not found error in your code ! ERROR: Dependency installation failed! ! ! The 'composer install' process failed with an error. The cause ! may be the download or installation of packages, or a pre- or ! post-install hook (e.g. a 'post-install-cmd' item in 'scripts') ! in your 'composer.json'. ! ! Typical error cases are out-of-date or missing parts of code, ! timeouts when making external connections, or memory limits. ! ! Check the above error output closely to determine the cause of ! the problem, ensure the code you're pushing is functioning ! properly, and that all local changes are committed correctly. ! ! For more information on builds for PHP on Heroku, refer to ! https://devcenter.heroku.com/articles/php-support ! Push rejected, failed to compile PHP app. ! Push failed

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

supermaruetsu

2018/10/18 15:30

config/appには追加しております。マニュアル通り、providersとaliasesへの登録です。これが誤りということでしょうか。
guest

回答1

0

ベストアンサー

config/appには追加しております。マニュアル通り、providersとaliasesへの登録です。

結論から言うとそれらを削除してください。

composerの設定を見る限り、"laravel/framework": "5.6.*"かつ、"barryvdh/laravel-debugbar": "^3.2"なのでパッケージディスカバリに対応しています。

どのマニュアルを見られたかわかりませんが、公式のインストール手順にも条件を満たせば以下だけ実行すれば良いと書いてあります。その条件は上記の通り満たされているようなので。

composer require barryvdh/laravel-debugbar --dev

投稿2018/10/18 16:07

xenbeat

総合スコア4258

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問