質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.47%

  • OpenSSL

    114questions

    OpenSSLはSSL/TLSのプロトコルと一般的な暗号のライブラリを導入するオープンソースのソフトウェアのツールキットです。

OpenSSLの更新について

解決済

回答 1

投稿

  • 評価
  • クリップ 2
  • VIEW 10K+

usizou

score 17

OpenSSLがかなり古いので、更新しようと思っています。

試しに開発環境で最新環境にしようとしていますが、
うまくいきません。

どなたかアドバイスいただけないでしょうか。

実施した方法は下記の通りです。

1. 「openssl version」でバージョンを確認する。
→「OpenSSL 1.0.1e-fips 11 Feb 2013」

2.「yum list | grep openssl」でバージョンを確認する。
→openssl.x86_64                             1.0.1e-30.el6.11             @updates
openssl-devel.x86_64                    1.0.1e-30.el6.11             @updates

3. 「yum update openssl」でアップデートする。

4.「openssl version」でバージョンを確認する。
→「OpenSSL 1.0.1e-fips 11 Feb 2013」

5.「yum list | grep openssl」でバージョンを確認する。
→openssl.x86_64                             1.0.1e-42.el6                @base
openssl.x86_64                             1.0.1e-42.el7                @base

※CentOS5をしています。バージョン確認はnginxのrestart後に実施しました。

確かにバージョンは上がっているのですが、最新バージョンにはならず…。
調べてみてもどうすればいいのかわかりませんでした。
どうかよろしくお願いいたします。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

Red Hat / CentOS では互換性を保つため、リリース時点のバージョンにセキュリティフィックス、バグフィックスのパッチを当てたものを(そのディストリビューションの)最新版として提供しています。
アップストリーム(OpenSSL であれば http://www.openssl.org/)で提供されている最新バージョンには
なりません。
そのため、yum update しても、バージョン番号やリリース日時がそのままになっていることがあります。
"rpm -q --changelog openssl" で履歴を見ることができます。

一部、アップストリームに追従するものもありますし(firefox など)、マイナーバージョンだけ上がるものや、別のパッケージ名で提供されるものもありますが(php53, mysql55, postgresql84, samba4 など)、ライブラリなどはバージョンは上がらないと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/08/18 15:34

    回答ありがとうございます!
    opensslやyum updateについて無知なところがかなり多く、
    「yum update」をすると自動的に1.0.2系になるのだと思っていました。

    "rpm -q --changelog openssl" で履歴を見たところ、2015/06月の更新まで対応できているので、多分最新?(あとでちゃんと調べようと思います)になっているみたいです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.47%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • OpenSSL

    114questions

    OpenSSLはSSL/TLSのプロトコルと一般的な暗号のライブラリを導入するオープンソースのソフトウェアのツールキットです。