質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.48%
Heroku

HerokuはHeroku社が開発と運営を行っているPaaSの名称です。RubyやNode.js、Python、そしてJVMベース(Java、Scala、Clojureなど)の複数のプログラミング言語をサポートしている。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Q&A

解決済

3回答

7152閲覧

[Railsチュートリアル第1章] Herokuにデプロイ出来ない

RyujiTakada

総合スコア38

Heroku

HerokuはHeroku社が開発と運営を行っているPaaSの名称です。RubyやNode.js、Python、そしてJVMベース(Java、Scala、Clojureなど)の複数のプログラミング言語をサポートしている。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

0グッド

2クリップ

投稿2015/08/16 12:08

Railsチュートリアルを始めましたが、さっそく第1章で詰まってしまいました。
Railsチュートリアル第1章

チュートリアル通り、Railsプロジェクトを作りgithubに上げたところまでは問題無かったのですが、Herokuにデプロイする際にエラーが出てデプロイ出来ません。

remote: ! Push rejected, no Cedar-supported app detected remote: HINT: This occurs when Heroku cannot detect the buildpack remote: to use for this application automatically. remote: See https://devcenter.heroku.com/articles/buildpacks

Cederとやらが使えないと。

なので、

heroku stack:set cedar-14

として、

git push heroku master

したのですが、変わらず…

どこが原因かおわかりの方いらっしゃいますでしょうか?

ちなみに、Railsチュートリアルには、「Rails4ではエラーが出るけど気にするな」的なことが書いてあるのですが、そもそもデプロイ出来ていないので、これは気にする必要ありますよね?

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答3

0

rails 4.2 版 http://railstutorial.jp/chapters/beginning?version=4.2#sec-heroku_setup
rails 4.0 版 http://railstutorial.jp/chapters/beginning?version=4.0#sec-heroku_setup
は、それなりに差がありますね。
特に理由がなければ、 4.2 版のテキストで勉強をしたほうがよいと思います。

投稿2015/11/19 20:09

katoy

総合スコア22324

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

git push heroku master の階層をワークスペース以下で行う。
heroku git:remote -a アプリ名を行う。

で私はデプロイできるようになりました。

投稿2015/11/19 17:34

love

総合スコア10

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

ベストアンサー

HINT: This occurs when Heroku cannot detect the buildpack to use for this application automatically.
See https://devcenter.heroku.com/articles/buildpacks

と書かれています。buildpackを自動検出できなかったようです。
https://devcenter.heroku.com/articles/buildpacksには

heroku buildpacks:set https://github.com/heroku/heroku-buildpack-ruby

と書かれているので上記コマンドを実行すればbuildpackを検出でき、デプロイできるようになるのではないでしょうか。

投稿2015/08/16 14:17

退会済みユーザー

退会済みユーザー

総合スコア0

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

RyujiTakada

2015/08/16 15:28 編集

ご回答ありがとうございます。 実は、質問してからご回答いただくまでの間に上記のコマンドは試しております。 …が、結果は変わらず。 再起動的な、リセット的な何かが必要なのでしょうか?
退会済みユーザー

退会済みユーザー

2015/08/16 16:50

ちょっと自分の手元でもチュートリアルを試してみましたが、Railsチュートリアルが更新されていないため、herokuにデプロイできないようです。herokuのRails対応バージョンまではちょっとわかりかねますが、古いcedarであれば動くかもしれません。 heroku stack:set cedar-10 原著ではRails 4.2.2を使ってデプロイしています。→https://www.railstutorial.org/book/beginning#sec-heroku_setup こちらではリポジトリを非公開にしたほうがセキュリティに配慮できるという理由でbitbucketを使ってたり、結構変わっているので、日本語版も対応していただけるといいですね。
RyujiTakada

2015/08/17 00:16

なるほどですね。 一旦、Herokuへのデプロイはなしで一周してみたいと思います。 ご回答ありがとうございました。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.48%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問