質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.03%

Rubyで作成したディレクトリをHPにアップした際に起きるエラーが解決出来ない

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 558
退会済みユーザー

退会済みユーザー

現在、Rubyで作成したディレクトリをHP上にアップしようとしております。

アップ自体は問題なく行っているようなのですが、以下のエラーが発生しています。

Error: The application encountered the following error: Your Ruby version is 2.3.0, but your Gemfile specified 2.3.1 (Bundler::RubyVersionMismatch)
    /home/smart/.rvm/gems/ruby-2.3.0/gems/bundler-1.16.2/lib/bundler/definition.rb:491:in `validate_ruby!'
    /home/smart/.rvm/gems/ruby-2.3.0/gems/bundler-1.16.2/lib/bundler/definition.rb:466:in `validate_runtime!'
    /home/smart/.rvm/gems/ruby-2.3.0/gems/bundler-1.16.2/lib/bundler.rb:101:in `setup'
    /home/smart/.rvm/gems/ruby-2.3.0/gems/bundler-1.16.2/lib/bundler/setup.rb:20:in `<top (required)>'
    /home/smart/.rvm/rubies/ruby-2.3.0/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    /home/smart/.rvm/rubies/ruby-2.3.0/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    /home/smart/.rvm/gems/ruby-2.3.0/gems/passenger-5.3.3/src/ruby_supportlib/phusion_passenger/loader_shared_helpers.rb:363:in `activate_gem'
    /home/smart/.rvm/gems/ruby-2.3.0/gems/passenger-5.3.3/src/ruby_supportlib/phusion_passenger/loader_shared_helpers.rb:221:in `block in run_load_path_setup_code'
    /home/smart/.rvm/gems/ruby-2.3.0/gems/passenger-5.3.3/src/ruby_supportlib/phusion_passenger/loader_shared_helpers.rb:527:in `running_bundler'
    /home/smart/.rvm/gems/ruby-2.3.0/gems/passenger-5.3.3/src/ruby_supportlib/phusion_passenger/loader_shared_helpers.rb:220:in `run_load_path_setup_code'
    /home/smart/.rvm/gems/ruby-2.3.0/gems/passenger-5.3.3/src/helper-scripts/rack-preloader.rb:91:in `preload_app'
    /home/smart/.rvm/gems/ruby-2.3.0/gems/passenger-5.3.3/src/helper-scripts/rack-preloader.rb:189:in `block in <module:App>'
    /home/smart/.rvm/gems/ruby-2.3.0/gems/passenger-5.3.3/src/ruby_supportlib/phusion_passenger/loader_shared_helpers.rb:380:in `run_block_and_record_step_progress'
    /home/smart/.rvm/gems/ruby-2.3.0/gems/passenger-5.3.3/src/helper-scripts/rack-preloader.rb:188:in `<module:App>'
    /home/smart/.rvm/gems/ruby-2.3.0/gems/passenger-5.3.3/src/helper-scripts/rack-preloader.rb:30:in `<module:PhusionPassenger>'
    /home/smart/.rvm/gems/ruby-2.3.0/gems/passenger-5.3.3/src/helper-scripts/rack-preloader.rb:29:in `<main>'

rubyのバージョンが2.3.0、Gemfileのバージョンは2.3.1となっているためのエラーとの事でしたので、rbenv を2.3.1でインストールしたのですが、

Downloading ruby-2.3.1.tar.bz2...
-> https://cache.ruby-lang.org/pub/ruby/2.3/ruby-2.3.1.tar.bz2
Installing ruby-2.3.1...
mkdir: ディレクトリ `/usr/local/rbenv/versions/2.3.1' を作成できません: 許可がありません

BUILD FAILED (CentOS release 6.9 (Final) using ruby-build 20180618-7-gb6428c7)

Inspect or clean up the working tree at /tmp/ruby-build.20180903151124.17736
Results logged to /tmp/ruby-build.20180903151124.17736.log

Last 10 log lines:
/tmp/ruby-build.20180903151124.17736 ~
ruby-2.3.1
ruby-2.3.1.tar.bz2
/tmp/ruby-build.20180903151124.17736/ruby-2.3.1 /tmp/ruby-build.20180903151124.17736 ~

と出て来てインストールできない状態です。

どう解決すればよろしいでしょうか?

よろしくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

/usr/local/の下にインストールするなら、sudoしてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.03%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る