質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.61%

  • Ruby

    7354questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

Rubyのインストール時に表示されたエラーメッセージ「DL is deprecated, please use Fiddle」について

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 6,827

poppo23

score 177

WindowsにRubyをインストールしましたが、「DL is deprecated, please use Fiddle」とエラーが出ます。

Rubyのバージョンは2.0.0p481です。

宜しくお願いいたします。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

DL は *.dllや*.soなどのダイナミックリンクライブラリーを使うためのライブラリーです。これは Ruby の 2.0 から deprecated(非推奨) になりました。
そのため、「DL ではなく、同じ目的のライブラリーである Fiddle の方を使ってください」というメッセージがでています。

これを消すためには、実行されたスクリプト中に DL を使っているところがあるはずなので、 そこを Fiddle に書き直す必要があります。
ただ、2.0 でも DL は一応残してあるので、これはエラーというよりもワーニングで、そのままでも使えないことはないと思います。 

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2014/08/25 13:14

    ありがとうございました!試してみようと思います!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 解決済

    bundle update がうまくいかない

    bundle updateを実行すると エラーが表示されます An error occurred while installing sqlite3 (1.3.8), and Bu

  • 解決済

    Rails4のMailerについて

    RailsのMailerについて、コンソール上からはしっかりと送れるのですが、アプリケーション上からは送れません。 ※logはこのようになっておりました。 DEPRECATION 

  • 解決済

    (至急)imagemagickをcloud9で扱いたい

    皆様、質問がございます、よろしくお願い申し上げます。 質問 Cloud9に"linuxbrew"を用いて"imageclip"をインストールする方法をお教えください。 下記コ

  • 解決済

    gemのインストールがうまくできません

    はじめにファイル構成を記します Projects   -Gemfile   -vendor     -bundle rubyのバージョンは2.0.0p645です rbenvを用い

  • 解決済

    ruby on rails の立ち上げからおかしいです

    初めて質問させていただきます。 以前railsを勉強していたのですが、少し間を空けてしまい、また一からわかりやすい 動画で勉強しなおそうと思い、You tubeのskill

  • 解決済

    rubysdlダウンロード

    家でも、rubyを使いたくてダウンロードしたのですが、sdlもダウンロードしなければならないことが分かり、とりあえず、学校のファイルをすべてコピーして家のパソコンに貼り付けたのです

  • 解決済

    heroku run rails db:migrateでPlease use `config.pub...

    開発環境では問題なくrails db:migrate が通るのですが、 herokuに「heroku run rails db:migrate」を実行すると以下のエラーがおきてし

  • 解決済

    Railsチュートリアル_Railsサーバーが起動しなくなった_第5章

    前提・実現したいこと Railsチュートリアルの第5章をローカル環境で実施中に、Railsサーバーを起動することができなくなりました。 エラーメッセージの内容を読んでも解決ができま

同じタグがついた質問を見る

  • Ruby

    7354questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

関連ワード: dl is deprecated, please use fiddle dl is deprecated please use fiddle please use fiddle

  • トップ
  • Rubyに関する質問
  • Rubyのインストール時に表示されたエラーメッセージ「DL is deprecated, please use Fiddle」について