質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.34%

  • Java

    14396questions

    Javaは、1995年にサン・マイクロシステムズが開発したプログラミング言語です。表記法はC言語に似ていますが、既存のプログラミング言語の短所を踏まえていちから設計されており、最初からオブジェクト指向性を備えてデザインされています。セキュリティ面が強力であることや、ネットワーク環境での利用に向いていることが特徴です。Javaで作られたソフトウェアは基本的にいかなるプラットフォームでも作動します。

  • Eclipse

    1738questions

    Eclipseは、IBM社で開発された統合開発環境のひとつです。2001年11月にオープンソース化されました。 たくさんのプラグインがあり自由に機能を追加をすることができるため、開発ツールにおける共通プラットフォームとして位置づけられています。 Eclipse自体は、Javaで実装されています。

  • Tomcat

    577questions

    TomcatはApache Software Foundation (ASF)で開発されたオープンソースのWebコンテナです。

  • Webサーバー

    458questions

    Webサーバーとは、HTTPリクエストに応じて、クライアントに情報を提供するシステムです。

EclipseにおけるDynamic Web Moduleのバージョンに関するエラー

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 270

syoshin

score 8

Eclipseでのエラーに関する質問をさせてください。

実行した手順:
テスト的にプロジェクトを作成し、プロジェクトのプロパティを開き、左ペインから Project Facetsを選択、
Dynamic Web Moduleにチェックを入れ、RuntimesにはTomcatサーバーを指定し、適用して保存しました。

するとProblemsに以下のエラーが発生しました。
"Cannot change version of project facet Dynamic Web Module to 2.4."

再度Project Facetsを開き、Dynamic Web Moduleのバージョンを確認すると、3.1に設定しておりました。

現状3.1に設定できているのであれば、2.4に変更できないエラーが発生しているのは何故なのでしょうか。
発生理由をご存知の方がいらっしゃいましたら、ご教授いただけないでしょうか。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+2

Eclipse3.7~4.2の頃のWTPプラグインにて頻発していた問題でしたが、プロジェクト内にあるweb.xmlのバージョンと、動的Webプロジェクトのファセットバージョンが一致していないとき、ないしは認識できないときに発生していました。

また、この問題はmavenを使ったプロジェクトの場合にて、異なるバージョンを指定した場合に発生しえます。最近では改善されたようですが、具体的に問題が発生するのは、プロジェクトの.settingsディレクトリにある、org.eclipse.wst.common.project.facet.core.xmlにかかれている 

<installed facet="jst.web" version="3.1"/>

このようになると思いますが、これが2.4で生成されていると、フェセットを3系に変更できない問題があり、プロジェクトファセットのリセットや、直接この値を書き換えてプロジェクトの更新をすると修正されます。

昨今リリースされているEclipse WTPプラグインでは修正されていますので、あまり気にしなくても良いでしょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/07/30 16:56

    承知致しました。
    詳しくご解説下さり、誠にありがとうございます。

    キャンセル

同じタグがついた質問を見る

  • Java

    14396questions

    Javaは、1995年にサン・マイクロシステムズが開発したプログラミング言語です。表記法はC言語に似ていますが、既存のプログラミング言語の短所を踏まえていちから設計されており、最初からオブジェクト指向性を備えてデザインされています。セキュリティ面が強力であることや、ネットワーク環境での利用に向いていることが特徴です。Javaで作られたソフトウェアは基本的にいかなるプラットフォームでも作動します。

  • Eclipse

    1738questions

    Eclipseは、IBM社で開発された統合開発環境のひとつです。2001年11月にオープンソース化されました。 たくさんのプラグインがあり自由に機能を追加をすることができるため、開発ツールにおける共通プラットフォームとして位置づけられています。 Eclipse自体は、Javaで実装されています。

  • Tomcat

    577questions

    TomcatはApache Software Foundation (ASF)で開発されたオープンソースのWebコンテナです。

  • Webサーバー

    458questions

    Webサーバーとは、HTTPリクエストに応じて、クライアントに情報を提供するシステムです。