質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.33%

  • Ruby

    8204questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7683questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Paperclipを使用するためにgemfileを書き換えbundle updateを行うとエラーが出ます。

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 131

S.K1994

score 16

Paperclipを使い画像のアップロード機能を制作しようとしているのですが、
bundle updateをしたらエラーが出てしまいました。

エラーの内容、解決方法がお分かりになる方がいらっしゃいましたら是非お力添えをお願いします。

ちなみに現在のrails rubyのバージョンはこちらです。
ruby 2.0.0p648
rails 4.0.5です。

まずはPaperclipの使用に必要なImagemagickをインストールしました。

$ sudo apt-get install imagemagick
コード

その後、githubから最新バージョンを指定してpaperclipをインストールするために,
gemfileを開き、この1行を追加しました。

gem 'paperclip', github: 'thoughtbot/paperclip’

コード

これによりgemfileはこのようになっています。

source 'https://rubygems.org'
ruby '2.0.0' 
gem 'paperclip', github: 'thoughtbot/paperclip'
gem 'rails', '4.0.5'
gem 'bootstrap-sass', '3.3.1'
gem 'sprockets', '2.11.0'
gem 'devise', '3.4.1'
gem 'faker', '1.1.2'
gem 'will_paginate', '3.0.4'
gem 'will_paginate-bootstrap', '1.0.1'




group :development do
  gem 'sqlite3', '1.3.9'
end

gem 'sass-rails', '4.0.3'
gem 'uglifier', '2.5.3'
gem 'coffee-rails', '4.0.1'
gem 'jquery-rails', '3.1.2'
gem 'turbolinks', '2.5.1'
gem 'jbuilder', '1.5.3'

group :doc do
  gem 'sdoc', '0.4.1', require: false
end

コード

このあとにbundle updateを実行するとこのような文言になりました。

The git source `git://github.com/thoughtbot/paperclip.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.
Fetching git://github.com/thoughtbot/paperclip.git
Fetching gem metadata from https://rubygems.org/..........
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for
gem "ruby":
  In Gemfile:
    ruby (~> 2.0.0.0)

paperclip was resolved to 6.0.0, which
depends on
      ruby (>= 2.1.0)

Could not find gem 'ruby (>= 2.1.0)', which
is required by gem 'paperclip', in any of the
relevant sources:
  the local ruby installation
コード

bundle installを実行するとこのようになります。

The git source `git://github.com/thoughtbot/paperclip.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.
Fetching git://github.com/thoughtbot/paperclip.git
Fetching gem metadata from https://rubygems.org/..........
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for
gem "activesupport":
  In snapshot (Gemfile.lock):
    activesupport (= 4.0.5)

  In Gemfile:
paperclip was resolved to 6.0.0, which
depends on
      activesupport (>= 4.2.0)

rails (= 4.0.5) was resolved to 4.0.5,
which depends on
      activesupport (= 4.0.5)

Running `bundle update` will rebuild your
snapshot from scratch, using only
the gems in your Gemfile, which may resolve
the conflict.
コード

この2つのエラー文の内容を検索してみても参考になりそうなものが見つからず困っています。
経験が浅いものですのでどうか参考になる回答をお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

ruby 2.0.0p648
rails 4.0.5です。

エラーメッセージにあるように(activesupportはRailsを構成するGemの1つです)、paperclipの最新版(6.0.0)はRuby 2.1以上、Rails 4.2以上が必要です。この環境でも動く古いバージョンを探すか、RubyとRailsをアップデートするかが必要です。


なお、Rails 5.2でActiveStorageが登場したこともあって、paperclip開発中止となりました

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • Ruby

    8204questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7683questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。