質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.33%

  • PHP

    21352questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • phpMyAdmin

    691questions

    phpMyAdminはオープンソースで、PHPで書かれたウェブベースのMySQL管理ツールのことです。

phpMyAdminをyumでインストールした際のエラー

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 601

ShHa

score 1

 前提・実現したいこと

環境:CentOS 7, PHP 7.1.7

この環境にphpMyAdminをインストールしようとしたところ、
以下のエラーで進められず困っております。 

 発生している問題・エラーメッセージ

いろいろ参考サイトを拝見して試行錯誤しましたがエラーが解消されることはありませんでした。

$ sudo yum --enablerepo=remi-php71 install phpMyAdmin


を試してます。

以下、エラー内容です。

--> 依存性解決を終了しました。
エラー: パッケージ: php-twig-extensions-1.5.1-1.el7.remi.noarch (remi)
             要求: php-composer(symfony/translation) >= 2.7.1
エラー: パッケージ: php-twig-extensions-1.5.1-1.el7.remi.noarch (remi)
             要求: php-composer(symfony/translation) < 4.0
エラー: パッケージ: php-twig-extensions-1.5.1-1.el7.remi.noarch (remi)
             要求: php-composer(fedora/autoloader)
エラー: パッケージ: phpMyAdmin-4.8.2-1.el7.remi.noarch (remi)
             要求: php-psr-container >= 1.0
エラー: パッケージ: php-pecl-zip-1.15.3-1.el7.remi.7.1.x86_64 (remi-php71)
             要求: libzip5(x86-64) >= 1.5.1
エラー: パッケージ: php-google-recaptcha-1.1.3-1.el7.remi.noarch (remi)
             要求: php-composer(fedora/autoloader)
エラー: パッケージ: php-gmp-7.1.19-1.el7.remi.x86_64 (remi-php71)
             要求: php-common(x86-64) = 7.1.19-1.el7.remi
            インストール: php-common-7.2.7-1.el7.remi.x86_64 (@remi-php72)
                php-common(x86-64) = 7.2.7-1.el7.remi
            利用可能: php-common-5.4.16-45.el7.x86_64 (base)
                php-common(x86-64) = 5.4.16-45.el7
            利用可能: php-common-7.1.18-1.el7.remi.x86_64 (remi-php71)
                php-common(x86-64) = 7.1.18-1.el7.remi
            利用可能: php-common-7.1.19-1.el7.remi.x86_64 (remi-php71)
                php-common(x86-64) = 7.1.19-1.el7.remi
エラー: パッケージ: php-symfony-polyfill-1.8.0-3.el7.remi.noarch (remi)
             要求: php-composer(paragonie/random_compat) < 3.0
エラー: パッケージ: php-pecl-zip-1.15.3-1.el7.remi.7.1.x86_64 (remi-php71)
             要求: php(api) = 20160303-64
            インストール: php-common-7.2.7-1.el7.remi.x86_64 (@remi-php72)
                php(api) = 20170718-64
            利用可能: php-common-5.4.16-45.el7.x86_64 (base)
                php(api) = 20100412-64
            利用可能: php-common-7.1.18-1.el7.remi.x86_64 (remi-php71)
                php(api) = 20160303-64
            利用可能: php-common-7.1.19-1.el7.remi.x86_64 (remi-php71)
                php(api) = 20160303-64
エラー: パッケージ: php-symfony-polyfill-1.8.0-3.el7.remi.noarch (remi)
             要求: php-composer(ircmaxell/password-compat) >= 1.0
エラー: パッケージ: php-phpseclib-2.0.11-1.el7.remi.noarch (remi)
             要求: php-composer(fedora/autoloader)
エラー: パッケージ: php-phpmyadmin-sql-parser-4.2.4-3.el7.remi.noarch (remi)
             要求: php-composer(fedora/autoloader)
エラー: パッケージ: php-phpmyadmin-motranslator-4.0-1.el7.remi.noarch (remi)
             要求: php-composer(symfony/expression-language) < 4
エラー: パッケージ: php-pecl-zip-1.15.3-1.el7.remi.7.1.x86_64 (remi-php71)
             要求: libzip.so.5()(64bit)
エラー: パッケージ: php-symfony-polyfill-1.8.0-3.el7.remi.noarch (remi)
             要求: php-composer(fedora/autoloader)
エラー: パッケージ: php-recode-7.1.19-1.el7.remi.x86_64 (remi-php71)
             要求: php-common(x86-64) = 7.1.19-1.el7.remi
            インストール: php-common-7.2.7-1.el7.remi.x86_64 (@remi-php72)
                php-common(x86-64) = 7.2.7-1.el7.remi
            利用可能: php-common-5.4.16-45.el7.x86_64 (base)
                php-common(x86-64) = 5.4.16-45.el7
            利用可能: php-common-7.1.18-1.el7.remi.x86_64 (remi-php71)
                php-common(x86-64) = 7.1.18-1.el7.remi
            利用可能: php-common-7.1.19-1.el7.remi.x86_64 (remi-php71)
                php-common(x86-64) = 7.1.19-1.el7.remi
エラー: パッケージ: php-phpmyadmin-motranslator-4.0-1.el7.remi.noarch (remi)
             要求: php-composer(fedora/autoloader)
エラー: パッケージ: php-twig-1.35.4-1.el7.remi.7.1.noarch (remi-php71)
             要求: php-composer(fedora/autoloader)
エラー: パッケージ: php-intl-7.1.19-1.el7.remi.x86_64 (remi-php71)
             要求: php-common(x86-64) = 7.1.19-1.el7.remi
            インストール: php-common-7.2.7-1.el7.remi.x86_64 (@remi-php72)
                php-common(x86-64) = 7.2.7-1.el7.remi
            利用可能: php-common-5.4.16-45.el7.x86_64 (base)
                php-common(x86-64) = 5.4.16-45.el7
            利用可能: php-common-7.1.18-1.el7.remi.x86_64 (remi-php71)
                php-common(x86-64) = 7.1.18-1.el7.remi
            利用可能: php-common-7.1.19-1.el7.remi.x86_64 (remi-php71)
                php-common(x86-64) = 7.1.19-1.el7.remi
エラー: パッケージ: phpMyAdmin-4.8.2-1.el7.remi.noarch (remi)
             要求: php-symfony-expression-language < 4
エラー: パッケージ: php-bcmath-7.1.19-1.el7.remi.x86_64 (remi-php71)
             要求: php-common(x86-64) = 7.1.19-1.el7.remi
            インストール: php-common-7.2.7-1.el7.remi.x86_64 (@remi-php72)
                php-common(x86-64) = 7.2.7-1.el7.remi
            利用可能: php-common-5.4.16-45.el7.x86_64 (base)
                php-common(x86-64) = 5.4.16-45.el7
            利用可能: php-common-7.1.18-1.el7.remi.x86_64 (remi-php71)
                php-common(x86-64) = 7.1.18-1.el7.remi
            利用可能: php-common-7.1.19-1.el7.remi.x86_64 (remi-php71)
                php-common(x86-64) = 7.1.19-1.el7.remi
エラー: パッケージ: php-symfony-polyfill-1.8.0-3.el7.remi.noarch (remi)
             要求: php-composer(paragonie/random_compat) >= 1.0
エラー: パッケージ: phpMyAdmin-4.8.2-1.el7.remi.noarch (remi)
             要求: php-phpmyadmin-shapefile >= 2.0
エラー: パッケージ: phpMyAdmin-4.8.2-1.el7.remi.noarch (remi)
             要求: php-composer(fedora/autoloader)
エラー: パッケージ: php-symfony-polyfill-1.8.0-3.el7.remi.noarch (remi)
             要求: php-composer(ircmaxell/password-compat) < 2.0
エラー: パッケージ: php-pecl-zip-1.15.3-1.el7.remi.7.1.x86_64 (remi-php71)
             要求: php(zend-abi) = 20160303-64
            インストール: php-common-7.2.7-1.el7.remi.x86_64 (@remi-php72)
                php(zend-abi) = 20170718-64
            利用可能: php-common-5.4.16-45.el7.x86_64 (base)
                php(zend-abi) = 20100525-64
            利用可能: php-common-7.1.18-1.el7.remi.x86_64 (remi-php71)
                php(zend-abi) = 20160303-64
            利用可能: php-common-7.1.19-1.el7.remi.x86_64 (remi-php71)
                php(zend-abi) = 20160303-64
 問題を回避するために --skip-broken を用いることができます。
 これらを試行できます: rpm -Va --nofiles --nodigest

どなたか宜しくお願い致しますm(__)m

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • asahina1979

    2018/07/18 03:04

    yum のリポジトリリストの表示結果を追記してください

    キャンセル

回答 1

checkベストアンサー

+1

エラー: パッケージ: php-intl-7.1.19-1.el7.remi.x86_64 (remi-php71)
要求: php-common(x86-64) = 7.1.19-1.el7.remi
インストール: php-common-7.2.7-1.el7.remi.x86_64 (@remi-php72)

この辺のエラーを見ると、PHP71で入れたいのにPHP72をインストールされようとしていますね。
/etc/yum.repo.d/remi-php72.repo が有効な設定になっているはず。

enable=0

に変更して、コマンド叩けば入りそう。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/07/17 20:18

    ご回答ありがとうございます。
    試してみたのですが、、エラーが出まして、、

    ーーー
    --> 依存性解決を終了しました。
    エラー: パッケージ: php-twig-extensions-1.5.1-1.el7.remi.noarch (remi)
    要求: php-composer(symfony/translation) >= 2.7.1
    エラー: パッケージ: php-twig-extensions-1.5.1-1.el7.remi.noarch (remi)
    要求: php-composer(symfony/translation) < 4.0
    エラー: パッケージ: php-twig-extensions-1.5.1-1.el7.remi.noarch (remi)
    要求: php-composer(fedora/autoloader)
    エラー: パッケージ: phpMyAdmin-4.8.2-1.el7.remi.noarch (remi)
    要求: php-psr-container >= 1.0
    エラー: パッケージ: php-pecl-zip-1.15.3-1.el7.remi.7.1.x86_64 (remi-php71)
    要求: libzip5(x86-64) >= 1.5.1
    エラー: パッケージ: php-google-recaptcha-1.1.3-1.el7.remi.noarch (remi)
    要求: php-composer(fedora/autoloader)
    エラー: パッケージ: php-gmp-7.1.19-1.el7.remi.x86_64 (remi-php71)
    要求: php-common(x86-64) = 7.1.19-1.el7.remi
    インストール: php-common-7.2.7-1.el7.remi.x86_64 (@remi-php72)
    php-common(x86-64) = 7.2.7-1.el7.remi
    利用可能: php-common-5.4.16-45.el7.x86_64 (base)
    php-common(x86-64) = 5.4.16-45.el7
    利用可能: php-common-7.1.18-1.el7.remi.x86_64 (remi-php71)
    php-common(x86-64) = 7.1.18-1.el7.remi
    利用可能: php-common-7.1.19-1.el7.remi.x86_64 (remi-php71)
    php-common(x86-64) = 7.1.19-1.el7.remi
    エラー: パッケージ: php-symfony-polyfill-1.8.0-3.el7.remi.noarch (remi)
    要求: php-composer(paragonie/random_compat) < 3.0
    エラー: パッケージ: php-pecl-zip-1.15.3-1.el7.remi.7.1.x86_64 (remi-php71)
    要求: php(api) = 20160303-64
    インストール: php-common-7.2.7-1.el7.remi.x86_64 (@remi-php72)
    php(api) = 20170718-64
    利用可能: php-common-5.4.16-45.el7.x86_64 (base)
    php(api) = 20100412-64
    利用可能: php-common-7.1.18-1.el7.remi.x86_64 (remi-php71)
    php(api) = 20160303-64
    利用可能: php-common-7.1.19-1.el7.remi.x86_64 (remi-php71)
    php(api) = 20160303-64
    エラー: パッケージ: php-symfony-polyfill-1.8.0-3.el7.remi.noarch (remi)
    要求: php-composer(ircmaxell/password-compat) >= 1.0
    エラー: パッケージ: php-phpseclib-2.0.11-1.el7.remi.noarch (remi)
    要求: php-composer(fedora/autoloader)
    エラー: パッケージ: php-phpmyadmin-sql-parser-4.2.4-3.el7.remi.noarch (remi)
    要求: php-composer(fedora/autoloader)
    エラー: パッケージ: php-phpmyadmin-motranslator-4.0-1.el7.remi.noarch (remi)
    要求: php-composer(symfony/expression-language) < 4
    エラー: パッケージ: php-pecl-zip-1.15.3-1.el7.remi.7.1.x86_64 (remi-php71)
    要求: libzip.so.5()(64bit)
    エラー: パッケージ: php-symfony-polyfill-1.8.0-3.el7.remi.noarch (remi)
    要求: php-composer(fedora/autoloader)
    エラー: パッケージ: php-recode-7.1.19-1.el7.remi.x86_64 (remi-php71)
    要求: php-common(x86-64) = 7.1.19-1.el7.remi
    インストール: php-common-7.2.7-1.el7.remi.x86_64 (@remi-php72)
    php-common(x86-64) = 7.2.7-1.el7.remi
    利用可能: php-common-5.4.16-45.el7.x86_64 (base)
    php-common(x86-64) = 5.4.16-45.el7
    利用可能: php-common-7.1.18-1.el7.remi.x86_64 (remi-php71)
    php-common(x86-64) = 7.1.18-1.el7.remi
    利用可能: php-common-7.1.19-1.el7.remi.x86_64 (remi-php71)
    php-common(x86-64) = 7.1.19-1.el7.remi
    エラー: パッケージ: php-phpmyadmin-motranslator-4.0-1.el7.remi.noarch (remi)
    要求: php-composer(fedora/autoloader)
    エラー: パッケージ: php-twig-1.35.4-1.el7.remi.7.1.noarch (remi-php71)
    要求: php-composer(fedora/autoloader)
    エラー: パッケージ: php-intl-7.1.19-1.el7.remi.x86_64 (remi-php71)
    要求: php-common(x86-64) = 7.1.19-1.el7.remi
    インストール: php-common-7.2.7-1.el7.remi.x86_64 (@remi-php72)
    php-common(x86-64) = 7.2.7-1.el7.remi
    利用可能: php-common-5.4.16-45.el7.x86_64 (base)
    php-common(x86-64) = 5.4.16-45.el7
    利用可能: php-common-7.1.18-1.el7.remi.x86_64 (remi-php71)
    php-common(x86-64) = 7.1.18-1.el7.remi
    利用可能: php-common-7.1.19-1.el7.remi.x86_64 (remi-php71)
    php-common(x86-64) = 7.1.19-1.el7.remi
    エラー: パッケージ: phpMyAdmin-4.8.2-1.el7.remi.noarch (remi)
    要求: php-symfony-expression-language < 4
    エラー: パッケージ: php-bcmath-7.1.19-1.el7.remi.x86_64 (remi-php71)
    要求: php-common(x86-64) = 7.1.19-1.el7.remi
    インストール: php-common-7.2.7-1.el7.remi.x86_64 (@remi-php72)
    php-common(x86-64) = 7.2.7-1.el7.remi
    利用可能: php-common-5.4.16-45.el7.x86_64 (base)
    php-common(x86-64) = 5.4.16-45.el7
    利用可能: php-common-7.1.18-1.el7.remi.x86_64 (remi-php71)
    php-common(x86-64) = 7.1.18-1.el7.remi
    利用可能: php-common-7.1.19-1.el7.remi.x86_64 (remi-php71)
    php-common(x86-64) = 7.1.19-1.el7.remi
    エラー: パッケージ: php-symfony-polyfill-1.8.0-3.el7.remi.noarch (remi)
    要求: php-composer(paragonie/random_compat) >= 1.0
    エラー: パッケージ: phpMyAdmin-4.8.2-1.el7.remi.noarch (remi)
    要求: php-phpmyadmin-shapefile >= 2.0
    エラー: パッケージ: phpMyAdmin-4.8.2-1.el7.remi.noarch (remi)
    要求: php-composer(fedora/autoloader)
    エラー: パッケージ: php-symfony-polyfill-1.8.0-3.el7.remi.noarch (remi)
    要求: php-composer(ircmaxell/password-compat) < 2.0
    エラー: パッケージ: php-pecl-zip-1.15.3-1.el7.remi.7.1.x86_64 (remi-php71)
    要求: php(zend-abi) = 20160303-64
    インストール: php-common-7.2.7-1.el7.remi.x86_64 (@remi-php72)
    php(zend-abi) = 20170718-64
    利用可能: php-common-5.4.16-45.el7.x86_64 (base)
    php(zend-abi) = 20100525-64
    利用可能: php-common-7.1.18-1.el7.remi.x86_64 (remi-php71)
    php(zend-abi) = 20160303-64
    利用可能: php-common-7.1.19-1.el7.remi.x86_64 (remi-php71)
    php(zend-abi) = 20160303-64
    問題を回避するために --skip-broken を用いることができます。
    これらを試行できます: rpm -Va --nofiles --nodigest
    ーーー

    です。
    まだPHP72をインストールしようとしてるぽいです。

    /etc/yum.repos.d/remi-php72.repo
    enable=0
    は設定しております。。

    ちなみに
    /etc/yum.repos.d/remi-php71.repo
    enable=1
    です。

    なにかお分かりになりませんでしょうか?

    キャンセル

  • 2018/07/18 12:20

    remi-php72からすでに何かインストールされているので、それをダウングレードした上で、実行しましょう。

    キャンセル

  • 2018/07/20 15:05

    ゼロベースで再構築したらうまくいきました。
    ご協力ありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.33%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • PHP

    21352questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • phpMyAdmin

    691questions

    phpMyAdminはオープンソースで、PHPで書かれたウェブベースのMySQL管理ツールのことです。