質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.53%

  • Vagrant

    1182questions

    Vagrantは、VirtualBox上の仮想マシンを コマンドラインから作成してくれるソフトウェアです。 ビルド環境など容易に構築が可能です。

Railsの開発環境でエラーが出る

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 128

Furisuke

score 93

https://www.sejuku.net/blog/39936#_Ruby_on_Rails
をみて手順通りにやっているのですがサイトの「Railsのインストール」の部分の

bundle install --path vendor/bundler


のコマンドを実行すると下記のエラー構文が出てきます
An error occurred while installing therubyracer (0.12.3), and Bundler cannot continue.
Make sure that gem install therubyracer -v '0.12.3' --source 'https://rubygems.org/' succeeds before bundling.
調べて

gem install therubyracer -v '0.12.3'


を実行したのですがそれでもエラーがでます
どうすれば

bundle install --path vendor/bundler


が実行できるようになりますか?

gem install therubyracer -v '0.12.3'
をした時のエラーは
Fetching: libv8-3.16.14.19-x86_64-linux.gem (100%)
Successfully installed libv8-3.16.14.19-x86_64-linux
Building native extensions. This could take a while...
ERROR:  Error installing therubyracer:
ERROR: Failed to build gem native extension.

current directory: /home/vagrant/.rbenv/versions/2.4.2/lib/ruby/gems/2.4.0/gems/therubyracer-0.12.3/ext/v8
/home/vagrant/.rbenv/versions/2.4.2/bin/ruby -r ./siteconf20180704-5206-12186cd.rb extconf.rb
checking for -lpthread... yes
creating Makefile

current directory: /home/vagrant/.rbenv/versions/2.4.2/lib/ruby/gems/2.4.0/gems/therubyracer-0.12.3/ext/v8
make "DESTDIR=" clean

current directory: /home/vagrant/.rbenv/versions/2.4.2/lib/ruby/gems/2.4.0/gems/therubyracer-0.12.3/ext/v8
make "DESTDIR="
compiling accessor.cc
make: g++: Command not found
make: *** [accessor.o] Error 127

make failed, exit code 2

Gem files will remain installed in /home/vagrant/.rbenv/versions/2.4.2/lib/ruby/gems/2.4.0/gems/therubyracer-0.12.3 for inspection.
Results logged to /home/vagrant/.rbenv/versions/2.4.2/lib/ruby/gems/2.4.0/extensions/x86_64-linux/2.4.0-static/therubyracer-0.12.3/gem_make.out

です

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • maisumakun

    2018/07/04 11:10

    エラーメッセージを見せていただけないでしょうか。

    キャンセル

  • Furisuke

    2018/07/04 15:59

    返信遅れてすみません。上にも記述した通りAn error occurred while installing therubyracer (0.12.3), and Bundler cannot continue. Make sure that gem install therubyracer -v '0.12.3' --source 'https://rubygems.org/' succeeds before bundling.と出てきます

    キャンセル

  • maisumakun

    2018/07/04 16:11

    「gem install therubyracer -v '0.12.3'」のほうではどのようなエラーが出ました?

    キャンセル

  • Furisuke

    2018/07/04 16:26

    ちょっとどの部分がエラーかわからず、ただインストールがされていないと思います。表示された文章が長いので、質問文を編集します

    キャンセル

回答 1

checkベストアンサー

0

therubyracerのインストール中にmake: g++: Command not foundと出ているように、おそらく環境にC++コンパイラが入っていません。

yum install gcc-c++のようにして、再度試してみましょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.53%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Vagrant

    1182questions

    Vagrantは、VirtualBox上の仮想マシンを コマンドラインから作成してくれるソフトウェアです。 ビルド環境など容易に構築が可能です。