質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.52%

  • Ruby

    7633questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7238questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

rails g 系統のコマンドができない

解決済

回答 3

投稿

  • 評価
  • クリップ 0
  • VIEW 225

hi_r

score 2

 前提・実現したいこと

$rails g controller home topのコマンドを実行したのですがファイルが作成されず以下の様なエラーメッセージがでて困っています。どうすればg系統のコマンドができる様になるのか教えていただきたいです。

 発生している問題・エラーメッセージ

Ignoring bindex-0.5.0 because its extensions are not built.  Try: gem pristine bindex --version 0.5.0
Ignoring bootsnap-1.3.0 because its extensions are not built.  Try: gem pristine bootsnap --version 1.3.0
Ignoring byebug-10.0.2 because its extensions are not built.  Try: gem pristine byebug --version 10.0.2
/Library/Ruby/Gems/2.3.0/gems/bundler-1.16.2/lib/bundler/spec_set.rb:91:in `block in materialize': Could not find nokogiri-1.8.3 in any of the sources (Bundler::GemNotFound)
        from /Library/Ruby/Gems/2.3.0/gems/bundler-1.16.2/lib/bundler/spec_set.rb:85:in `map!'
        from /Library/Ruby/Gems/2.3.0/gems/bundler-1.16.2/lib/bundler/spec_set.rb:85:in `materialize'
        from /Library/Ruby/Gems/2.3.0/gems/bundler-1.16.2/lib/bundler/definition.rb:171:in `specs'
        from /Library/Ruby/Gems/2.3.0/gems/bundler-1.16.2/lib/bundler/definition.rb:238:in `specs_for'
        from /Library/Ruby/Gems/2.3.0/gems/bundler-1.16.2/lib/bundler/definition.rb:227:in `requested_specs'
        from /Library/Ruby/Gems/2.3.0/gems/bundler-1.16.2/lib/bundler/runtime.rb:108:in `block in definition_method'
        from /Library/Ruby/Gems/2.3.0/gems/bundler-1.16.2/lib/bundler/runtime.rb:20:in `setup'
        from /Library/Ruby/Gems/2.3.0/gems/bundler-1.16.2/lib/bundler.rb:107:in `setup'
        from /Library/Ruby/Gems/2.3.0/gems/bundler-1.16.2/lib/bundler/setup.rb:20:in `<top (required)>'
        from /Users/hiro/.rbenv/versions/2.3.3/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /Users/hiro/.rbenv/versions/2.3.3/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/commands.rb:33:in `<module:Spring>'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/commands.rb:4:in `<top (required)>'
        from /Users/hiro/.rbenv/versions/2.3.3/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /Users/hiro/.rbenv/versions/2.3.3/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/server.rb:9:in `<top (required)>'
        from /Users/hiro/.rbenv/versions/2.3.3/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /Users/hiro/.rbenv/versions/2.3.3/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/client/server.rb:9:in `call'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/client/command.rb:7:in `call'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/client.rb:30:in `run'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/bin/spring:49:in `<main>'

 補足情報(FW/ツールのバージョンなど)

Rails 5.2.0
ruby 2.3.3p222 (2016-11-21 revision 56859) [x86_64-darwin17]

初心者で何を書けば良いのかわからないので他に必要な情報等ありましたら教えてください。。。。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

check解決した方法

0

なぜ解決できたのかは分からないのですが、rbenvでrubyのバージョンを2.3.3→2.5.0→2.3.3と変更し直したらgenerateできるようになりました!ご迷惑をおかけいたしました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

もしrbenvを使っているのであれば、bundlerを再インストールしてみてください
$ rbenv exec gem install bundler
$ rbenv rehash

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/07/04 17:04

    やってみたのですが、まだ上と同じ文が表示されます。。。

    キャンセル

0

bundle exec rails g controller home topで事態は変わりますでしょうか?

bundle installは正常に終了していますか?

xcode(というかgcc)はインストールされているでしょうか?

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 解決済

    railsのgemで導入したJQueryプラグインファイルについて

    いつも皆さんにはお世話になっています。 この度、gemでFullcalendarというJQueryで作成しているカレンダーを導入したのですが、少しカスタマイズを加えたいと思い

  • 解決済

    [Ruby on Rails]bundle install でのエラー解決方法

    bundle install でエラー Railsチュートリアルを行っている最中なのですが、 下記エラーが発生し困っております。 解決方法をググって色々探し、試してみたの

  • 受付中

    ruby on rails install error

    ruby on railsをmac (os EI captain)にインストールしたいのですが、エラーがででインストールできません 発生している問題・エラーメッセージ ERRO

  • 受付中

    rails server コマンドでエラーがでます(cannnot load such file)

    railsでアプリを作ろうとしています。 rails new で新しいフォルダを作成まではできるのですが、そのディレクトリに移動してrails -vや、 rails -sコマンド

  • 解決済

    windowsにてbundlerが使えない

    windowsにてbundlerでgemを管理しようとしましたが、該当のgemはないとエラーが出ます。 CentOSで試したところ、ちゃんとロードされました。 解決方法はないでしょ

  • 受付中

    rails appのbundleがインストールできない

    bundle install Fetching gem metadata from https://rubygems.org/......... Fetching version

  • 解決済

    Rubyの環境には2種類の状態がある。

     壊れているか、これから壊れるかだ。 ちなみに、今朝これをくらいました。(復旧済み) xxxxxx-no-MacBook-Pro:~ xxxxxx$ gem list /usr

  • 解決済

    bundle installができない エラー

    昨日、nokogiriのインストールでエラーが出るという質問を投稿させていただきました。 nokogiriのせいなのかと思っていたのですが、そもそもrails sもできないという状

同じタグがついた質問を見る

  • Ruby

    7633questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7238questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。