質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.52%

  • Android

    6513questions

    Androidは、Google社が開発したスマートフォンやタブレットなど携帯端末向けのプラットフォームです。 カーネル・ミドルウェア・ユーザーインターフェイス・ウェブブラウザ・電話帳などのアプリケーションやソフトウェアをひとつにまとめて構成。 カーネル・ライブラリ・ランタイムはほとんどがC言語/C++、アプリケーションなどはJavaSEのサブセットとAndroid環境で書かれています。

  • Android Studio

    3694questions

    Android Studioは、 Google社によって開発された、 Androidのネイティブアプリケーション開発に特化した統合開発ツールです。

build.gradleのimplementation部分のバージョンによるエラーが出るようになった

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 604

聞きたいこと

AndroidStudioで作製したコードを6月26日午前に実行し、実行できたのですが。翌日の6月27日午後夕方ごろに再度実行したらエラーで落ちてしまいました
コード自体は変えていなくコンパイルは通るのですが、実行時エラーで強制終了してしまいます。コードを見てみると、appのbulid.gradleのimplementation部分に赤い波線が書いてある部分がありました。build.gradleとエラーコードは以下に挙げます。どうすれば解決するでしょうか?

唯一したこと

6月26日から6月27日の間でしたことは、ほかの人のプロジェクトデータをもらい自分の方でそのままコンパイル、実行をした。その時のbuild.gradleでのimplementationで記述されているバージョンはいつも使っているバージョンのものとは違うものをコンパイルし実行した。

build.gradle

apply plugin: 'com.android.application'

android {
    compileSdkVersion 27
    defaultConfig {
        applicationId "自分のところのパッケージ"
        minSdkVersion 15
        targetSdkVersion 27
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    implementation 'com.android.support:appcompat-v7:27.1.1'//←ここの部分がエラーとなる
    implementation 'com.android.support.constraint:constraint-layout:1.1.2'
    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.android.support.test:runner:1.0.2'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'

    // ここから下を追加
    implementation 'com.google.android.gms:play-services-auth:15.0.1'
    implementation 'pub.devrel:easypermissions:0.1.5'
    implementation('com.google.api-client:google-api-client-android:1.22.0') {
        exclude group: 'org.apache.httpcomponents'
    }
    implementation('com.google.apis:google-api-services-sheets:v4-rev10-1.22.0') {
        exclude group: 'org.apache.httpcomponents'
    }
}

エラー部分

All com.android.support libraries must use the exact same version specification (mixing versions can lead to runtime crashes). Found versions 27.1.1, 26.1.0. Examples include com.android.support:animated-vector-drawable:27.1.1 and com.android.support:support-media-compat:26.1.0 less... (Ctrl+F1) 
There are some combinations of libraries, or tools and libraries, that are incompatible, or can lead to bugs. One such incompatibility is compiling with a version of the Android support libraries that is not the latest version (or in particular, a version lower than your targetSdkVersion).

環境

・Windows10
・Android Studio3.1.3
・AndroidSDKTools 26.1.1

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

一つのアプリケーション内で読み込まれるサポートライブラリー(com.android.supportに属するライブラリー)は全て同じバージョンでなくてはならないのですが、異なるバージョンに依存しているライブラリーが存在するために問題が生じているようです。Terminalを開いて

> gradlew :app:dependencies

と入力すると、ライブラリーの依存関係を表示することができます。dependenciesを質問と同じ構成にして調べてみると、以下のようになっていました(一部だけ抜き出し)。

+--- com.google.android.gms:play-services-auth:15.0.1
|    +--- com.google.android.gms:play-services-auth-api-phone:[15.0.1,16.0.0) -> 15.0.1
|    |    +--- com.google.android.gms:play-services-base:[15.0.1,16.0.0) -> 15.0.1
|    |    |    +--- com.google.android.gms:play-services-basement:[15.0.1] -> 15.0.1
|    |    |    |    \--- com.android.support:support-v4:26.1.0

これから見ると、play-services-auth:15.0.1が、support-v4:26.1.0に依存しているのが原因のようです。これを改めてsupport-v4:27.1.1を参照してもらうようにするために、build.gradleのdependenciesに

dependencies {
    // 他は略
    implementation 'com.android.support:support-v4:27.1.1'
}

と1行追加することで回避できないでしょうか。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/06/28 09:57

    回答ありがとうございます。わかりやすい説明で実際にコーディングしたら赤線のエラーはなくなりました。しかし、アプリが起動後、すぐ強制終了してしまう現象は治りませんでした。別のことが原因であるとわかりました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Android

    6513questions

    Androidは、Google社が開発したスマートフォンやタブレットなど携帯端末向けのプラットフォームです。 カーネル・ミドルウェア・ユーザーインターフェイス・ウェブブラウザ・電話帳などのアプリケーションやソフトウェアをひとつにまとめて構成。 カーネル・ライブラリ・ランタイムはほとんどがC言語/C++、アプリケーションなどはJavaSEのサブセットとAndroid環境で書かれています。

  • Android Studio

    3694questions

    Android Studioは、 Google社によって開発された、 Androidのネイティブアプリケーション開発に特化した統合開発ツールです。