質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.34%

  • R

    347questions

    R言語は、「S言語」をオープンソースとして実装なおした、統計解析向けのプログラミング言語です。 計算がとても速くグラフィックも充実しているため、数値計算に向いています。 文法的には、統計解析部分はS言語を参考にしており、データ処理部分はSchemeの影響を受けています。 世界中の専門家が開発に関わり、日々新しい手法やアルゴリズムが追加されています。

Rをバージョンアップしたらうまく動かなくなってしまいました…。

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 276

hacosato

score 26

Rをバージョンアップしたらうまく動かなくなってしまいました…。

macOS High Sierra 10.13.4
R 3.5.0
RStudio 1.1.453

R.appを起動すると赤字で以下のように表示されます。

 起動準備中です -  警告メッセージ: 
 doTryCatch(return(expr), name, parentenv, handler) で: 
   共有ライブラリ '/Library/Frameworks/R.framework/Resources/modules//R_X11.so' を読み込めません: 
  dlopen(/Library/Frameworks/R.framework/Resources/modules//R_X11.so, 6): Library not loaded: /opt/X11/lib/libcairo.2.dylib
  Referenced from: /Library/Frameworks/R.framework/Resources/modules//R_X11.so
  Reason: Incompatible library version: R_X11.so requires version 11403.0.0 or later, but libcairo.2.dylib provides version 11203.0.0 

ターミナルでbrew upgrade rすると

Error: r 3.5.0_1 already installed


ってなりました。

一応起動はできるようなのですが、ライブラリがないみたいです。
インストールし直してみましたが、うまく動きません…。

libcairo.2.dylibのバージョンを上げる必要があるのかと思いますが、わかりませんでした…。

お力いただけると幸いです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • hacosato

    2018/06/16 11:13

    すみません、XQuartz.app起動してみたところバージョンアップの通知が来ていまして、上げてみたところ、R.appもエラーなしで起動するようになりました! バージョンは2.7.11です。CUIばっかりに気を取られていました…。Xcode 9.4.1とCommand Line Toolsも新しいバージョン来てると気づいたんですが、これも上げてしまっていいものでしょうか? どうもありがとうございました〜〜!

    キャンセル

  • fiwa

    2018/06/17 01:51

    使いたい環境は人によって違うので一概に言えませんが、Xcode や Command Line Tools は High Sierra なら同じ ver. 9系でしょうから大した問題は起きないとは思いますが。ご自身の判断でどうぞ。Xcode のアップデートは大容量になりますので回線の状態が良いところでのダウンロードをお勧めします。

    キャンセル

  • hacosato

    2018/06/17 10:19

    ありがとうございます!

    キャンセル

回答 1

check解決した方法

0

/Applications/Utilities/XQuartz.app
を最新のバージョンに更新しました!

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/06/17 10:22

    追記・修正依頼のかたちでアドバイスいただきました! ありがとうございます。

    キャンセル

同じタグがついた質問を見る

  • R

    347questions

    R言語は、「S言語」をオープンソースとして実装なおした、統計解析向けのプログラミング言語です。 計算がとても速くグラフィックも充実しているため、数値計算に向いています。 文法的には、統計解析部分はS言語を参考にしており、データ処理部分はSchemeの影響を受けています。 世界中の専門家が開発に関わり、日々新しい手法やアルゴリズムが追加されています。