質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.76%

  • Ruby

    7035questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6749questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 5

    1299questions

[Ruby on Rails]rake db:createでLoadError: cannot load such file -- sqlite3/sqlite3_native

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 126

nayaka

score 12

 前提

rubyonrailsの環境構築を勉強しています。
こちらを参照しています。「coffee-cupさんのサイト」
windows10 ×64
rubyインストール
mysys2を使いました
[こちらを参照しました。Qiita「RubyInstaller2でWindows環境にRuby 2.4 + Rails 5.0.2をインストールする」](RubyInstaller2でWindows環境にRuby 2.4 + Rails 5.0.2をインストールする)
railsインストール
gem update --system
gem install bundler
Sqlite Browserのインストール
Bootstrapの導入
bootstrapの導入はこちらを参照しました。Qiita「Railsアプリで Bootstrap 4 を利用する」
gem update --system
gemは正常に終了しました。
rails new myapp

 発生している問題・エラーメッセージ

rake db:createと打ったところ、

rake aborted!
LoadError: cannot load such file -- sqlite3/sqlite3_native
C:/Users/myapp/config/application.rb:7:in <top (required)>' C:/Users/myapp/Rakefile:4:in require_relative'
C:/Users/myapp/Rakefile:4:in `<top (required)>'

Caused by: LoadError: cannot load such file -- sqlite3/2.5/sqlite3_native C:/Users/myapp/config/application.rb:7:in <top (required)>' C:/Users/myapp/Rakefile:4:in require_relative' C:/Users/myapp/Rakefile:4:in `<top (required)>'
(See full trace by running task with --trace)
とエラー表示されます。
そのようなローカルファイルはロードできない、というのは上記ファイルの<>のところを削除すれば良いのでしょうか?
初歩的な質問で、大変大変申し訳ございません。
かれこれ半日悩んでおります。
どうぞよろしくお願いいたします。

 試したこと

①SqliteBrowserでOpen Databaseをクリックし、myappのdbを開いても、sqlite3は見つかりませんでした。
②gem list sqlite3で確認すると、
* LOCAL GEMS *
sqlite3 (1.3.13 x64-mingw32)
と表示されます。
③sqlite3本体をダウンロードしました。
しかし、依然として同じエラーメッセージが表示されます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

以下のサイトにある内容を試してみてはどうでしょう。gemだけでなくsqlite3本体が必要なのだと思われます。

【補足】

MySQLとmysql2、PostgreSQLとpgのようにsqlite3のgemはsqlite3データベースに接続するためのライブラリで、sqlite3データベース本体は別途インストールする必要があるのでしょう。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/06/12 14:29 編集

    早速のご返答ありがとうございます。
    DevKitに相当するMSYS2なので、その辺は要らないのかな、と思ってました。
    https://qiita.com/jnchito/items/08b5be458134073c60e3
    Qiita「RubyInstaller2でWindows環境にRuby 2.4 + Rails 5.0.2をインストールする」を参照し、進めました。すいません。
    sqlite3本体を入れましたが、同じエラーメッセージが出てしまいます。
    https://teratail.com/questions/44920
    この質問者さまと同じように、ruby2.2系にしないといけないのでしょうか?

    キャンセル

check解決した方法

0

Ruby on Railsをcdから、rails s をした時にsqlite3_nativeがないため、エラー返します。また、sqlite3_nativeを入れても解決できません。
の質問者さまと同じような症状でしたので、ruby2.2系にしないとダメなのか?と思いましたが、
回答者「t-kuroda」さまが書かれていたように、

$ gem uninstall -a sqlite3
$ gem install sqlite3 --platform=rubyコード


としたら上手くいきました。
多くの方々に、お時間とらせてしまい申し訳ございません。
ホントにありがとうございました。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.76%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7035questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6749questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 5

    1299questions