質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.76%

  • PHP

    19224questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • Laravel 5

    1698questions

    Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

  • Vagrant

    1118questions

    Vagrantは、VirtualBox上の仮想マシンを コマンドラインから作成してくれるソフトウェアです。 ビルド環境など容易に構築が可能です。

Laravelでcomposer requireがエラーとなる

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 150

kenny_sayama

score 941

 環境

  • PHP7.0.27
  • Laravel 5.4.35
  • Vagrant

 起きているエラー

composer require barryvdh/laravel-debugbarコマンドを実行すると以下のようなエラーが出てしまいます。

Using version ^3.1 for barryvdh/laravel-debugbar
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
    - Conclusion: don't install barryvdh/laravel-debugbar v3.1.5
    - Conclusion: don't install barryvdh/laravel-debugbar v3.1.4
    - Conclusion: don't install barryvdh/laravel-debugbar v3.1.3
    - Conclusion: don't install barryvdh/laravel-debugbar v3.1.2
    - Conclusion: don't install barryvdh/laravel-debugbar v3.1.1
    - Conclusion: remove laravel/framework v5.4.35
    - Installation request for barryvdh/laravel-debugbar ^3.1 -> satisfiable by barryvdh/laravel-debugbar[v3.1.0, v3.1.1, v3.1.2, v3.1.3, v3.1.4, v3.1.5].
    - Conclusion: don't install laravel/framework v5.4.35
    - barryvdh/laravel-debugbar v3.1.0 requires illuminate/session 5.5.x -> satisfiable by illuminate/session[v5.5.0, v5.5.16, v5.5.17, v5.5.2, v5.5.28, v5.5.33, v5.5.34, v5.5.35, v5.5.36, v5.5.37, v5.5.39, v5.5.40].
    - don't install illuminate/session v5.5.0|don't install laravel/framework v5.4.35
    - don't install illuminate/session v5.5.16|don't install laravel/framework v5.4.35
    - don't install illuminate/session v5.5.17|don't install laravel/framework v5.4.35
    - don't install illuminate/session v5.5.2|don't install laravel/framework v5.4.35
    - don't install illuminate/session v5.5.28|don't install laravel/framework v5.4.35
    - don't install illuminate/session v5.5.33|don't install laravel/framework v5.4.35
    - don't install illuminate/session v5.5.34|don't install laravel/framework v5.4.35
    - don't install illuminate/session v5.5.35|don't install laravel/framework v5.4.35
    - don't install illuminate/session v5.5.36|don't install laravel/framework v5.4.35
    - don't install illuminate/session v5.5.37|don't install laravel/framework v5.4.35
    - don't install illuminate/session v5.5.39|don't install laravel/framework v5.4.35
    - don't install illuminate/session v5.5.40|don't install laravel/framework v5.4.35
    - Installation request for laravel/framework (locked at v5.4.35, required as 5.4.*) -> satisfiable by laravel/framework[v5.4.35].

 試してみたこと

バージョンの差異なのかと思い、composer.jsonに以下を追記

"config": {
  "preferred-install": "dist",
  "sort-packages": true,
  "optimize-autoloader": true,
  "platform": {
    "php": "7.0.27"
  }
}

ご助言いただけますと幸いです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

composer require barryvdh/laravel-debugbar:~2.4で試してみてください。
最新バージョンがv5.4.35に対応していない可能性が高いです。
https://github.com/barryvdh/laravel-debugbar#user-content-for-laravel--55-please-use-the-24-branch

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/05/28 17:52

    まさにその通りでした!
    回答いただきありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.76%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • PHP

    19224questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • Laravel 5

    1698questions

    Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

  • Vagrant

    1118questions

    Vagrantは、VirtualBox上の仮想マシンを コマンドラインから作成してくれるソフトウェアです。 ビルド環境など容易に構築が可能です。