質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.04%

rubyのバージョンアップ後、debug系のgemでLoadErrorが起こる

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,833

score 26

Rubyのバージョンを1.9.3-p551にしたところ、
下記のようなエラーが発生しました。
自分なりに試してみましたがうまくいかず、困っています。
ちなみに同じGemfileを使用している開発メンバーは何も問題が起きていません。

どなたかアドバイスいただけないでしょうか?

<発生する箇所>
  • rails console 起動時(bundle execを付けて起動)
  • unicorn起動時

<エラー内容>
console、unicorn共に下記のエラーが発生します。
※APP_ROOT=Railsアプリケーションのルートディレクトリです。
APP_ROOT/vendor/bundle/ruby/1.9.1/gems/activesupport-3.0.20/lib/active_support/dependencies.rb:242:in `require': APP_ROOT/vendor/bundle/ruby/1.9.1/gems/ruby-debug-base19-0.11.25/lib/ruby_debug.so: undefined symbol: ruby_threadptr_data_type - APP_ROOT/vendor/bundle/ruby/1.9.1/gems/ruby-debug-base19-0.11.25/lib/ruby_debug.so (LoadError)

<実施内容>
  • vendor/bundle以下にgemをインストールしていたので、vendor/bundle内にあるgemディレクトリを削除し、再度bundle installを実施。
⇒解決できず

  • gem cleanupを実施
⇒解決できず

  • Gemfileから「ruby-debug19」をコメントアウト
⇒起動するようになる

<最終的な目標>
「ruby-debug19」もインストールした状態で、consoleやunicornを使える状態にしたい。

どうか、よろしくお願いいたします。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

ruby-debug19ではなくdebuggerを使って解決しました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

ruby 1.9 系を利用するのは必須でしょうか? 2.x 系を使えない理由があるのでしょうか?

- Ruby 1.9.3 のサポート終了について   https://www.ruby-lang.org/ja/news/2015/02/23/support-for-ruby-1-9-3-has-ended/
...
本日 (2015年2月23日) をもって Ruby 1.9.3 のすべてのサポートが終了しました。 今後、新しいバージョンの Ruby で行われたバグ修正やセキュリティ修正は、1.9.3 にバックポートされません。
...
できるだけすぐに Ruby 2.0.0 以上にアップグレードすることを、われわれは強く推奨します。
...

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/07/07 09:38

    Railsのバージョンの関係でまだ2.X系に上げられないのです…。すみません。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.04%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る