質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.77%

  • Ruby

    7060questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6757questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Vagrant

    1120questions

    Vagrantは、VirtualBox上の仮想マシンを コマンドラインから作成してくれるソフトウェアです。 ビルド環境など容易に構築が可能です。

bundle installが出来ない

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 211

Piesuke

score 8

railsの環境構築をしようとしています。

bundle installを行ったのですが、

[!] There was an error parsing `Gemfile`: compile error - syntax error, unexpected ':', expecting $end
gem 'therubyracer',platforms: :ruby
                             ^. Bundler cannot continue.

 #  from /vagrant/project/Gemfile:19
 #  -------------------------------------------
 #  # See https://github.com/rails/execjs#readme for more supported runtimes
 >  gem 'therubyracer',platforms: :ruby
 #  
 #  -------------------------------------------


というエラーが出ました。
Gemfileを見てみても、特に文法上のエラーは見つからず、therubyracerのエラーだと思い、
http://l-light-note.hatenablog.com/entry/2014/09/17/134807
に従って色々試してみましたが、結果は変わりません。
改善策を教えてください。

【追記】
rubyはデフォルトでインストールされているものです。
Gemfile全文↓

source 'https://rubygems.org'

git_source(:github) do |repo_name|
  repo_name = "#{repo_name}/#{repo_name}" unless repo_name.include?("/")
  "https://github.com/#{repo_name}.git"
end

# Bundle edge Rails instead: gem 'rails', github: 'rails/rails'
gem 'rails', '~> 5.1.5'
# Use sqlite3 as the database for Active Record
gem 'sqlite3'
# Use Puma as the app server
gem 'puma', '~> 3.7'
# Use SCSS for stylesheets
gem 'sass-rails', '~> 5.0'
# Use Uglifier as compressor for JavaScript assets
gem 'uglifier', '>= 1.3.0'
# See https://github.com/rails/execjs#readme for more supported runtimes
gem 'therubyracer', platforms: :ruby

# Use CoffeeScript for .coffee assets and views
gem 'coffee-rails', '~> 4.2'
# Turbolinks makes navigating your web application faster. Read more: https://github.com/turbolinks/turbolinks
gem 'turbolinks', '~> 5'
# Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
gem 'jbuilder', '~> 2.5'
# Use Redis adapter to run Action Cable in production
# gem 'redis', '~> 4.0'
# Use ActiveModel has_secure_password
# gem 'bcrypt', '~> 3.1.7'

# Use Capistrano for deployment
# gem 'capistrano-rails', group: :development

group :development, :test do
  # Call 'byebug' anywhere in the code to stop execution and get a debugger console
  gem 'byebug', platforms: [:mri, :mingw, :x64_mingw]
  # Adds support for Capybara system testing and selenium driver
  gem 'capybara', '~> 2.13'
  gem 'selenium-webdriver'
end

group :development do
  # Access an IRB console on exception pages or by using <%= console %> anywhere in the code.
  gem 'web-console', '>= 3.3.0'
  gem 'listen', '>= 3.0.5', '< 3.2'
  # Spring speeds up development by keeping your application running in the background. Read more: https://github.com/rails/spring
  gem 'spring'
  gem 'spring-watcher-listen', '~> 2.0.0'
end

# Windows does not include zoneinfo files, so bundle the tzinfo-data gem
gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]

gem 'sass'
gem 'unicorn'
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • asm

    2018/04/18 12:31

    rubyはデフォルトでインストールされてるものでしょうか? Gemfile全文出せますでしょうか

    キャンセル

  • Piesuke

    2018/04/18 16:11

    追記したしました

    キャンセル

回答 2

check解決した方法

0

rubyを入れた時と同じ階層にいき、gem でbundleをインストールするとbundlerのrubyのバージョンがアップデートされ、無事解決しました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux]
にてインストールできる事を確認しました。

ハッシュのキーがシンボル時の記法が導入されたのが1.9だった筈なので
おそらく、Rubyが古いです。
rbenv+ruby-build等を利用して2.4以上を導入しましょう。


別解としては
gem 'therubyracer', :platforms => :rubyに書き換える

therubyracerのインストールは諦めてnode.jsをインストールする

等が考えられます。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/04/18 21:33

    rubyの2.5.0を導入して、bundle installしましたが同じエラーがでました。
    ruby -vを実行しても
    ruby 2.5.0p0 (2017-12-25 revision 61468) [x86_64-linux]
    と出るので、アップデートは成功していると思うのですが...

    キャンセル

  • 2018/04/18 22:14

    which bundle でbundleコマンドの場所を確認した場合ruby2.5.0のインストール先以下のものでしょうか?

    キャンセル

  • 2018/04/18 22:23

    いや、違います
    rubyより下の階層にあったら良いということでしょうか?

    キャンセル

  • 2018/04/18 22:44

    失礼しました。
    rbenv環境下だと .rbenv/shims/bundleになるんですね

    bundle env

    Ruby 2.5.0p0 (2017-12-25 revision 61468) [x86_64-linux]
    が確認できますか?

    キャンセル

  • 2018/04/18 22:57

    bundle envでもGemfileのエラーが出ます。

    キャンセル

  • 2018/04/18 23:05

    Gemfileないとこでも呼べますよ

    キャンセル

  • 2018/04/18 23:09

    ここではRubyのバージョン1.8.3になってます。
    なぜなのでしょうか?

    キャンセル

  • 2018/04/19 00:36 編集

    さて、なぜなのだろうね
    私が想像できる理由は2つ
    ruby2.5.0のセットアップが不十分
    デフォルトのruby1.8.3のbundlerが2.5.0のbundlerよりも優先されている
    まぁ、どちらかだと思うよ

    gem env が ruby2.5.0 になってるなら「gem i bundler」で直りそうな気がする

    キャンセル

  • 2018/04/19 02:03

    gem env がruby2.5.0になってたので、gem i bundler をしましたが結果は同じでした

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.77%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7060questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6757questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Vagrant

    1120questions

    Vagrantは、VirtualBox上の仮想マシンを コマンドラインから作成してくれるソフトウェアです。 ビルド環境など容易に構築が可能です。