質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.96%

Railsサーバーが起動しない

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 10K+

jaaaaack

score 36

Railsで

rails new rails_project


を使ってプロジェクトを作成し、

rails s


で起動すると

Could not find gem 'uglifier (>= 1.3.0)' in any of the gem sources listed in your Gemfile. Run 'bundle install' to install missing gems.

というエラーがでてしまい、Railsを起動させることができません。
どのようにすればこのエラーを修正することができるのでしょうか。

rubyのバーションは2.3.3
railsのバージョンは5.1.6
gemのバージョンは2.5.2

を使用しています。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+2

まずは,当該ディレクトリーで

bundle install

を試してみてください。
これは,そのディレクトリーの Gemfile(そのアプリで必要とする gem たちの情報が書かれたファイル)に従って,gem をインストールし,Gemfile.lock(そのアプリで使うことになった gem たちの実際のバージョンが書かれたファイル)を生成するコマンドです。

そのあとでもう一度 rails s をやってみてください。

もっとも,-B オプションを付けずに 

rails new rails_project

とやった場合,bundle install も自動的に行われるはずなので,質問に書かれた手順どおりなら,改めて bundle install する必要はないはずなのですが。

それから,

gem list uglifier

の結果も教えてください。

なお,ご質問の問題とはおそらく無関係ですが,RubyGems のバージョンが 2.5.2  なのはちょっと古いと思うので,

gem update --system

とやって,最新にしておきましょう。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/04/01 12:20

    回答ありがとうございます。
    ```
    gem list uglifier
    ```
    と入力したところ
    *** LOCAL GEMS ***
    と表示されるだけでした。

    キャンセル

  • 2018/04/01 12:26

    ということは,uglifier という gem はインストールされていない,というわけですね。
    これ自体は,
    gem install uglifier
    とやれば解決しますが,saida_nishida さんのご回答への返答を見ると,sqlite3 gem のインストールでコケているようですね。

    キャンセル

  • 2018/04/01 15:32

    https://qiita.com/YakibutaMegane/items/17377feedc7bf9b8c5e8
    のサイトを参考にして、Ruby on Rails環境構築をやってみたらRailsが動きました。
    ご回答ありがとうございます。

    キャンセル

+1

bundle install
bundle update


を実行してみてください。
多分違うエラーメッセージがでるはずなんでそれを教えてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/04/01 12:30

    osは
    macOS High Sierra バージョン10.13.3
    を使用しています。

    キャンセル

  • 2018/04/01 13:54

    そのように、〜〜をインストールしろとエラーがいくつかでてきます。
    支持に従って入れていくとエラーが解消します、何が不足しているかはエラーをみないとわからないので、これを3〜4回ほど繰り返すかもしれません。根気強く頑張ってください。
    エラーでもわからないものが出るかもしれません。その時またこちらにお願いします

    キャンセル

  • 2018/04/01 14:24

    sqlite3 gem のインストールに先立って,システムに SQLite3 の何かを入れておかないといけないのだと思いますが,私はそれについてよく知りません。

    ①teratail,Qiita,ウェブ検索などで「macOS で sqlite3 gem がインストールできない」に関する情報を調べるか(いっぱい出てくると思います),②「macOS で sqlite3 gem がインストールできない」というタイトルで改めて teratail に質問を立てるとよいかもしれません。

    ①の場合,古い情報もあるので,気をつけてくださいね。
    ②の場合は,OS の情報のほか,
    gem install sqlite3
    とやったときのエラーメッセージ(詳細)を添えて。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.96%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる