質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.12%

gemファイル cannot load such file

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 4,854

Koyyyyyy

score 49

jobca.rbというrubyファイルに
require 'selenium-webdriver'を1行目につけて'selenium-webdriver'というgemを読み込もうとしているのですが
/.rbenv/versions/2.3.1/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- selenium-webdriver (LoadError)

とこのファイルを実行するとエラーが出てしまい、実行することができません。
誰かアドバイスをくださるとありがたいです。ヽ(;▽;)ノ

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+1

selenium-webdriverのgemファイルをインストールしていないことによるものです。
ターミナル上でgem install selenium-webdriverを実施してから、スクリプトを実行してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/03/26 12:09

    なるほど!自分が勘違いしていることでした!自分はrequireをつければcdnみたいにそのgemをinstallしなくても使えるようになると思っていました!ここでinstallしたgemはどこに保存されたり、みれたりできるのですか

    キャンセル

  • 2018/03/26 12:12

    エラー文から、rbenvを使ってらっしゃると推測しますので、

    > ~/.rbenv/versions/2.3.1/lib/ruby/2.3.0/rubygems/

    以下にインストールされます。

    キャンセル

  • 2018/03/26 12:19

    なるほど!ありがとうございます!

    キャンセル

-4

cannot load such file をグーグル翻訳にかけてみますと、
「そのようなファイルを読み込めません」と出ます

kernel_require.rb というファイルの(おそらく)55行目にある(おそらく)`require'という名前のファイルがあるのか確認してみてはどうでしょうか

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/03/26 12:10

    rubyのエラーの読み方は、
    > kernel_require.rb:55:in `require': cannot load such file -- selenium-webdriver (LoadError)

    kernel_require.rb:55:「の」`require'「が」selenium-webdriver 「について」 cannot load such file 「である」

    と読みます。

    キャンセル

  • 2018/03/26 12:14

    ああ、そなんですか。
    ご教示、ありがとうございます

    キャンセル

  • 2018/03/27 00:12

    Rubyを触っている人であればよく見るエラーであり、Rubyを知っていればそのような完全に的が外れた回答はありえません。Rubyを触ったこともない、Rubyを全く知らないのに完全な憶測で答えているようにに思えます。ましてや、少しググればわかる程度のものでもあります。あまりにも的外れな回答は、質問者をただ混乱させるだけであり、良い行動とは決して思えません。あまりにも品質が低い回答ですので、低評価を入れさせていただきます。

    キャンセル

  • 2018/03/27 20:28

    y_waiwaiさんは安定の品質だなぁ…

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる