質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.97%

gem install ffi でエラーになってしまう

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,153

GenkiA

score 11

sudo gem install ffi -v '1.9.23'
で原因不明のエラーが起きてしまっています。

これまでに試したことは幾つかあり

$softwareupdate --install -a
$brew upgrade
$brew update

など試してみたのですが全く動かずエラーからも何をすればいいかがわからず丸一日費やしてしまい、こちらに質問させていただいております。

近いところで
sudo gem install -n /usr/local/bin sass
もやってみたのですが、結局ほぼおなじエラーメッセージが返ってくるだけで進歩がない状態です。

sudo gem install ffi -v '1.9.23'
Building native extensions. This could take a while...
ERROR:  Error installing ffi:
    ERROR: Failed to build gem native extension.

    current directory: /Users/NAME/.rvm/rubies/ruby-2.4.0/lib/ruby/gems/2.4.0/gems/ffi-1.9.23/ext/ffi_c
/Users/NAME/.rvm/rubies/ruby-2.4.0/bin/ruby -r ./siteconf20180306-14300-1yeut6m.rb extconf.rb
checking for ffi.h... no
checking for ffi.h in /usr/local/include,/usr/include/ffi... yes
checking for ffi_call() in -lffi... yes
checking for ffi_closure_alloc()... no
checking for ffi_raw_call()... no
checking for shlwapi.h... no
checking for rb_thread_blocking_region()... no
checking for rb_thread_call_with_gvl()... yes
checking for rb_thread_call_without_gvl()... yes
creating extconf.h
creating Makefile

current directory: /Users/NAME/.rvm/rubies/ruby-2.4.0/lib/ruby/gems/2.4.0/gems/ffi-1.9.23/ext/ffi_c
make "DESTDIR=" clean
/Users/NAME/.rvm/rubies/ruby-2.4.0/lib/ruby/site_ruby/2.4.0/rubygems.rb:289:in `find_spec_for_exe': can't find gem make (>= 0.a) with executable make (Gem::GemNotFoundException)
    from /Users/NAME/.rvm/rubies/ruby-2.4.0/lib/ruby/site_ruby/2.4.0/rubygems.rb:308:in `activate_bin_path'
    from /Users/NAME/.rvm/gems/ruby-2.4.0/bin/make:22:in `<main>'
    from /Users/NAME/.rvm/gems/ruby-2.4.0/bin/ruby_executable_hooks:15:in `eval'
    from /Users/NAME/.rvm/gems/ruby-2.4.0/bin/ruby_executable_hooks:15:in `<main>'

current directory: /Users/NAME/.rvm/rubies/ruby-2.4.0/lib/ruby/gems/2.4.0/gems/ffi-1.9.23/ext/ffi_c
make "DESTDIR="
/Users/NAME/.rvm/rubies/ruby-2.4.0/lib/ruby/site_ruby/2.4.0/rubygems.rb:289:in `find_spec_for_exe': can't find gem make (>= 0.a) with executable make (Gem::GemNotFoundException)
    from /Users/NAME/.rvm/rubies/ruby-2.4.0/lib/ruby/site_ruby/2.4.0/rubygems.rb:308:in `activate_bin_path'
    from /Users/NAME/.rvm/gems/ruby-2.4.0/bin/make:22:in `<main>'
    from /Users/NAME/.rvm/gems/ruby-2.4.0/bin/ruby_executable_hooks:15:in `eval'
    from /Users/NAME/.rvm/gems/ruby-2.4.0/bin/ruby_executable_hooks:15:in `<main>'

make failed, exit code 1

Gem files will remain installed in /Users/NAME/.rvm/rubies/ruby-2.4.0/lib/ruby/gems/2.4.0/gems/ffi-1.9.23 for inspection.
Results logged to /Users/NAME/.rvm/rubies/ruby-2.4.0/lib/ruby/gems/2.4.0/extensions/x86_64-darwin-16/2.4.0/ffi-1.9.23/gem_make.out

Brew doctorで確認したものは以下になります。

api $brew doctor
Please note that these warnings are just used to help the Homebrew maintainers
with debugging if you file an issue. If everything you use Homebrew for is
working fine: please don't worry or file an issue; just ignore this. Thanks!

Warning: "config" scripts exist outside your system or Homebrew directories.
`./configure` scripts often look for *-config scripts to determine if
software packages are installed, and what additional flags to use when
compiling and linking.

Having additional scripts in your path can confuse software installed via
Homebrew if the config script overrides a system or Homebrew provided
script of the same name. We found the following "config" scripts:
  /Users/NAME/anaconda/bin/libdynd-config
  /Users/NAME/anaconda/bin/python3.5m-config
  /Users/NAME/anaconda/bin/freetype-config
  /Users/NAME/anaconda/bin/xslt-config
  /Users/NAME/anaconda/bin/libpng16-config
  /Users/NAME/anaconda/bin/libpng-config
  /Users/NAME/anaconda/bin/xml2-config
  /Users/NAME/anaconda/bin/python3.5-config
  /Users/NAME/anaconda/bin/python3-config
  /Users/NAME/anaconda/bin/curl-config
  /Users/NAME/.pyenv/shims/libdynd-config
  /Users/NAME/.pyenv/shims/python3.5m-config
  /Users/NAME/.pyenv/shims/llvm-config
  /Users/NAME/.pyenv/shims/python2-config
  /Users/NAME/.pyenv/shims/python3.4m-config
  /Users/NAME/.pyenv/shims/python3.6m-config
  /Users/NAME/.pyenv/shims/python2.7-config
  /Users/NAME/.pyenv/shims/python3.5-config
  /Users/NAME/.pyenv/shims/python-config
  /Users/NAME/.pyenv/shims/python3-config
  /Users/NAME/.pyenv/shims/python3.6-config
  /Users/NAME/.pyenv/shims/python3.4-config
  /Users/NAME/.pyenv/shims/libpng15-config

Warning: Unbrewed dylibs were found in /usr/local/lib.
If you didn't put them there on purpose they could cause problems when
building Homebrew formulae, and may need to be deleted.

Unexpected dylibs:
  /usr/local/lib/libbitcoinconsensus.0.dylib
  /usr/local/lib/libportaudio.2.dylib

Warning: Unbrewed header files were found in /usr/local/include.
If you didn't put them there on purpose they could cause problems when
building Homebrew formulae, and may need to be deleted.

Unexpected header files:
  /usr/local/include/bitcoinconsensus.h
  /usr/local/include/portaudio.h

Warning: Unbrewed .la files were found in /usr/local/lib.
If you didn't put them there on purpose they could cause problems when
building Homebrew formulae, and may need to be deleted.

Unexpected .la files:
  /usr/local/lib/libbitcoinconsensus.la
  /usr/local/lib/libportaudio.la

Warning: Unbrewed .pc files were found in /usr/local/lib/pkgconfig.
If you didn't put them there on purpose they could cause problems when
building Homebrew formulae, and may need to be deleted.

Unexpected .pc files:
  /usr/local/lib/pkgconfig/libbitcoinconsensus.pc
  /usr/local/lib/pkgconfig/portaudio-2.0.pc

Warning: Unbrewed static libraries were found in /usr/local/lib.
If you didn't put them there on purpose they could cause problems when
building Homebrew formulae, and may need to be deleted.

Unexpected static libraries:
  /usr/local/lib/libbitcoinconsensus.a
  /usr/local/lib/libportaudio.a

Warning: You have unlinked kegs in your Cellar
Leaving kegs unlinked can lead to build-trouble and cause brews that depend on
those kegs to fail to run properly once built. Run `brew link` on these:
  numpy
  portaudio
  node
  git

Warning: /usr/bin occurs before /usr/local/bin
This means that system-provided programs will be used instead of those
provided by Homebrew. The following tools exist at both paths:
  idle
  easy_install
  pydoc
  python
  python-config
  git-cvsserver
  git-shell
  git-upload-pack
  tar
  git

Consider setting your PATH so that /usr/local/bin
occurs before /usr/bin. Here is a one-liner:
  echo 'export PATH="/usr/local/bin:$PATH"' >> ~/.bash_profile

Warning: Some keg-only formulae are linked into the Cellar.
Linking a keg-only formula, such as gettext, into the cellar with
`brew link <formula>` will cause other formulae to detect them during
the `./configure` step. This may cause problems when compiling those
other formulae.

Binaries provided by keg-only formulae may override system binaries
with other strange results.

You may wish to `brew unlink` these brews:
  openssl

よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • otn

    2018/03/07 13:14

    makeコマンドは実行できますか?

    キャンセル

  • GenkiA

    2018/03/08 10:53

    回答ありがとうございます。 戻って確認してみます。

    キャンセル

回答 1

0

失礼します。
以下のコマンドを実行してみればどうでしょうか。

make clean
make


もしくは,以下のコマンドを実行して見たらどうでしょうか。

gem update --system

わかりにくいところがあったら,申し訳ありません。
以上です。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.97%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる