質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

Laravel 5

Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

解決済

Laravel5.5のクライアント認証のためのパッケージがインストールできない

lkjgffh
lkjgffh

総合スコア0

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

Laravel 5

Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

1回答

0評価

0クリップ

1722閲覧

投稿2018/02/27 01:43

前提・実現したいこと

Laravel5.5でクライアント認証を実装しようとしています

発生している問題・エラーメッセージ

https://readouble.com/laravel/5.5/ja/passport.html
にあるようにcomposer require laravel/passportでパッケージをインストールしようとするとこのようなエラーが出ます

Your requirements could not be resolved to an installable set of packages. Problem 1 - Installation request for laravel/passport ^5.0 -> satisfiable by laravel/passport[v5.0.0]. - Conclusion: remove laravel/framework v5.5.35 - Conclusion: don't install laravel/framework v5.5.35 - laravel/passport v5.0.0 requires illuminate/http ~5.6 -> satisfiable by illuminate/http[v5.6.0, v5.6.1, v5.6.2, v5.6.3, v5.6.4, v5.6.5]. - don't install illuminate/http v5.6.0|don't install laravel/framework v5.5.35 - don't install illuminate/http v5.6.1|don't install laravel/framework v5.5.35 - don't install illuminate/http v5.6.2|don't install laravel/framework v5.5.35 - don't install illuminate/http v5.6.3|don't install laravel/framework v5.5.35 - don't install illuminate/http v5.6.4|don't install laravel/framework v5.5.35 - don't install illuminate/http v5.6.5|don't install laravel/framework v5.5.35 - Installation request for laravel/framework (locked at v5.5.35, required as 5.5.*) -> satisfiable by laravel/framework[v5.5.35].

該当のソースコード

composer.json

"require": { "php": ">=7.0.0", "asvae/laravel-api-tester": "^2.0", "doctrine/dbal": "^2.6", "fideloper/proxy": "~3.3", "laravel/framework": "5.5.*", "laravel/tinker": "~1.0" },

試したこと

don't install laravel/framework v5.5.35と合ったので "laravel/framework": "5.5.*",を削除してコンポーサーをアップデート下後再度パッケージのインストールを試しましたが結果同じエラーが出ました

こちらで質問されていることが似ている現象かと思い
https://github.com/dingo/api/issues/1076
"laravel/framework": "5.5.*",は削除せずに"phpdocumentor/reflection": "3.x@dev"を追記し下記のコマンドを実行しました
$ composer update
$ composer require dingo/api:1.0.x@dev

結果

Your requirements could not be resolved to an installable set of packages. Problem 1 - Conclusion: don't install dingo/api v1.0.0-beta8 - Conclusion: don't install dingo/api v1.0.0-beta7 - Conclusion: don't install dingo/api v1.0.0-beta6 - Conclusion: don't install dingo/api v1.0.0-beta5 - Conclusion: don't install dingo/api v1.0.0-beta4 - Conclusion: don't install dingo/api v1.0.0-beta3 - Conclusion: don't install dingo/api v1.0.0-beta2 - Conclusion: remove laravel/framework v5.5.35 - Conclusion: don't install dingo/api v1.0.0-beta8|remove phpdocumentor/reflection-docblock 2.0.5|install dingo/blueprint 0.2.2|install dingo/blueprint v0.2.0|install dingo/blueprint v0.2.1 - Conclusion: don't install dingo/api v1.0.0-beta8|don't install phpdocumentor/reflection-docblock 2.0.5|install dingo/blueprint 0.2.2|install dingo/blueprint v0.2.0|install dingo/blueprint v0.2.1 - Conclusion: don't install dingo/api v1.0.0-beta8|remove phpdocumentor/reflection-docblock 2.0.5|install dingo/blueprint 0.2.2|install dingo/blueprint v0.2.0|install dingo/blueprint v0.2.1 - Conclusion: don't install dingo/api v1.0.0-beta8|don't install phpdocumentor/reflection-docblock 2.0.5|install dingo/blueprint 0.2.2|install dingo/blueprint v0.2.0|install dingo/blueprint v0.2.1 - Installation request for phpdocumentor/reflection-docblock (locked at 2.0.5) -> satisfiable by phpdocumentor/reflection-docblock[2.0.5]. - Installation request for doctrine/annotations (locked at v1.6.0) -> satisfiable by doctrine/annotations[v1.6.0]. - Installation request for dingo/api 1.0.x@dev -> satisfiable by dingo/api[v1.0.0-beta1, v1.0.0-beta2, v1.0.0-beta3, v1.0.0-beta4, v1.0.0-beta5, v1.0.0-beta6, v1.0.0-beta7, v1.0.0-beta8]. - Conclusion: don't install laravel/framework v5.5.35 - dingo/api v1.0.0-beta1 requires illuminate/routing 5.1.* -> satisfiable by illuminate/routing[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.41, v5.1.6, v5.1.8]. - don't install illuminate/routing v5.1.1|don't install laravel/framework v5.5.35 - don't install illuminate/routing v5.1.13|don't install laravel/framework v5.5.35 - don't install illuminate/routing v5.1.16|don't install laravel/framework v5.5.35 - don't install illuminate/routing v5.1.2|don't install laravel/framework v5.5.35 - don't install illuminate/routing v5.1.20|don't install laravel/framework v5.5.35 - don't install illuminate/routing v5.1.22|don't install laravel/framework v5.5.35 - don't install illuminate/routing v5.1.25|don't install laravel/framework v5.5.35 - don't install illuminate/routing v5.1.28|don't install laravel/framework v5.5.35 - don't install illuminate/routing v5.1.30|don't install laravel/framework v5.5.35 - don't install illuminate/routing v5.1.31|don't install laravel/framework v5.5.35 - don't install illuminate/routing v5.1.41|don't install laravel/framework v5.5.35 - don't install illuminate/routing v5.1.6|don't install laravel/framework v5.5.35 - don't install illuminate/routing v5.1.8|don't install laravel/framework v5.5.35 - Installation request for laravel/framework (locked at v5.5.35, required as 5.5.*) -> satisfiable by laravel/framework[v5.5.35]. Installation failed, reverting ./composer.json to its original content.

これらのエラーはそれぞれのパッケージが合わずに出ているものなのでしょうか?
こういう風に変更すれば解決するのでは、と何か思い当たる節がある方いらっしゃいましたらご教授いただけませんでしょうか

または公式のクライアント認証実装方法以外で実装する方法などありますでしょうか?

補足情報(FW/ツールのバージョンなど)

PHP 7.2.0
Laravel Framework 5.5.35

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

Laravel 5

Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。