質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.37%

not-trunkingになってしまいます

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,361

score 128

環境

GNS3
イメージ説明

現状

PC-1←→PC-2間の疎通可

ip routingの設定有バージョンですと、異なるVLAN間でも疎通可(トランクリンク除く)

問題点

R1←→R2のトランクリンクの通信ができないです。
ステータスを確認すると2点、気になる箇所があります。
①Statusが「not-trunking」になってる点

R1#show int fa1/15 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa1/15    on           802.1q         not-trunking  1

Port      Vlans allowed on trunk
Fa1/15    none

Port      Vlans allowed and active in management domain
Fa1/15    none

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/15    none
R2#show int fa1/15 t

Port      Mode         Encapsulation  Status        Native vlan
Fa1/15    on           802.1q         not-trunking  1

Port      Vlans allowed on trunk
Fa1/15    none

Port      Vlans allowed and active in management domain
Fa1/15    none

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/15    none


②トランクリンクしたポートのProtocolがdownになってる点

R1#show ip int b

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet1/15           unassigned      YES unset  up                    down
R2#show ip int b

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet1/15           unassigned      YES unset  up                    down

その他ステータス

R1#show arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.2.254           -   c401.10cc.0000  ARPA   Vlan20
Internet  192.168.1.254           -   c401.10cc.0000  ARPA   Vlan10
R2#show arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.1.253           -   c402.1cac.0000  ARPA   Vlan10
Internet  192.168.2.253           -   c402.1cac.0000  ARPA   Vlan20
R1#show run
Building configuration...

Current configuration : 2008 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip icmp rate-limit unreachable
no ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
!
interface FastEthernet1/1
 switchport access vlan 10
!
interface FastEthernet1/2
 switchport access vlan 10
!
interface FastEthernet1/3
 switchport access vlan 20
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
 switchport trunk allowed vlan 1,2,10,20,1002-1005
 switchport mode trunk
!
interface Vlan1
 no ip address
 no ip route-cache
!
interface Vlan10
 ip address 192.168.1.254 255.255.255.0
 no ip route-cache
!
interface Vlan20
 ip address 192.168.2.254 255.255.255.0
 no ip route-cache
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
R2#show run
Building configuration...

Current configuration : 1981 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip icmp rate-limit unreachable
no ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
!
interface FastEthernet1/1
 switchport access vlan 10
!
interface FastEthernet1/2
 switchport access vlan 20
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
 switchport trunk allowed vlan 1,2,10,20,1002-1005
 switchport mode trunk
!
interface Vlan1
 no ip address
 no ip route-cache
!
interface Vlan10
 ip address 192.168.1.253 255.255.255.0
 no ip route-cache
!
interface Vlan20
 ip address 192.168.2.253 255.255.255.0
 no ip route-cache
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

わたしの設定の何がイケなかったのでしょうか(>_<)
GNS3のバグでしょうか('_')
何か分かる方いらっしゃいましたらご教授願います。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

問題解決しました。
原因はGNS3特有の仕様で、
トランクリンクの設定をしたポートを一度shutdownしてからno shutdownすることで
show int fa1/15 trunkのステータスがnot-trunkingからtrunkingに表示が変わり、
実際に疎通もできました。
むーん、GNS3にはこのような仕様が多々ありそうで大変です。
何かGNS3に代わるツールがあればいいのにナー('ω')

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.37%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る