質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.47%

  • Ruby

    9665questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • OpenCV

    1557questions

    OpenCV(オープンソースコンピュータービジョン)は、1999年にインテルが開発・公開したオープンソースのコンピュータビジョン向けのクロスプラットフォームライブラリです。

ruby で opencv を使うには・・・

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 986

Amateur

score 8

 前提・実現したいこと

ruby で opencv を使いたいです。
brew install opencv でインストールしましたが、
require 'opencv'をするとエラーが出てしまいます。

 発生している問題・エラーメッセージ

require

require 'opencv'


エラー

/usr/local/Cellar/ruby/2.4.2_1/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- opencv (LoadError)

 状況・状態

opencvはインストールできている

$ brew install opencv
Updating Homebrew...
==> Auto-updated Homebrew!
Updated 1 tap (homebrew/core).
==> Updated Formulae
tintin

Warning: opencv 3.4.0_1 is already installed

 試したこと

which opencv を実行しても、
何も表示されないので、パスを通す必要があるのかと思っているのですが、
どこにパスを通すべきなのか、わかりません。

 補足情報

gem install ruby-opencv ができていません。
with でディレクトリを指定しても同様のエラーが出ます。

$ gem install ruby-opencv 
uilding native extensions.  This could take a while...
ERROR:  Error installing ruby-opencv:
    ERROR: Failed to build gem native extension.

    current directory: /usr/local/lib/ruby/gems/2.4.0/gems/ruby-opencv-0.0.18/ext/opencv
/usr/local/opt/ruby/bin/ruby -r ./siteconf20180204-3252-17f30oh.rb extconf.rb
>> Check the required libraries...
checking for -lstdc++... yes
checking for -lopencv_calib3d... yes
checking for -lopencv_contrib... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
    --with-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/usr/local/Cellar/ruby/2.4.2_1/bin/$(RUBY_BASE_NAME)
    --with-opencv-dir
    --without-opencv-dir
    --with-opencv-include
    --without-opencv-include=${opencv-dir}/include
    --with-opencv-lib
    --without-opencv-lib=${opencv-dir}/lib
    --with-libxml2-dir
    --without-libxml2-dir
    --with-libxml2-include
    --without-libxml2-include=${libxml2-dir}/include
    --with-libxml2-lib
    --without-libxml2-lib=${libxml2-dir}/lib
    --with-stdc++lib
    --without-stdc++lib
    --with-opencv_calib3dlib
    --without-opencv_calib3dlib
    --with-opencv_contriblib
    --without-opencv_contriblib
extconf.rb:58:in `block in <main>': opencv_contrib not found. (RuntimeError)
    from extconf.rb:58:in `each'
    from extconf.rb:58:in `<main>'

To see why this extension failed to compile, please check the mkmf.log which can be found here:

  /usr/local/lib/ruby/gems/2.4.0/extensions/x86_64-darwin-16/2.4.0/ruby-opencv-0.0.18/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in /usr/local/lib/ruby/gems/2.4.0/gems/ruby-opencv-0.0.18 for inspection.
Results logged to /usr/local/lib/ruby/gems/2.4.0/extensions/x86_64-darwin-16/2.4.0/ruby-opencv-0.0.18/gem_make.out
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

ruby-opencvのインストールの際には、OpenCVの保存場所の指定が必要です(README)。

$ gem install ruby-opencv -- --with-opencv-dir=/path/to/opencvdir

あと、ruby-opencvはOpenCV 2系列専用のようです。現状、OpenCV 3に対応したバージョンはない模様です。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/02/04 17:52

    まずは、openCV 2系をインストールすることとします。

    ちなみにですが、下記を実行した際にもエラーが出ますが、
    current directory以下〜 とは何を示しているのでしょうか。

    $ gem install ruby-opencv -- -- with-opencv-dir=/usr/local/cellar
    uilding native extensions. This could take a while...
    ERROR: Error installing ruby-opencv:
    ERROR: Failed to build gem native extension.

    current directory: /usr/local/lib/ruby/gems/2.4.0/gems/ruby-opencv-0.0.18/ext/opencv
    ←もうすでにruby-opencvがインストールされているという意味でしょうか。
     まずは、2系をインストールしてからですが、同様のエラーがでそうなので・・・

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.47%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Ruby

    9665questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • OpenCV

    1557questions

    OpenCV(オープンソースコンピュータービジョン)は、1999年にインテルが開発・公開したオープンソースのコンピュータビジョン向けのクロスプラットフォームライブラリです。