質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.35%

  • Cisco

    104questions

    シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品

  • Cisco IOS

    33questions

HSRP障害試験 迂回されない

解決済

回答 4

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 1,721

narururu

score 40

環境

GNS3

イメージ説明

ステータス

R1#show run
Building configuration...

Current configuration : 1984 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip sla monitor 1
 type echo protocol ipIcmpEcho 192.168.1.1
 frequency 10
ip sla monitor schedule 1 life forever start-time now
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
 switchport access vlan 10
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
 no switchport
 ip address 10.0.0.1 255.255.255.0
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 192.168.0.253 255.255.255.0
 standby 10 ip 192.168.0.254
 standby 10 priority 105
 standby 10 preempt
 standby 10 track FastEthernet1/5
!
ip forward-protocol nd
ip route 192.168.1.0 255.255.255.0 10.0.0.2
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2 show run

R2#show run
Building configuration...

Current configuration : 1775 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
 switchport access vlan 10
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
 no switchport
 ip address 10.0.1.1 255.255.255.0
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 192.168.0.252 255.255.255.0
 standby 10 ip 192.168.0.254
!
ip forward-protocol nd
ip route 192.168.1.0 255.255.255.0 10.0.1.2
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R3 show run

R3#sho run
Building configuration...

Current configuration : 1981 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip sla monitor 2
 type echo protocol ipIcmpEcho 192.168.0.1
 frequency 10
ip sla monitor schedule 2 life forever start-time now
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
 switchport access vlan 20
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
 no switchport
 ip address 10.0.0.2 255.255.255.0
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
interface Vlan20
 ip address 192.168.1.253 255.255.255.0
 standby preempt
 standby 20 ip 192.168.1.254
 standby 20 priority 105
 standby 20 track FastEthernet1/5
!
ip forward-protocol nd
ip route 192.168.0.0 255.255.255.0 10.0.0.1
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R4 show run

R4#show run
Building configuration...

Current configuration : 1775 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
 switchport access vlan 20
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
 no switchport
 ip address 10.0.1.2 255.255.255.0
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
interface Vlan20
 ip address 192.168.1.252 255.255.255.0
 standby 20 ip 192.168.1.254
!
ip forward-protocol nd
ip route 192.168.0.0 255.255.255.0 10.0.1.1
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end


R1 show standby brief

R1#sho standby b
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Vl10        10  105  P Active   local           192.168.0.252   192.168.0.254


R2 show standby brief

R2#show standby b
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Vl10        10  100    Standby  192.168.0.253   local           192.168.0.254


R3 show standby brief

R3#show standby b
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Vl20        20  105    Active   local           192.168.1.252   192.168.1.254


R4 show standby brief

R4#show standby b
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Vl20        20  100    Standby  192.168.1.253   local           192.168.1.254

追記

全般的に質問事項を更新しました。
ip slaの設定を入れたので、R1とR3のshow runを更新しました。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 4

checkベストアンサー

0

頑張ってますね。
HSRPを理解するために、課題を作ってみました(^^
是非以下の構成にチャレンジしてみてください!

目的は記載したポイントで障害が発生してもPC-1⇔PC-2間は
迂回経路(10.0.1.0/24)を使って通信を継続できることです。
ルーティングは
スタティックルートだけでの構成
それがうまくいったら、eigrpやospfなどを使っても面白いかも。
これを理解して構築できたら、結構勉強になると思いますよ!
頑張ってください!

イメージ説明

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/02/04 14:18

    わあ、問題作って下さりありがとうございます☺

    頂いた構成で作ってみました。
    障害試験に入る前に、まずは、Activeの経路でPC間の疎通ができないとですね。
    現時点では、PC間の疎通はできていないですが、途中経過として報告します。
    質問事項は頂いた問題に対応し全般的に更新しました。

    キャンセル

  • 2018/02/04 14:45

    PC間の疎通、確認取れました!
    スタティックルートの設定してなかただけでした。
    これから障害試験やってみます!
    ケーブル障害は対象ポートをshutdownでシミュレーションしてみます。
    筐体障害は、機器をSTOPでシミュレーションしてみます。
    ちゃんと迂回されるかな。楽しみです☺

    キャンセル

  • 2018/02/04 16:14 編集

    むーん、①と②、③を試してみたのですが、PC間の疎通ができなくなってしまいました。
    HSRPはstandbyがActiveに切り替わってるのですが、pingすると
    *192.168.0.252 icmp_seq=2 ttl=255 time=8.020 ms (ICMP type:3, code:1, Destination host unreachable)
    と表示されてしまいます。
    この表示を見るとR2までは通信でき、その先には行けないようです。
    あ、そうか。R4がStandbyになっているからですね。
    vlan20のHSRPも検知させないとダメですね。
    その設定をしないといけないんですね。しかし、そのような設定方法があるのでしょうか。
    それとも何か勘違いしてますでしょうか。

    キャンセル

  • 2018/02/04 17:23

    >> むーん、①と②、③を試してみたのですが、PC間の疎通ができなくなってしまいました。

    障害試験をするときは、pingに加えてtracerouteを行うと経路の確認が行えて良いと思います。

    以下は解説ですが、RT1とRT2(及びRT3とRT4)に正しいスタティックルートが設定されている前提です。
     RT1 DST:192.168.1.0/24 NH:10.0.0.2
     RT2 DST:192.168.1.0/24 NH:10.0.1.2
     RT3 DST:192.168.0.0/24 NH:10.0.0.1
     RT3 DST:192.168.0.0/24 NH:10.0.1.1

    >> この表示を見るとR2までは通信でき、その先には行けないようです。
    ん?ルーティングが無いように見えますね。当方が想定する動きとしては以下です。
     ・RT2がACTルータになって副系の経路でRT4にパケットを転送
     ・RT4経由でpingを受け取ったPC-2は戻りのパケットをActルータであるRT3に投げる
     ・①の障害:RT1はRT3からパケットを受け取ってもSW1に繋がっていないので、
           192.168.0.0/24のルートが存在せず、パケットを廃棄して終わり。
     ・②、③の障害:RT3は192.168.0.0/24のNHであるRT1とのリンクがきれたため、
             パケットを転送できず、破棄して終わり。


    では、障害ポイントごとの解説と対応です。

    ①SW1⇔RT1間のケーブル障害
     RT1⇔RT2間でHSRPのhelloパケットを交換できなくなるので、
     RT2が自発的にActに切り替わるため、迂回経路へ行けますね。
     ※これはHSRPの基本動作なので簡単ですね。

    ②RT1の筐体障害
     これも動作としては①と同様です。

    ③RT1⇔RT3間のケーブル障害
    ④RT3の筐体障害
     ここからがポイントです。
     HSRP は、サブネット内で動作するプロトコルなので、同じルータであっても、他のサブネットの
     状況は関知しません。
     つまり、WAN側(10.0.0.0/24)より先で何が起きても、LAN側で動作しているHSRPへは影響せず、
     RT1はActのままです。
     このケースではRT1が自身のWAN側I/Fのダウンを検知して、HSRPのPriorityを下げることで自身が
     HSRPのStanにならなければなりません。(そしてRT2がActになる)
     そのためには、Ciscoの「インターフェーストラッキング」という機能を用います。

    ⑤SW2⇔RT3間のケーブル障害
     ③、④のケースと異なり、この障害はRT1自身のI/Fはリンクダウンしません。
     (③と④はいずれも発生することでRT1のWAN側I/Fがダウンする。)
     となると、このケースはRT3のLAN側障害を検知しなくてはなりませんね。
     そのためには、RT1が自身のWAN側I/F(10.0.0.1)からRT3のLAN側I/F(192.168.1.253)に対して
     定期的にPingを飛ばして、当該pingが不通になったら、自身のHSRPのPriorityを下げることで自身が
     HSRPのStanになる機能を使います。(そしてRT2がActになる)
     これも機能としてはトラッキングを使い名称としては「オブジェクトトラッキング」です。

     インターフェーストラッキングとオブジェクトトラッキングの説明。
     http://www.infraexpert.com/study/fhrpz04.html


    もちろん、これらの設定はRT3とRT4にも同様に設定が必要です。
    これらの動きを理解の上、設定してみてください!

    キャンセル

  • 2018/02/04 19:40

    ご回答ありがとうございます。
    HSRPの動き、理解しました。
    また、スタティックルートはご指摘いただいた通りの設定をしております。
    インターフェイストラッキングの設定も既にしてあります。
    ただし、オブジェクトトラッキングの設定はしておりませんでした。
    設定していきます。
    しかし、障害試験の前に正常時の疎通ができなくなってしまいました。
    【PC-1→PC-2】
    PC-1> trace 192.168.1.1
    trace to 192.168.1.1, 8 hops max, press Ctrl+C to stop
    1 * * *
    2 * * *
    3 * * *
    4 * * *
    5 * * *
    6 * * *
    7 * * *
    8 * * *
    【PC-2→PC-1】
    PC-2> trace 192.168.0.1
    trace to 192.168.0.1, 8 hops max, press Ctrl+C to stop
    1 192.168.1.253 34.090 ms 16.042 ms 16.043 ms
    2 10.0.0.1 53.141 ms 75.200 ms 57.152 ms
    3 * * *
    4 * * *
    5 * * *
    6 * * *
    7 * * *
    8 * * *
    一度GNS3を閉じて再開してから疎通ができなくなってしまいました。GNS3の仕様であるvlan 消える現象については改めて作成したので問題ないはずです。また、質問のステータスに記載したshow runの結果と比較したところ差分はありませんでした。よって、只今トラブルシューティング中です。R1とSW1に問題がありそうなんですが、何が原因かわからずです。なかなか課題に進めず申し訳ございません。

    キャンセル

  • 2018/02/04 19:44

    ゆっくりやってください😁
    GNS3の再起動でPCのIPアドレスも消えませんでしたっけ?

    キャンセル

  • 2018/02/04 19:48

    ありがとうございます。
    PCのIPアドレスも消えますが、再度設定してあります。

    キャンセル

  • 2018/02/04 19:54

    因みに、PC-1←→R1間は疎通でき、PC-1←→R3になると疎通できません。

    キャンセル

  • 2018/02/04 20:23

    show arp
    show int(I/Fカウンタの上昇でパケット到着成否を確認)
    Wiresharkでパケットキャプチャ(GNS3でも使える)

    などを駆使して疎通を確認してみてください!

    キャンセル

  • 2018/02/04 20:45

    アドバイスありがとうございます!
    ゆっくり調べてみます。
    Wiresharkの使い方や見方も調べて使いこなせるようにならないとですね。

    キャンセル

  • 2018/02/05 20:31

    再起動しましたら、正常時の疎通はできました。
    原因はわかりません。
    障害試験に向けて、R1にオブジェクトトラッキングの設定としてip slaを入れました。(GNS3特有のコマンドでした)
    しかし、R1のfa1/2のshutdownやfa1/5のshutdownをして迂回されませんでした。

    そこで、分けてpingをしてみましたところ以下のような結果となりました。
    R2→R4 疎通できる。
    R4→PC-2 疎通できる。
    R2→PC-2 疎通できない。
    つまり、そもそも迂回路の疎通ができな状態でした。
    スタティックルートの設定をR2とR4で入れており、疎通できるはずだと思うので不思議です。
    他の構成の練習もしながら、原因を探っていこうと思います。

    キャンセル

  • 2018/02/06 14:33 編集

    >> しかし、R1のfa1/2のshutdownやfa1/5のshutdownをして迂回されませんでした。
    理由は後述します。(fa1/5のshutなら迂回できると思うので、そこだけ不可解です。)

    また、Config確認しました。修正が必要そうです。

    ■R1(R3も同様)
    >> ip sla monitor 1
    >> type echo protocol ipIcmpEcho 192.168.1.1
    これは変です。正系のNW障害を検知する機構なので、
    slaの飛ばし先はPCでなく、192.168.1.253(R3 VLAN20)となるべきです。
    また、trackを新規作成してこのslaと紐付けなければならないのですが、
    その設定も見当たらないです。

    >> interface Vlan10
    >> ip address 192.168.0.253 255.255.255.0
    >> standby 10 ip 192.168.0.254
    >> standby 10 priority 105
    >> standby 10 preempt
    >> standby 10 track FastEthernet1/5
    trackで、Fa1/5(正系回線)のリンク状態は監視できてますが、
    ip sla1を設定したtrackも設定する必要があります。

    以上を踏まえた修正Configは下記です。

    ■修正Config
    ・R1
    conf t
    !
    ip sla monitor 1
    no type echo protocol ipIcmpEcho 192.168.1.1
    type echo protocol ipIcmpEcho 192.168.1.253
    exit
    !
    track 1 rtr 1 reachability
    delay down 10
    exit
    !
    interface Vlan10
    standby 10 track 1 decrement 10
    exit
    !
    end

    ・R3
    conf t
    !
    ip sla monitor 1
    no type echo protocol ipIcmpEcho 192.168.0.1
    type echo protocol ipIcmpEcho 192.168.0.253
    exit
    !
    track 1 rtr 1 reachability
    delay down 10
    exit
    !
    interface Vlan10
    standby 10 track 1 decrement 10
    exit
    !
    end


    ■疑問への回答(たぶんあってる,,,)
    >> つまり、そもそも迂回路の疎通ができな状態でした。
    いいえ、Configを見る限り迂回経路のルートは通っていると思います。


    >> R2→R4 疎通できる。
    はい。connectedルーティングを持っているのでそうです。

    >> R4→PC-2 疎通できる。
    はい。同セグ通信なので、HSRP関係ないので、通信できるでしょう。
    アドレスとしては下記です。普通のarpで通信できます。
     192.168.1.252⇔192.168.1.1

    >> R2→PC-2 疎通できない。
    はい。たぶんそれで正解です。(異常ではない)
    正系が生きている前提で話します。
    前述の内容からR2(たぶんソースアドレスは10.0.1.1)からPC2への行きは通るはずです。
    しかし、戻りの通信でDstは10.0.1.0になるはずなので、別セグ通信です。
    PC-2は別セグ通信なので、自身のデフォルトGW(=HSRP:192.168.1.254)宛てにパケットを投げます。
    そのパケットを受け取るのはActルータとなるR3です。
    R3は10.0.1.0/24へのルートを持っていないので、パケットを破棄して終わってるのではないでしょうか。
    なので、R2からPC-2へpingする際のソースアドレスを192.168.0.252に設定すれば取りあえずは帰ってくると思います。


    以上です。
    修正Config投入で迂回できないでしょうか。

    キャンセル

  • 2018/02/06 14:41

    因みに以下の疑問についても回答します。
    >> しかし、R1のfa1/2のshutdownやfa1/5のshutdownをして迂回されませんでした。
    Config修正前の状態ですと、R3はR1のfa1/2のダウンを検知できません。
    よって、R3はこれまで通り戻りの通信をR1に投げるのですが、R1はその先を持っていないので、パケットを破棄して終わってると思います。

    R1のFa1/5がダウンしたらR1とR3それぞれのtrackが動作してHSRPがstandbyになるので、迂回できるはずなので、納得できません。
    Fa1/5のダウン状態でR1、R3の
     show track brief(I/F監視はDownになっているはず)
     show standby brief(Priorityは10減算されて95になっているはず)
    を確認してみると詳細が分かると思います。

    キャンセル

  • 2018/02/06 19:35

    ご回答ありがとうございます。
    いつも本当にすみません。とても助かります。

    「正系が生きている前提で話します。」と記載されていますが、
    その場合ですと、R1←→R3の経路を辿るので特に問題はないのかなと認識しております。
    type echo protocol ipIcmpEcho 192.168.0.253の設定をしていなかったために、R2→PC-2の疎通の戻りの際にR3の経路を辿ってしまったと認識しました。間違っていましたら申し訳ございません。
    ip slaのコマンドありがとうございます。
    探してもGNS3のコマンドがなかなか見つからない状態でしたので助かりました。
    ご指摘いただいた点を踏まえ、再度チャレンジしてみます。

    キャンセル

  • 2018/02/06 21:03

    R3にはtrack 1 rtr 1 reachabilityを入力すると% Cannot change object created via HSRPで弾かれてしまうので、track 10 rtr 1 reachabilityなどの違う数字ですと入力できましたが、迂回されず。
    show track briefでは
    R1#sho track b
    Track Object Parameter Value
    1 rtr 1 reachability Down
    R3#show track b
    H indicates object created via HSRP.
    |
    Track H Object Parameter Value
    1 H interface FastEthernet1/5 line-protocol Up
    2 rtr 1 reachability Down
    となっており、I/Fがダウンになりません。。。

    むむーん、ちょっと今の私には難しすぎる内容なので基本的な構成で別の練習も進めていこうと思います。
    いろいろアドバイスいただきありがとうございました。
    また、質問することがあると思いますので、その時はよろしくお願いいたします。

    キャンセル

  • 2018/02/07 18:37

    なんどもすいません。
    こちらもGNS3で環境構築してみました。
    結果として、slaの細かいコマンドに違いがあったり、副系ルータにもpreemptの設定が必要だったことが分かりました。
    以下が正常に迂回できるConfigの主要な投入Configです。
     ※Configは初期化した状態で投入しないとだめです
     ※正副切替りに1分ほど掛かります

    ■R1

    conf t
    !
    hostname R1
    !
    no ip domain lookup
    !
    ip sla monitor 100
    type echo protocol ipIcmpEcho 192.168.1.253
    exit
    ip sla monitor schedule 100 life forever start-time now
    !
    track 1 rtr 100 reachability
    delay down 10
    exit
    !
    int fa 0/0
    ip address 10.0.0.1 255.255.255.0
    speed 100
    duplex full
    no shut
    exit
    !
    int fa 0/1
    ip address 192.168.0.253 255.255.255.0
    standby 10 ip 192.168.0.254
    standby 10 priority 105
    standby 10 preempt
    standby 10 track FastEthernet0/1
    standby 10 track 1 decrement 10
    speed 100
    duplex full
    no shut
    exit
    !
    ip route 192.168.1.0 255.255.255.0 10.0.0.2
    !
    end


    ■R2

    conf t
    !
    hostname R2
    !
    no ip domain lookup
    !
    !
    !
    !

    !
    !
    !
    !
    !
    int fa 0/0
    ip address 10.0.1.1 255.255.255.0
    speed 100
    duplex full
    no shut
    exit
    !
    int fa 0/1
    ip address 192.168.0.252 255.255.255.0
    standby 10 ip 192.168.0.254
    standby 10 preempt
    speed 100
    duplex full
    no shut
    exit
    !
    !
    !
    !
    ip route 192.168.1.0 255.255.255.0 10.0.1.2
    !
    end


    ■R3

    conf t
    !
    hostname R3
    !
    no ip domain lookup
    !
    ip sla monitor 100
    type echo protocol ipIcmpEcho 192.168.0.253
    exit
    ip sla monitor schedule 100 life forever start-time now
    !
    track 1 rtr 100 reachability
    delay down 10
    exit
    !
    int fa 0/0
    ip address 10.0.0.2 255.255.255.0
    speed 100
    duplex full
    no shut
    exit
    !
    int fa 0/1
    ip address 192.168.1.253 255.255.255.0
    standby 10 ip 192.168.1.254
    standby 10 priority 105
    standby 10 preempt
    standby 10 track FastEthernet0/1
    standby 10 track 1 decrement 10
    speed 100
    duplex full
    no shut
    exit
    !
    ip route 192.168.0.0 255.255.255.0 10.0.0.1
    !
    end


    ■R4

    conf t
    !
    hostname R4
    !
    no ip domain lookup
    !
    !
    !
    !

    !
    !
    !
    !
    !
    int fa 0/0
    ip address 10.0.1.2 255.255.255.0
    speed 100
    duplex full
    no shut
    exit
    !
    int fa 0/1
    ip address 192.168.1.252 255.255.255.0
    standby 10 ip 192.168.1.254
    standby 10 preempt
    speed 100
    duplex full
    no shut
    exit
    !
    !
    !
    !
    ip route 192.168.0.0 255.255.255.0 10.0.1.1
    !
    end

    お時間を取らせてしまい、すいません。
    お手すきの際にでも見てください!

    キャンセル

  • 2018/02/07 19:56

    こちらこそ、何度もすみません。
    configありがとうございます!
    コマンドの意味を理解しながらやっていきたいので、時間があるときにゆっくり考えながら進めていこうと思います。taichiさんが仰っていたようにOSPFやEIGRPなども絡めてやると理解が進みそうです。
    アドバイス本当にありがとうございました!とても助かりました。
    今回の課題を通じて、もっと自分で調べて情報収集して解決できるようになることも課題だと感じました。
    エンジニアってすごいです☺

    キャンセル

  • 2018/02/07 21:54

    あ、一点だけ質問させてください。
    今回のNW構成ではスタティックルートを使用したため、HSRPの設定が必要だったと感じました。
    なぜなら、Activeの経路が何らかの障害でダウンしてしまった際に、手動でもう片方の経路へデータが流れるように切り替わりの設定をしなければならないからです。
    一方、OSPFではトリガーアップデートにより、障害があった時に、その変化を検知しLSAを用いて隣接機器へパケットを転送します。その情報に基づいてルーティングテーブルがアップデートされ経路の変更がされると認識しました。
    よって、OSPFを使用する際は物理的な冗長構成を組めばHSRPなどの論理的な冗長構成を組む必要はないのでは?と考えました。
    もし、何か私の方で勘違いしていましたらご教授願います。よろしくお願いいたします☺

    キャンセル

  • 2018/02/08 15:23

    >> OSPFを使用する際は物理的な冗長構成を組めばHSRPなどの論理的な冗長構成を組む必要はないのでは?と考えました。
    OSPFを使う構成でもHSRPは必要です。
    なぜなら、PCのデフォルトGW(ルータのIP)を冗長化するには必ずHSRPの仮想IPが必要だからです。
     ・OSPFはHSRPのような仮想IPは持てません。
     ・PCはデフォルトGWを複数持てません。(出来るかもだが、普通やらない)

    今回の構成でいうと、PC-1のデフォルトGWにR1の物理アドレス192.168.0.253を設定したとしましょう。
     ①R1の筐体障害が発生
     ② ①をOSPFの機能で各ルータが検知
     ③各ルータは192.168.1.0/24への経路は10.0.1.0/24を使う旨学習する
     ④しかし、PC-1は固定のデフォルトGW設定なので、相変わらず通信できないR1宛てにパケットを投げ続ける
    です。

    因みR1の筐体障害ではなく、WAN側ポート障害の場合、迂回はできますね。
     ①R1のWAN側(fa1/5)ポート(orケーブル)障害が発生
     ② ①の障害をOSPFの機能で各ルータが検知
     ③各ルータは192.168.1.0/24への経路は10.0.1.0/24を使う旨学習する
     ④PC-1はR1宛てにパケットを投げる
     ⑤R1のルーティングテーブルは下記になっているため、R2に転送する
       Dst:192.168.1.0/24 NH:192.168.0.252(R2)
     ⑥R2は副系回線でパケットを転送する。

    です。

    キャンセル

  • 2018/02/08 19:10

    ご回答ありがとうございます☺
    なるほどです。
    確かにデフォルトゲートウェイは固定しているので、R1-SW1間のケーブル抜き線やR1の筐体障害ですと、OSPFのルーティングがされる前にR1への経路にしか行けず破棄されるだけですね。
    一方、R1のfa1/5であればR1に到達できるのでOSPFのルーティングが働きますね。192.168.1.0への経路は一度R1へ行くことになるので遠回りになってしまいますが。
    よって、OSPFでもHSRP使用する必要性があること、理解しました。
    ホントにホントにたくさんありがとうございました!
    taichiさん、てんさい☺

    キャンセル

0

R2のfa1/1 シャットダウンしていませんか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/02/01 23:30

    ご回答ありがとうございます。Hogeさん☺

    仰る通りシャットダウンしてましたので、開放しました。見つけて下さりありがとうございます。
    しかし、開放後も何故かHSRPがR2とR3で反映されないのです('_')
    あと、もしご存知でしたら教えていただきたいのですが、以下のURLですとSW1とSW2にはVlan5の設定が記載されていますが、PCーAに直接繋がっているスイッチ?の設定については何も記載がありません。図に書かれている構成は全てVLAN5の範囲になるのでしょうか。もしそうであれば、私のNW図でいうR1にもVLAN設定を入れないといけないなと思いまして、R1のint Vlan10に192.168.5.5/24を設定しました。しかし、HSRPは反映されず。私、見当違いなことしてるのかな。混乱してきました。http://www.infraexpert.com/study/fhrpz02.html

    キャンセル

  • 2018/02/01 23:48 編集

    とりあえずリンク先のVlan5について回答します。

    VIDの値の統一は「トランクポート(タグ付きポート)で接続されている場合のみ」必要です。アクセスポート(タグなしポート)で繋がっている場合は、VIDが統一されている必要はありません。(そもそもVIDの設定がなくても良い。)

    理由はこのポートを出入りするパケット(正確にはフレーム)のことを考えれば簡単です。トランクポートを出入りするパケットにはタグが付与されていてVLAN情報を区別しますが、アクセスポートを出入りするパケットにはタグが存在しないためです。

    本題のHSRPの方はまだ解決していないようですね。ただ、設定投入後若干ラグがあるはずなのでしばらくしてから確認すると良いと思いますよ。少なくともStateがInitというのはおかしいです。

    キャンセル

  • 2018/02/02 00:47

    ご回答ありがとうございます。
    そして夜分に失礼いたします。
    Hogeさんが仰るVIDは、今回のR1でいうと以下のことですね。
    int vlan 10 
    ip address 192.168.5.5 255.255.255.0
    R2~R5にもそれぞれint vlan 10でIPアドレスを割り振っていましたが、今回は全てアクセスポートの設定なので不要ですね。
    アクセスポートの設定では
    ①vlanの作成
    vlan 10
    ②接続先ポートにアクセスポートの設定
    switchport mode access
    switchport access vlan 10
    上記2点で済む話だったんですね。
    トランクポートの設定の際に、双方の機器に
    ・PC-A
    int vlan 10
    ip address 192.168.5.1 255.255.255.0
    int vlan 20
    ~以下省略~
    ・PC-B
    int vlan 10
    ip address 192.168.5.2 255.255.255.0
    int vlan 20
    ~以下省略~
    上記の設定がプラスされるわけですね。
    そしてこの設定が「タグ」として付与される情報になるわけですね。
    納得しました☺(間違ってたらすみません)
    わかりやすいご説明ありがとうございます。

    あとは、HSRPですが、今日はもう遅いので明日チャレンジしてみます。
    恐縮ですが、引き続きお相手して下さると助かります。
    本日はありがとうございました!

    キャンセル

  • 2018/02/02 13:56

    経過報告です。
    残念ながら、HSRPの設定はinitから変わることはありませんでした。

    また、今回の構成でpingの疎通をするときに、宛先はデフォルトゲートウェイの192.168.5.254で行っていますが、これだとR1からR2,R1からR3までの範囲しか確認できないような気がしています。(HSRPの設定はR2とR3にしかしていないため)
    その先のR4やR5までデータを送るにはスタティックルートや他のダイナミックルート(OSPFとか)の設定が必要になってくるのでしょうか。
    うう、初歩的な質問で申し訳ありませんがアドバイスお願いいたします。

    キャンセル

0

話が長くなってきたので分割します。そしてもっとも重要な基礎事項を述べます。多分根本的に勘違いされています。

 単純にルータ、スイッチの使い方だけ勉強するのではなく、伝送路上を流れるIPパケット(やEthernetフレーム)の宛先情報とセットで考えてください。

まず、一番基本的なことを述べます。ルータ、スイッチの間を流れるIPパケットやEthernetフレームを考えないことにはルータやスイッチを理解できません。

スイッチ:宛先MACアドレスによって経路判断
ルータ:宛先IPアドレスによって経路判断
トランクポート:スイッチポートの一種。EthernetフレームにVLAN情報を付与する。
アクセスポート:スイッチポートの一種。EthernetフレームにVLAN情報を付与しない。

「アクセスポートであればIPアドレスを省略できる」と解釈されているようですが、そういうことではありません。図の中ではルータの記号ばかりでスイッチの記号が出てきていないので、多分混同されていると思います。そもそもスイッチにIPアドレスは必要ありません。IPアドレスによる経路判断はL3の処理です。VLANもL2の機能なので、IPアドレスは関係ありません。もっとも、Ciscoスイッチは高機能なのでIPアドレスを付与できますが、このIPアドレスはL2経路判断には無関係です。L3スイッチのスイッチポートも同様です。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/02/03 13:10

    ご回答ありがとうございます。

    L2とL3の役割について理解しました。
    ざっくばらんに言うと、流れているデータはL1~L7までの階層(レイヤー)で分かれていて、それぞれ役割があり、各レイヤーに基づいて考える必要があるのですね。各レイヤーには各プロトコルによって役割を担っているんですね。
    L2SW同士の通信ですと、フレームというデータ形式でレイヤー1とレイヤー2が乗っかったデータがMACアドレスを基に流れ、
    L3SWを加えた通信ですと、パケットというデータ形式でレイヤー1~レイヤー3までが乗っかったデータ(IPアドレス情報がプラス)を基に流れ、
    telnetなどの通信をするときは、さらにレイヤー4(TCP/UDP情報)がプラスされ、、、
    teratailのwebサイトを閲覧するときは、レイヤー1~レイヤー7(HTTPなど)までの情報が一まとめになって流れる、
    という認識で理解したつもりです。

    そうしますと、今回HSRPは仮想MACアドレスや仮想デフォルトゲートウェイを使うのでレイヤー3までの情報を使って実装する必要があるのですね。
    しかしそれでもちょっと理解できないです。なぜなら、今の設定で192.168.5.254で疎通ができると思うのですが、not reachableになってしまうからです。
    やぱり難しいです('_')プシュー

    キャンセル

  • 2018/02/03 13:53

    HSRPの話題はとりあえずおいておきます。

    それでは、どのフレームがどのVLANに属するものかを識別するのはどうするかわかりますか?トランクポートの場合は複数のVLANに属するフレームが出入りするはずです。アクセスポートの場合は一種類だけですよね。つまり、トランクポートを出入りするフレームにはVLAN情報が付与されるわけです。これがタグです。

    キャンセル

  • 2018/02/03 13:53

    訂正
    telnetの通信はレイヤー5以上でした。失礼いたしました。

    キャンセル

  • 2018/02/03 14:04

    直接スイッチと接続されているPCはアクセスリンクで指定したvlasn番号の範囲でしたら通信は可能です。
    一方、同様のvlan番号でも別のスイッチに直接接続されているPCへ通信をさせるためにはvlanの数だけケーブルの接続数も増えるので、一本のケーブルで複数のvlanデータを送るためにタグをつけて識別させる役割をもたせています。
    アクセスリンクとトランクリンクの仕組みは理解できていると思います。

    キャンセル

0

Config上はHSRPの設定は問題無いように見受けられます。

R2、R3はちゃんと接続されていますか?
そしてお互いのVlan10のアドレスを学習していますか?
GNS3の特性上、故意にPingとかしないとarp学習しなかったりするので、
R2⇔R3間でPingしたりすると、学習できるようになります。
そこらへんはGNS3のクセを覚えるか、実機を使うか,,,という感じです。

R2のFa1/4とR3のFa1/5にVlan10を割り当ててるのは、HSRPと関係無いですけど、違和感があります。
なぜなら、当該HSRPはPCにデフォルトGWを提供するためのものですよね?
そして、R4とR5はその先にある別のネットワークという意味合いに見えます。
であれば、その先のネットワークはセグメントを分けるべきなのです。
※HSRPと関係なくてすいません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/02/03 18:58 編集

    ご回答ありがとうございます。taichiさん☺
    PC-1からデフォルトゲートウェイ192.168.5.254で疎通できました!
    原因は、これもGNS3の仕様かもしれませんが、一度画面(プロジェクト自体)を閉じてしまうと設定した各スイッチのvlan情報が全て消えてました。再度、vlanを作成したところ疎通できました。
    なるほど。HSRPは別のセグメントへデータを送る直前のネットワークの冗長化を目的とした機能なんですね。
    であれば、確かにR2のFa1/4とR3のFa1/5にvlanを割り当てるのはおかしいですね。あと、R4のfa1/2とR5のfa1/3のvlanも修正します。

    あれ、そうすると、R2からR4、R3からR5への通信を実現させるために、別途ルーティングの設定が必要になるということでしょうか。192.168.5.254で通信ができた時点では、R2スイッチに到達しているということですよね?その先の別セグメントネットワークで通信するためにはルーティング設定が必要かなと思ったのですが、何か認識間違いしてますでしょうか。
    アドバイスよろしくお願いいたします。

    キャンセル

  • 2018/02/03 19:49 編集

    >>その先の別セグメントネットワークで通信するためにはルーティング設定が必要かなと思ったのですが、何か認識間違いしてますでしょうか。
    その通りです。
    学習を続けるのならR4、R5の配下にPCを繋げてそこにもHSRPを設定して、PC間の通信をしてみるとイメージしやすいかもしれません。
    また、以下は感想です。
     ・R1はただのL2スイッチ機能しか提供していないので、ルータではなくGNS3のL2SWでいいと思います。
     ・ルータのアイコンが全てL2SWになってます。ルータとL2のアイコンは使い分けたほうがわかりやすいです

    キャンセル

  • 2018/02/03 21:09

    ご回答ありがとうございます。
    お料理とご飯で、お返事遅れました。
    認識合っててよかたです。
    えーと、そうしますと、R4とR5配下にも同様にvlan10のような構成にしてみようかな。そしたら、R2ーR4、R3ーR5はトランクポートにになるのかな。

    または、R4とR5にそれぞれ一台ずつPCを繋げて、スタティックルートの設定で通信の検証をしてみようかと思います。

    以上2つの構成でチャレンジしてみようと思ってますが、認識合ってますでしょうか。(おなかいっぱいで頭が回ってないかもです)

    感想のところも踏まえて修正してみます。

    キャンセル

  • 2018/02/03 21:15

    2つ目の構成は実際にはおかしいですよね。冗長化を目的にしてることを考えると、R4とR5に別のPCを接続するのはPCの無駄遣いですね。ただ、スタティックルートの設定できちんと通信できるか検証してみたいと思い、この構成でもやってみようと思います。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.35%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Cisco

    104questions

    シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品

  • Cisco IOS

    33questions