質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.50%

  • Cisco

    117questions

    シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品

  • Cisco IOS

    40questions

DHCPサーバーを立てたけどIPアドレスが割り振られない

解決済

回答 2

投稿

  • 評価
  • クリップ 1
  • VIEW 3,277

narururu

score 42

環境

GNS3
イメージ説明

PC-1~PC-4は何も設定していない。(DHCPサーバーから自動的にIPアドレス192.168.1.0/24が割り振られることを想定しているため)

show run
R1

R1#show run
Building configuration...

Current configuration : 1358 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip dhcp use vrf connected
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.0.1 192.168.0.10
!
ip dhcp pool Tec
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.10
   domain-name test-dhcp.com
   lease 7
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.0.1 255.255.255.0
 ip helper-address 192.168.0.1
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2

R2#show run
Building configuration...

Current configuration : 1613 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
 shutdown
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end


R1
show ip dhcp pool
イメージ説明

show ip dhcp binding
イメージ説明

show ip dhcp conflict
イメージ説明

R2
show ip interface brief
イメージ説明

現状

上記の通り、DHCPの設定をR1に投入したのですが、PC-1~PC-4にIPアドレスが割り振られない状況です。
PCの画面には「dhcp」とコマンドを打つと、「Can't find dhcp server」と表示されます。
R1←→R2間の疎通はできています。

原因が分かる方いらっしゃいましたら、ご教授願います。
以上、よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+1

ざっと見てみたところ、追加で必要な設定があるようです。

■R2に必要な設定

①PC接続ポート(fa1/1-6)にスイッチポートの設定が無い
⇒PCを接続するのでポートVLANの設定が必要だと思われます。

②VLAN I/Fが存在しない
⇒PCのデフォルトGWとなる192.168.1.x/24のアドレスを割り振るVLAN I/Fが無いように見えます。

③VLAN I/FにはDHCPリレー設定が必要
⇒②で作成するVLAN I/FにはPCが発信するブロードキャスト(DHCP ディスカバー)をR1宛てのユニキャストへ変換するDHCPリレー設定(ip helper-addres)が必要です。
http://beginners-network.com/cisco-catalyst-command/ip-helper-address.html
http://www.infraexpert.com/study/tcpip14.html

■R1に必要な設定
①192.168.1.x/24へのルート
⇒DHCP OFFERやDHCP ACKはPCへのユニキャストで返すので、ルートが必要ですね。

ご確認ください!

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/01/30 18:31

    ご回答ありがとうございます。taichiさん。
    vlanの設定はスイッチを使うときは必ず必要ですね。大変失礼いたしました。
    DHCPリレー設定はR2にするのですね。間違ってR1に設定してしまいました。R1の設定は消しました。
    R1のルーテッドポッドの設定に関しては、R1とR2間でケーブルを1本追加し、ip routingを設定し、R2のint vlan 10にno switchportの設定をしようとしたのですが、% Invalid input detected at '^' marker.でコマンドが弾かれてしまいます。
    以上、現時点では、R2の①と②、③の設定が完了したところです。
    すいません。ルーテッドポートの設定が反映されないのですが、私の認識に誤りがありますでしょうか。

    キャンセル

  • 2018/01/30 18:47

    ルーテッドポートの設定ができない理由は、R2が、L2SWだからかもしれません。
    今回使用しているルーターがc3725なので、 Cisco 3640 series IOSをインストールして使ってみます。
    https://protechgurus.com/use-add-layer-3-switches-gns3/

    キャンセル

  • 2018/01/30 18:49

    >> R1のルーテッドポッドの設定に関しては、R1とR2間でケーブルを1本追加し、ip routingを設定し、
    >> R2のint vlan 10にno switchportの設定をしようとしたのですが、% Invalid input detected at '^' marker.でコマンドが弾かれてしまいます。
    う~ん。
    ルーテッドポートとスイッチポートの見分けについて、認識が必要そうですね。

    A.まず、R1、R2のfa0/0と0/1はルータに最初から付いているポートなので、これはルーテッドポートです。
    なので、no switchportコマンドは弾かれます。(no switchportはスイッチポートに「お前はルーテッドポートとして働け」と命令するコマンドです。)

    B.それに対し、fa1/0~15は後から追加したスイッチポートモジュールなので、ルーテッドポートとしての役割を与える場合にno switchportコマンドを使います。

    C.また、VLAN I/Fにもno switchportコマンドは入りません。なぜなら、VLAN I/Fはそもそもレイヤ3で動作する仮想的なルーテッドポートだからです。
    つまり、Aで述べた内容と同様の振る舞いです。

    つづきます。

    キャンセル

  • 2018/01/30 19:00

    これらの情報を今回のやりたいことに当てはめると、以下の様になる想定です。(DHCPクライアントが動作するPCは「PC-1」、所属するVLANは「VLAN10」としています。)

    1.PC-1がDHCP Discoverをブロードキャストで発信する。
    2.RT1のスイッチポート(Fa1/1)はそのパケットを受信し、VLAN I/Fへ内部転送する。
    3.VLAN I/FはDHCP Discoverパケットを認識し、設定されたDHCPリレーエージェントに基づき、ブロードキャストパケットをユニキャストへ変換し、R1へ転送する。
      ⇒その際、用いるルーティングテーブルは"192.168.0.0/24 connected"です。(R1 fa0/0 は 192.168.0.1 なので)
    4.R1はDHCP Discoverを受け取り、既定のDHCPサーバとしての振る舞いに基づき、DHCP OFFERをユニキャストでPC-1へ返す。
      ⇒その際、192.168.1.0/24へのルートが必要となる。
    5.以降の動作は設定に関係ないので省略。
      詳細は、http://atnetwork.info/tcpip1/tcpip181.html

    キャンセル

  • 2018/01/30 19:00

    ふむふむ('ω')
    ここまでの説明で1点確認したいのですが、
    C.のご説明にあるVLAN I/Fも仮想的なルーテッドポートとは、SVIのことで認識合ってますか?
    ご丁寧にありがとうございます。分かりやすいです。
    つづき、お待ちしてます☺

    キャンセル

  • 2018/01/30 19:01

    修正Configは以下で良いと思います。(検証はしてないです。)

    ■R2
    conf t
    !
    interface FastEthernet0/0
    ip address 192.168.0.2 255.255.255.0
    duplex auto
    speed auto
    ip helper-address 192.168.0.1
    exit
    !
    interface range FastEthernet1/0 - 15
    switchport mode access
    switchport access vlan 10
    no shut
    exit
    !
    interface vlan 10
    ip address 192.168.1.10 255.255.255.0
    no shut
    exit
    !
    end

    ■R1
    conf t
    !
    ip route 192.168.1.0 255.255.255.0 192.168.0.2
    !
    end

    キャンセル

  • 2018/01/30 19:11

    コンフィグまで書いて下さり、ありがとうございます。
    taichiさんが仰ってた「ルートの設定」はスタティックルートのことだったんですね。ルーテッドポートのことかと間違って認識してました。
    頂いたコンフィグを基に試してみます。
    ありがとうございます☺

    キャンセル

  • 2018/01/30 19:20

    すいません,,,間違えました。
     ip helper-address 192.168.0.1
    の設定箇所はDHCP Discoverを受け取る、VLAN I/F(SVI)でした,,,。ごめんなさい。
    ■R2
    conf t
    !
    interface FastEthernet0/0
    ip address 192.168.0.2 255.255.255.0
    duplex auto
    speed auto
    exit
    !
    interface range FastEthernet1/0 - 15
    switchport mode access
    switchport access vlan 10
    no shut
    exit
    !
    interface vlan 10
    ip address 192.168.1.10 255.255.255.0
    ip helper-address 192.168.0.1
    no shut
    exit
    !
    end

    ■R1
    conf t
    !
    ip route 192.168.1.0 255.255.255.0 192.168.0.2
    !
    end

    キャンセル

  • 2018/01/30 19:47

    ご回答ありがとうございます。
    それぞれPCのコマンドでdhcpを打つと、ちゃんとIPアドレスが割り振られました!
    すごいです☺
    今回のやり方、考え方をきちんと理解し、複数のVLAN構成でもDHCPサーバーからIPアドレスが割り振られるようにチャレンジしてみます。
    最後に1点だけ疑問があります。
    それは、PCの方でわざわざdhcpのコマンドを打たないといけない点です。
    普段使用しているPCはdhcpと打たずにDHCPサーバーから自動でIPアドレスが割り振られてるのに、なぜGNS3ではdhcpとコマンドを入れる必要があるのか、という点です。
    普段使用しているPCではデフォルトでdhcpコマンドが自動的に入力されているというイメージですが、あまり気にしなくてよいのでしょうか。

    キャンセル

  • 2018/01/30 19:53

    >> それは、PCの方でわざわざdhcpのコマンドを打たないといけない点です。
    ご認識の通り、GNS3特有の動きだと思いますので、気にしないで大丈夫です。
    Windows等 普通のPCは、NICのリンクアップと同時にDHCPクライアントが動作し、DHCP Discoverを発信します。

    キャンセル

  • 2018/01/30 19:56

    なるほどです。
    今回の解説のおかげで、だいぶ理解が深まりました。
    いつも本当に助かってます☺
    ご丁寧な解説、ありがとうございました!

    キャンセル

0

C.のご説明にあるVLAN I/Fも仮想的なルーテッドポートとは、SVIのことで認識合ってますか?

合ってます!

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/01/30 19:48

    合っててよかたです☺

    キャンセル

  • 2018/01/30 23:06

    おかげさまで、複数Vlan構成でもそれぞれのVlan内のIPアドレスの割り振りできました!
    ありがとうございました☺

    キャンセル

同じタグがついた質問を見る

  • Cisco

    117questions

    シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品

  • Cisco IOS

    40questions