質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.50%

  • Cisco

    92questions

    シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品

  • Cisco IOS

    30questions

cisco IOSを吸い出したい

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 1,088

narururu

score 35

実現したいこと

cisco IOSを吸い出したい。

環境

ネットワーク機器:Catalyst3750
PC:Windows10 (IPアドレス192.168.10.1 /24を設定)
FTPソフト:Tftpd64(ServerInterfacesに192.168.10.1を設定)
ファイアウォールの設定解除

現状

show flash
copy
IOSを転送しようとすると上記画像のようにエラーになってしまいます。
また、PCとスイッチをシリアルで接続し、teratermでping 192.168.10.1したところパケットが届きません。

PS

皆さんはどのようにして問題解決されてるのでしょうか?
調べても答えはないので、自力でいろいろ試して答えを見つけているのでしょうか?
あまりにも大変作業で心が折れそうです。
マニュアルみたいなものがあると助かるのですが…

追記

LANケーブルを接続しております。(スイッチinterface FastEthernet1/0/1とPC)
PCにIPアドレス192.168.10.1を設定しております。
また、PC(コマンドプロンプト)からスイッチへping 172.16.1.1を飛ばしてもエラーとなってしまいました。
telnetも接続でません。

show runの結果

goma#sh run
Building configuration...

Current configuration : 2813 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname goma
!
enable password 7 121E0A1A13
!
no aaa new-model
switch 1 provision ws-c3750-24ts
system mtu routing 1500
ip subnet-zero
ip routing
!
!
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 100,200
 switchport mode trunk
 switchport nonegotiate
!
interface Port-channel2
 no switchport
 no ip address
!
interface FastEthernet1/0/1
 switchport access vlan 100
 switchport mode access
!
interface FastEthernet1/0/2
 switchport access vlan 100
 switchport mode access
!
interface FastEthernet1/0/3
 switchport access vlan 200
 switchport mode access
!
interface FastEthernet1/0/4
 switchport access vlan 200
 switchport mode access
!
interface FastEthernet1/0/5
 no switchport
 ip address 192.168.111.2 255.255.255.0
!
interface FastEthernet1/0/6
 shutdown
!
interface FastEthernet1/0/7
 shutdown
!
interface FastEthernet1/0/8
 shutdown
!
interface FastEthernet1/0/9
 shutdown
!
interface FastEthernet1/0/10
 shutdown
!
interface FastEthernet1/0/11
 no switchport
 no ip address
 channel-group 2 mode on
!
interface FastEthernet1/0/12
 no switchport
 no ip address
 channel-group 2 mode on
!
interface FastEthernet1/0/13
 shutdown
!
interface FastEthernet1/0/14
 shutdown
!
interface FastEthernet1/0/15
 shutdown
!
interface FastEthernet1/0/16
 shutdown
!
interface FastEthernet1/0/17
 shutdown
!
interface FastEthernet1/0/18
 shutdown
!
interface FastEthernet1/0/19
 shutdown
!
interface FastEthernet1/0/20
 shutdown
!
interface FastEthernet1/0/21
 shutdown
!
interface FastEthernet1/0/22
 shutdown
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 100,200
 switchport mode trunk
 switchport nonegotiate
 channel-group 1 mode active
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 100,200
 switchport mode trunk
 switchport nonegotiate
 channel-group 1 mode active
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan100
 ip address 192.168.10.100 255.255.255.0
 standby 1 ip 172.16.1.254
!
interface Vlan200
 ip address 172.16.2.2 255.255.255.0
 standby 2 ip 172.16.2.254
!
ip default-gateway 192.168.0.254
ip classless
ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
 password 7 051F07042042411B10
 logging synchronous
line vty 0 4
 exec-timeout 0 0
 password 7 071B20474F0716171E
 logging synchronous
 login
line vty 5 15
 exec-timeout 0 0
 password 7 0010120D0555041406
 logging synchronous
 login
!
end

show log
show log

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • archiver

    2018/01/21 03:29

    PCとスイッチとの接続はシリアル接続だけですか?(LANでは接続していない?)それと、192.168.10.1のIPアドレスを割り当ててあるのはPCの方でいいんですよね?

    キャンセル

  • narururu

    2018/01/21 12:21

    ご回答ありがとうございます。追記いたしました。ご確認お願いいたします。

    キャンセル

回答 2

checkベストアンサー

0

①Windows側のTFTP設定確認
まずは copy run tftp などでwindows側のTFTPが正しく動くか確認してください。

②Destination filename を修正 ←これっぽい
Destination filenameを聞かれて、その結果c:\users~~ みたいな、Windowsのディレクトリがファイル名に指定されちゃってますよね。
これが原因な気がするので、「Destination filename」を聞かれたらtestなど簡単なファイル名にしてください。
私の環境だと、それでいけました。

~~~失敗パターン~~~
CatSW1#copy flash:c3750-i5-mz.121-19.EA1a.bin tftp:
Address or name of remote host []? 192.168.0.100
Destination filename [/c3750-i5-mz.121-19.EA1a/c3750-i5-mz.121-19.EA1a.bin]?
TFTP: error code 2 received - Access violation

%Error opening tftp://192.168.0.100//c3750-i5-mz.121-19.EA1a/c3750-i5-mz.121-19.EA1a.bin (Permission denied)
CatSW1#

~~~成功パターン~~~
CatSW1#copy flash:c3750-i5-mz.121-19.EA1a.bin tftp:
Address or name of remote host []? 192.168.51.68
Destination filename [/c3750-i5-mz.121-19.EA1a/c3750-i5-mz.121-19.EA1a.bin]? test
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
4045778 bytes copied in 24.092 secs (167930 bytes/sec)
CatSW1#

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/01/23 17:05

    ご回答ありがとうございます。taichiさん。
    頂いた方法で試しましたが、エラーになってしまいました。
    現時点では、PC←→Catalyst3750間でpingの疎通ができていないことから基本的な箇所で間違っているor抜け漏れがあるように感じております。
    一度、初期化してint fa1/0/1にno switchport と、ip address 192.168.1.10を設定し、PCの方でcmdからping 192.168.1.10で疎通確認したのですが、これもダメでした。スイッチからPCへも同様に疎通できません。
    私の認識に誤りがありますでしょうか?
    以上の点から何かアドバイスいただけると助かります。
    よろしくお願いいたします。

    キャンセル

  • 2018/01/23 17:27 編集

    なるほど
    >> 一度、初期化してint fa1/0/1にno switchport と、ip address 192.168.1.10を設定し、PCの方でcmdからping 192.168.1.10で疎通確認したのですが、これもダメでした。
    これは変ですね。
    int fa1/0/1 をルーテッドポートにしているということですが、以下はどうなってますか?(無論、PCのIPアドレスは192.168.1.0/24範囲内であることが前提です。)
     ①show ip int brief
      ⇒int fa1/0/1 がUPしている。
     ②show ip route
      ⇒192.168.1.0/24 が coneccted(出力I/F:Fa1/0/1)で登録されている。
     ③show arp
      ⇒PCのarp情報が登録されている。
    あと、ルーテッドポートとサーバを直接接続する場合、AutoMDI/MDI-Xが有効になってないとリンクアップしないので、要注意です。その場合はクロスケーブルが必要です。

    キャンセル

  • 2018/01/23 18:06

    ご回答ありがとうございます。
    ①show ip int briefの結果は、fa1/0/1は「up/up」になっております。
    ②show ip routeの結果は、「C 192.168.1.0/24 is directly connected, FastEthernet1/0/1」と表示されています。
    AutoMDI/MDI-Xについては確認方法が分からず、また、ケーブルもクロスかストレートか確認できず。。。
    しかし、fa1/0/1が緑色に点灯しリンクアップしているので問題ないかなと思っております。
    それともAutoMDI/MDI-Xやケーブルの問題なのでしょうか。
    クロスケーブルも購入しようと思います。
    他に考えられる原因がありましたら、アドバイスいただけると助かります。お願いします。

    キャンセル

  • 2018/01/23 18:13 編集

    >>fa1/0/1が緑色に点灯しリンクアップしているので問題ないかなと思っております。
    そうだと思います。クロスケーブル云々は忘れてください。

     ③show arp
      ⇒PC(サーバ)のarp情報が登録されている。
    上記はどうですか?
    上記がincompleteでなく、ちゃんと登録されているかで被疑箇所がかなり特定されてくるはずです。

    キャンセル

  • 2018/01/23 18:55

    ご回答ありがとうございます。
    ③show arpの結果は、Internet 192.168.1.10 - 001e.133f.68c1 ARPA FastEthernet1/0/1だけ表示されておりますので、スイッチのポートはテーブルに登録されており、PCの情報は登録されていませんでした。
    こちらの情報で被疑箇所が特定されてくるのでしょうか?
    難しいですね。

    キャンセル

  • 2018/01/23 19:11

    ご確認ありがとうございます。
    ちゃんとarp登録されているのですね。
    であれば、PC側の問題だと思いますけどねえ。
    PC側はファイアーウォール無効化or許可設定してるんですよね?

    度々で恐縮ですが、以下はどうでしょう。

    Conf t
    Access-list 1 permit any log
    Int fa1/0/1
    ip access-group 1 in
    Exit
    End

    これでポートに着信したパケットはログに記録されますので、正常にPCからパケットが来てるかどうかがshow logで確認可能です。

    ・パケットが来てたら
    考えにくいですが、cisco側の故障?
    ・パケットが来てなければ
    やはりPC側の問題。設定を見直す。

    だと思います。

    キャンセル

  • 2018/01/23 20:10

    ご回答ありがとうございます。
    ファイアウォールは無効化にしてあります。
    頂いたコンフィグをそのまま設定し、show logで確認したところ、パケットが来てるような感じです。
    念のため、追加の欄に、画像を貼っておきます。参考になれば幸いです。
    これで、もしパケットが正常に届いているようであれば機械の故障だということで諦めます。
    ご確認お願いいたします。

    キャンセル

  • 2018/01/23 20:31

    show logをきちんと確認すると、
    IPアドレスが設定したものと全然違います。
    PC側の設定に問題があるということになるわけですね。

    キャンセル

  • 2018/01/24 00:24

    PCから169.254.x.x(リンクローカルアドレス)のアドレスでパケットが着信しているようですね。
    ちゃんとIPアドレスが設定されているのかが疑問です。
    PC側でipconfigを実行して、どのようなIPアドレスが設定しているか、確認してください。
    下記の設定になっていないのではないかと思います。
    IPv4 アドレス . . . . . . . . . . . .: 192.168.1.xxx
    サブネット マスク . . . . . . . . . .: 255.255.255.0
    デフォルト ゲートウェイ . . . . . . .: (関係無い設定)

    キャンセル

  • 2018/01/24 14:47

    ご回答ありがとうございます。
    ipconfigで確認したところ、アドレスが反映されていませんでした。
    そこで、GUIではなく、コマンドで設定しようと思い、以下のコマンドを入力しましたが、「次のコマンドは見つかりませんでした」と返ってきてしまいます。
    netsh interface ip address "ローカルエリア接続" static 192.168.1.11 255.255.255.0 192.168.1.254
    また、調べてみると、コマンドプロンプトのPathを渡す必要があると書かれていたので、その設定もしました。
    何か認識間違いや不足している点がありますでしょうか。
    度々申し訳ございませんが、ご回答よろしくお願いいたします。

    キャンセル

  • 2018/01/24 23:44

    まず、GUIで設定したIPアドレスが反映されないというのが通常考えにくい状況です。
    言わずもがなですが、手順は以下です。
    http://faq.buffalo.jp/app/answers/detail/a_id/862

    上記の手順でIPアドレスを固定に設定しても反映されないのであれば、
    PC側にNICが複数あって、IPアドレスを設定したNICとは別のNICをCiscoに繋げているとか?ないでしょうか。
    とにかく、PCにIPアドレスを設定するっていうのは正直初歩的なものなので、可能なアドバイスも限られてしまいます,,,。

    あと、以前の回答の修正です。arpは正常に学習できていませんでした。
    学習していたアドレスはCiscoのI/Fアドレス(Fa1/0/1)のものでしたね。
    >> ちゃんとarp登録されているのですね。
    >> であれば、PC側の問題だと思いますけどねえ。

    キャンセル

  • 2018/01/25 14:51

    ご回答ありがとうございます。
    ping双方向ともに通りました!
    原因は設定していたIPアドレスのNICが「イーサネット」ではなく、「Wi-Fi」で行っていたためでした。
    とても初歩的な質問に対してもご丁寧に回答して下さり、本当にありがとうございました。
    感謝感激です。taichiさん、てんさい!
    あとは、本来の目的であるIOSの吸出しをしてみます。
    本当にありがとうございました。

    キャンセル

  • 2018/01/25 18:55

    疎通できたとのこと、良かったです。
    無事IOSの吸出しができるかな?
    成功するといいですね。

    あと、現状全ての通信をCisco側でログ出力していますが、そのままだとCisco側の負荷が高いため、全て終わった後に当該設定は消した方が良いですよ。
    コンフィグは以下です。

    conf t
    int fa1/0/1
    no ip access-group 1 in
    exit
    no access-list 1
    end

    キャンセル

  • 2018/01/25 21:57

    IOSの吸出し成功しました!
    最初、permission deniedと表示されガックリしたのも束の間、FTPサーバで指定したディレクトリが存在しないものだったからでした。これはすぐに解決できて良かったです。
    taichiさんのおかげで、目的のIOS吸い出しに成功しました。

    ログ出力の設定を解除しますね。
    ご丁寧にコンフィグまで載せていただき本当にありがとうございました。
    とても助かりました。これからGNS3の設定にチャレンジします。
    ありがとうございました!☺

    キャンセル

  • 2018/01/26 10:35

    あ、もしかしてCatalystのIOSでGNS3を動かそうとしてる感じですか?
    残念ながらGNS3上ではCatalystは動かないんですよねぇ。。。
    動くのはCiscoルータのIOSです。

    CiscoルータのIOSはヤフオクで売ってる中古のCiscoルータ買うか、
    ネットに転がってるのを自己責任でゴニョゴニョするか、お任せします。
    http://noir-es.cocolog-nifty.com/blog/2016/07/gns3cisco-ios-4.html

    キャンセル

  • 2018/01/26 11:10

    はい。GNS3を使うためにIOSを吸い出したのですが、Catalyst3750は使えないんですね。あとから知りました。
    しかし、この作業でNW機器を介してpingの疎通やPCをFTPサーバとしてデータの転送ができるようになりましたので、いい経験だったと思います。
    インターネットに転がっているIOSでやってみます!
    URLありがとうございます。
    こちらのコメントを見る前に、以下のサイトからIOSをダウンロードしてましたので、こちらを使ってチャレンジしてみます。
    http://srijit.com/working-cisco-ios-gns3/
    ご丁寧にありがとうございました!☺

    キャンセル

0

私の知る限り、IOSのコピーはLANケーブル越し(Ethernet互換インタフェース)で行うことが普通です。ですので、LAN越しでの接続確認(たとえばping)を事前に行えなければ繋がりようがありません。先にそちらを見たほうが良いと思います。

今回では、PCとつながっているFa1/0/1はVlan100に属するインタフェースなのでIPアドレス上互いに疎通しないと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/01/21 14:04

    ご回答ありがとうございます。
    はい。私もそう思って、pingを通すために設定をしているのですが、うまくいきません。
    どのように設定すればいいのでしょうか。

    キャンセル

  • 2018/01/21 15:02

    方法1:Vlan100を管理VLANにしたうえで、Vlan100のIPアドレスを192.168.10.100(一例)にする。
    方法2:Fa1/0/1をVlan1(デフォルト管理VLAN)、Vlan1のIPアドレスを192.168.10.100(一例)にする。
    方法3:適当に余ってるIntefacceにケーブルを差し替え、管理Vlanを割り当ててアドレスを以下略

    キャンセル

  • 2018/01/21 15:09

    ちなみにpc側でEthernetを遮断とかping無視とかしている場合といった別件の可能性もありますのでそれも確認ください。

    キャンセル

  • 2018/01/21 15:48

    ご回答ありがとうございます。
    方法1を試してみました。
    ①デフォルトの管理VLAN1をshutdownにしました。
    ②VLAN100のIPアドレスを192.168.10.100に変更しました。
    以上の変更から同じように、ping 192.168.10.1をしたのですが、宛先ホストに到達できませんとエラーになってしまいました。
    何か不足しているのでしょうか。

    キャンセル

  • 2018/01/21 21:18 編集

    確認ですが、ping時に起点インタフェースをvlan100とかfa1/0/1にしていないといけないです。

    そのエラーメッセージならルーティングの設定の課題と思われます。ですので、192.168.10.x以外のアドレスを起点にpingを送出しようとしていると思われます。

    キャンセル

  • 2018/01/21 22:53

    ご回答ありがとうございます。
    前言に間違いがありました。失礼しました。
    正しくは、
    PCからスイッチへping 192.168.10.100を試したときに、宛先ホストに到達できないエラーが表示され、
    スイッチからPCへping 192.168.10.1を試したときに、タイムアウトのエラーが表示されてしまいます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.50%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Cisco

    92questions

    シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品

  • Cisco IOS

    30questions