質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.99%

  • Cisco

    68questions

    シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品

  • Network+

    38questions

    Network+とは、IT業界団体CompTIA認定のネットワーク技術に関する知識を証明する資格です。ネットワーク技術者として、実務で必要なネットワークセキュリティ・ネットワークアーキテクチャなどの知識を取得している証明となります。

Cisco機器の設定において動的IPのport forwardingとddns(mydns)の更新の方法ついて

受付中

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 192

HogeHoge0022

score 2

環境

Router: Cisco 2901
isp: eo光
ip: 動的(IP固定契約していない)

状況・やりたいこと

上記の環境でddns(mydns)を使用して外部にServerを公開したいと思っているのですが、動的IPの為、下記のコマンド([command1])のようにinterface指定だとCiscoのport forwardingのコマンドが使用出来ませんでした。

[command1]
ip nat inside source static tcp 192.168.0.1 80 interface dialer 0 80 extendable

※extendableオプション抜きのコマンド([command2])を使用すると別のportのコマンドを使用すると上書きされてしまいました。
extendableオプションを付けたコマンドはTCP/UDPともに一つずつしか使用できないみたいです。
今回は複数のポートをforwardingしたいので、使用しませんでした。

[command2]
ip nat inside source static tcp 192.168.0.1 80 interface dialer 0 80

そこで、下記([command3])のコマンドを使用してport forwardingをしたのですが、ddns(mydns)へのIP更新の通信もforwardingしてlocal serverのほうに送信してしまいddns(mydns)のIP更新ができなくなってしまいました。
また、このコマンドを使用してもUDPのトラフィックがforwardingされませんでした。

※mydnsのIPを拒否しforwardingさせないことも考えましたが、mydnsのIPも固定でなく変動するためできませんでした。

[command3]
ip nat pool TEST 192.168.0.1 192.168.0.1 netmask 255.255.255.0 type rotary
ip nat inside destination list TEST pool TEST
ip access-list extended TEST
permit tcp any any eq www
permit tcp any any eq 443
permit udp any any eq 56400

IPを固定化せずにddns(mydns)を使用して、port forwardingを行い外部にServerを公開する方法はありますでしょうか?

補足情報

NAT変換履歴

(Router)#show ip nat translations | include 192.168.0.1
tcp {mydnsのIP}:80  192.168.0.1:80       {自宅の外部IP}:16656 {自宅の外部IP}:16656

access-list

IP変更前
Extended IP access list TEST
50 permit tcp any any eq www (18 matches)
60 permit tcp any any eq 443 (2 matches)
80 permit udp any any eq 56400

IP変更後
Extended IP access list TEST
50 permit tcp any any eq www (22 matches)
60 permit tcp any any eq 443 (5 matches)
80 permit udp any any eq 56400

config

Building configuration...

Current configuration : 7824 bytes
!
! Last configuration change at 19:30:33 JST Thu Jan 18 2018
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!

!
boot-start-marker
boot-end-marker
!
!
!
!
!
!
aaa session-id common
memory-size iomem 5
clock timezone JST 9 0
!
!
!
ip ddns update method MyDNS
HTTP
add http://{ID}:{PASS}@www.mydns.jp/login.html
interval maximum 0 1 0 0
!
ip cef
no ipv6 cef
!
!
!
redundancy
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
ip virtual-reassembly in
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/1
ip address 192.168.0.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
!
interface Vlan1
no ip address
!
interface Dialer0
mtu 1480
ip ddns update hostname {取得ドメイン}
ip ddns update MyDNS
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1440
dialer pool 1
dialer idle-timeout 0
dialer-group 1
ppp authentication chap callin
ppp chap hostname {HOST}
ppp chap password 7 {PASS}
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat pool TEST 192.168.0.1 192.168.0.1 netmask 255.255.255.0 type rotary
ip nat inside source list PAT interface Dialer0 overload
ip nat inside destination list TEST pool TEST
ip route 0.0.0.0 0.0.0.0 Dialer0 permanent
!
ip access-list extended PAT
permit ip 192.168.0.0 0.0.0.255 any

ip access-list extended TEST
permit tcp any any eq www
permit tcp any any eq 443
permit udp any any eq 56400
!
dialer-list 1 protocol ip permit
ipv6 ioam timestamp
!

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

command2 が正解だと思います。
因みに当方の環境では、以下のConfigでインターネット公開できています。

ip nat inside source static tcp 192.168.0.30 9142 interface FastEthernet8 9142
ip nat inside source static udp 192.168.0.30 9142 interface FastEthernet8 9142
ip nat inside source static tcp 192.168.0.1 443 interface FastEthernet8 443
ip nat inside source static tcp 192.168.10.1 10443 interface FastEthernet8 10443

extendable設定と通常のNAT設定の併用が原因では?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/03/08 10:27

    返信が遅くなり申し訳ございません。
    検証してみましたがうまくいきませんでした。

    お手数ですがよろしければ下記のconfigを書き換えて頂くことはできますでしょうか。

    --------------- 以下 config ---------------

    ip dhcp excluded-address 192.168.0.200 192.168.0.254
    !
    ip dhcp pool CLIENT
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.254
    dns-server 8.8.8.8 8.8.4.4
    !
    !
    !
    ip ddns update method MyDNS
    HTTP
    add http://{ID}:{PASS}@www.mydns.jp/login.html
    interval maximum 0 1 0 0
    !
    !
    ip cef
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    redundancy
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    no ip address
    ip virtual-reassembly in
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 1
    !
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1.10
    description CLIENT
    encapsulation dot1Q 10
    ip address 192.168.0.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    !
    !
    !
    interface GigabitEthernet0/1.30
    description DMZ
    encapsulation dot1Q 30
    ip address 192.168.30.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    !
    !
    !
    interface Vlan1
    no ip address
    !
    interface Dialer0
    description PPPoE Interface
    mtu 1480
    ip ddns update hostname {取得ドメイン}
    ip ddns update MyDNS
    ip address negotiated previous
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    ip tcp adjust-mss 1440
    dialer pool 1
    dialer idle-timeout 0
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname {HOST}
    ppp chap password 7 {PASS}
    !
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    ip dns server
    ip nat pool TEST 192.168.30.1 192.168.30.1 netmask 255.255.255.0 type rotary
    ip nat inside source list PAT interface Dialer0 overload
    ip nat inside destination list TEST pool TEST
    ip route 0.0.0.0 0.0.0.0 Dialer0 permanent
    !
    ip access-list extended PAT
    permit ip 192.168.0.0 0.0.0.255 any
    permit ip 192.168.30.0 0.0.0.255 any
    ip access-list extended TEST
    permit tcp any any eq www
    permit tcp any any eq 443
    permit tcp any any eq 56498


    !
    dialer-list 1 protocol ip permit
    ipv6 ioam timestamp
    !
    !
    !
    !

    キャンセル

  • 2018/03/08 18:47

    投入Config形式で記載します。
    以下を投入すれば行けるはずです。
    ========================
    conf t
    !
    no ip nat inside destination list TEST pool TEST
    no ip nat pool TEST 192.168.30.1 192.168.30.1 netmask 255.255.255.0 type rotary
    no ip access-list extended TEST
    !
    ip nat inside source static tcp 192.168.30.1 80 interface Dialer0 80
    ip nat inside source static tcp 192.168.30.1 443 interface Dialer0 443
    ip nat inside source static tcp 192.168.30.1 56498 interface Dialer0 56498
    !
    end
    ========================

    なお、以下を前提として記載しています。
     ・インターネットアクセスはできている。
     ・MyDNSによるDDNS機能は正常動作している。(ドメインの名前解決が行える)
     ・公開したいサーバのIPアドレスは192.168.30.1(固定IP)
      ⇒もし違っていたら、投入Config記載の"192.168.30.1 "を全て公開したいサーバのIPアドレスに変えて使ってください。


    以上、お試しください。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.99%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Cisco

    68questions

    シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品

  • Network+

    38questions

    Network+とは、IT業界団体CompTIA認定のネットワーク技術に関する知識を証明する資格です。ネットワーク技術者として、実務で必要なネットワークセキュリティ・ネットワークアーキテクチャなどの知識を取得している証明となります。