質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.61%

  • Perl

    451questions

    Perlは多目的に使用される実用性が高い動的プログラミング言語のひとつです。

perlモジュールのバージョンアップ

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 417

skyopen

score 16

perlモジュール(具体的にはModule::Metadataというモジュール)のバージョンを
1.000000から1.000005以上に上げる方法を教えてください。

なお、cpanモジュール、CPANコマンドの設定はしていなく、使えないため、
その他の方法であると助かります。

<現状>
下記のコマンドで確認したかぎり、Module::Metadataのバージョンは1.000000だと考えております。
また、自分でModule::Metadataのversion1.000000をインストールした記憶があります。

perl -M'Module::Metadata' -e 'print $Module::Metadata::VERSION'


結果:1

<バージョンアップ失敗の流れ>
1) CPANで見ると、アップデートしたい1.000005のバージョンはないため、
それより上のバージョン1.000009をダウンロードしました。

CPANのModule::Metadata URL

2) バージョン1.000009のファイルを解凍し、解凍先フォルダに移動し、

perl ./Makefile.PL


を実行したところ、下記の警告がでました。

Checking if your kit is complete...
Looks good
Warning: prerequisite version 0.87 not found. We have 0.77.
Writing Makefile for Module::Metadata

<困っている点>
さきほど確認した通り、Module::Metadataのバージョンは1.000000のはずですが、
なぜか、「前提バージョンは0.87で、今(わたしたち)はバージョンは0.77です」
という警告文が出ています。

どのように、この警告をなくせばよいか(どのようにバージョンアップすればよいのか)
を可能であれば、具体的なコマンドも含め、ご教授いただければ大変助かります。

どうぞよろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

解決策はわかりませんが、エラーメッセージについてだけ。

Warning: prerequisite version 0.87 not found. We have 0.77.

これは、 version.pmの バージョン0.87が求められているのだと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/01/23 13:00

    ありがとうございます。おっしゃられるとおりでした。助かりました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 解決済

    【perl】Macintoshで,perlのモジュールの追加方法

     質問 MacOS 10.7.5でのperlのモジュールの追加方法及び,バージョンのアップデートを行いたいです.  行いたいこと ヤフーの日本語係り受け解析APIとサンプ

  • 解決済

    PDF::API3のインストールについて

    Perlを勉強中です。(Windows7、Perl v5.20.2)。  CPAN の PDF::API3(PDF-API3-3.001) モジュールをイントールして、Wor

  • 解決済

    各サーバのPerlモジュールインストール済みの比較

    お世話になっております。 kaoriと申します。 【今回やりたい事】 各サーバ(⓵と⓶)のインストール済みPerlモジュール一覧を取得しました。 各サーバで比較して⓵に

  • 解決済

    Windows PowerShellでWindows Task Schedulerのコマンドレットの...

    【背景】   Windows PowerShell ISEを使用してWindows Task Schedulerのコマンドレットの一覧を取得しようと した所Errorが出て正常

  • 解決済

    AnyEvent設置法及びコード記述

    ActivePerlのAnyEventというモジュールをインストールし解凍しました。このAnyEvent-7.13フォルダをどこにおいてソースコードにどのように記述するか注意点がご

  • 解決済

    MVC モデルのバリデーションについて

    モデルでアノテーション(Required)を指定しているプロパティが4つあります。 [Required] public string A { get; set;

  • 解決済

    Object::simple のインストール

    前提・実現したいこと オブジェクト指向について学ぶ為にObject::simpleなるものをインストールしようとしたのですが、なかなかうまくゆきません。 初歩的な質問ですが回答いた

  • 解決済

    pythonのrandom モジュール関連です

    前提・実現したいこと ここに質問したいことを詳細に書いてください (例)PHP(CakePHP)で●●なシステムを作っています。 ■■な機能を実装中に以下のエラーメッセージが発生し

同じタグがついた質問を見る

  • Perl

    451questions

    Perlは多目的に使用される実用性が高い動的プログラミング言語のひとつです。