質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.42%
CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

Apache

Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

Q&A

解決済

2回答

8513閲覧

phpを正常に動作させたい。

ringomilk

総合スコア22

CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

Apache

Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

0グッド

1クリップ

投稿2017/12/11 06:18

###前提・実現したいこと
下記の環境で、phpを正常に動作させたい。
ひとまず、ブラウザの検索窓にホスト名を入力して、index.phpを表示させたい
centOS = 6.9
php = 7.0
httpd = 2.4

###発生している問題・エラーメッセージ
・index.phpに書かれているソースがそのまま表示されてしまう。
→phpが動いていないと思われる。

###試したこと
・phpを動かすよう、httpd.confに下記の記述を追加
LoadModule php7_module modules/libphp7.so
⇒httpdを再起動させようとしたところ、下記のエラーが発生
エラー:undefined symbol:unixd_config

・調べたところ、php70-php-fpmを入れるとphpが動くとの情報があったため、
上記のLoadModuleの記述をコメントアウトし、php70-php-fpmをインストール。
⇒状況は変わらず。

###補足情報
・すべてyumでインストールしている

解決方法をご存知の方がいらっしゃいましたら、
ご教授のほどよろしくお願いいたします。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答2

0

・phpを動かすよう、httpd.confに下記の記述を追加

LoadModule php7_module modules/libphp7.so
⇒httpdを再起動させようとしたところ、下記のエラーが発生
エラー:undefined symbol:unixd_config

apache(2.4)起動せず。libphp5.so undefined symbol: unixd_config

これが該当しているようで、どうやら導入方法が誤っていますね。
Apache2.2へ戻すか、Apache2.4に対応したPHPモジュールを探しましょう。


・調べたところ、php70-php-fpmを入れるとphpが動くとの情報があったため、

上記のLoadModuleの記述をコメントアウトし、php70-php-fpmをインストール。

PHP-FPMは普通のApache連携(PHPモジュール利用)とは異なるやり方です。
PHP-FPMを使った事が無いので曖昧ですが、Apacheとは完全別にプロセスを起動して、つなぎこむように設定変更するんでしたっけ?
もしPHP-FPMを使うのであれば色々探して連携方法を確認してみましょう。

投稿2017/12/11 06:34

miyabi-sun

総合スコア21170

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

ベストアンサー

epel-httpd24 リポジトリでインストールした httpd24は パッケージインストーラーのPHP連携に対応していません。

  1. ソースからインストールする
  2. CENTOS 7.x を利用する
  3. HTTPD 2.2.x を利用する
  4. php-fpmを利用する。

投稿2017/12/11 22:54

退会済みユーザー

退会済みユーザー

総合スコア0

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.42%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問