質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.37%

  • Ruby

    5166questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    5037questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 5

    76questions

サーバーのエラーでアプリを起動出来なくなりました

解決済

回答 1

投稿 2017/12/01 22:18 ・編集 2017/12/02 00:29

  • 評価
  • クリップ 0
  • VIEW 67

ninpig04

score 8

昨日までは何も問題無くアプリをローカルホストで起動できていたのに、今日いきなり出来なくなりました。

以下のようなエラーが表示されます。

Puma caught this error: Invalid option key: raise_on_unfiltered_parameters= (RuntimeError)
/Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_controller/railtie.rb:60:in block (3 levels) in <class:Railtie>' /Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_controller/railtie.rb:55:in each'
/Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_controller/railtie.rb:55:in block (2 levels) in <class:Railtie>' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/lazy_load_hooks.rb:43:in instance_eval'
/Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/lazy_load_hooks.rb:43:in execute_hook' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/lazy_load_hooks.rb:50:in block in run_load_hooks'
/Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/lazy_load_hooks.rb:49:in each' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/lazy_load_hooks.rb:49:in run_load_hooks'
/Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_controller/base.rb:269:in <class:Base>' /Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_controller/base.rb:164:in <module:ActionController>'
/Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_controller/base.rb:5:in <top (required)>' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/dependencies.rb:293:in require'
/Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/dependencies.rb:293:in block in require' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/dependencies.rb:259:in load_dependency'
/Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/dependencies.rb:293:in require' /Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_dispatch/middleware/static.rb:77:in ext'
/Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_dispatch/middleware/static.rb:33:in match?' /Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_dispatch/middleware/static.rb:130:in call'
/Library/Ruby/Gems/2.3.0/gems/rack-2.0.3/lib/rack/sendfile.rb:111:in call' /Library/Ruby/Gems/2.3.0/gems/railties-5.0.3/lib/rails/engine.rb:522:in call'
/Library/Ruby/Gems/2.3.0/gems/puma-3.6.2/lib/puma/configuration.rb:225:in call' /Library/Ruby/Gems/2.3.0/gems/puma-3.6.2/lib/puma/server.rb:578:in handle_request'
/Library/Ruby/Gems/2.3.0/gems/puma-3.6.2/lib/puma/server.rb:415:in process_client' /Library/Ruby/Gems/2.3.0/gems/puma-3.6.2/lib/puma/server.rb:275:in block in run'
/Library/Ruby/Gems/2.3.0/gems/puma-3.6.2/lib/puma/thread_pool.rb:116:in `block in spawn_thread'

なにが悪いのでしょうか 昨日から今日までの間にやったことと言えば、スキャホルドを使って別のアプリを作成してサーバーで起動したことはあります これが何か関係しているのでしょうか? よろしくお願いします

os:mac Ruby 2.3.1 RoR 5.0.0

追記です

ターミナルの方では次のようなエラーが出ています

<RuntimeError: Invalid option key: raise_on_unfiltered_parameters=>

/Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_controller/railtie.rb:60:in block (3 levels) in <class:Railtie>' /Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_controller/railtie.rb:55:in each' /Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_controller/railtie.rb:55:in block (2 levels) in <class:Railtie>' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/lazy_load_hooks.rb:43:in instance_eval' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/lazy_load_hooks.rb:43:in execute_hook' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/lazy_load_hooks.rb:50:in block in run_load_hooks' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/lazy_load_hooks.rb:49:in each' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/lazy_load_hooks.rb:49:in run_load_hooks' /Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_controller/base.rb:269:in <class:Base>' /Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_controller/base.rb:164:in <module:ActionController>' /Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_controller/base.rb:5:in <top (required)>' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/dependencies.rb:293:in require' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/dependencies.rb:293:in block in require' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/dependencies.rb:259:in load_dependency' /Library/Ruby/Gems/2.3.0/gems/activesupport-5.0.3/lib/active_support/dependencies.rb:293:in require' /Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_dispatch/middleware/static.rb:77:in ext' /Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_dispatch/middleware/static.rb:33:in match?' /Library/Ruby/Gems/2.3.0/gems/actionpack-5.0.3/lib/action_dispatch/middleware/static.rb:130:in call' /Library/Ruby/Gems/2.3.0/gems/rack-2.0.3/lib/rack/sendfile.rb:111:in call' /Library/Ruby/Gems/2.3.0/gems/railties-5.0.3/lib/rails/engine.rb:522:in call' /Library/Ruby/Gems/2.3.0/gems/puma-3.6.2/lib/puma/configuration.rb:225:in call' /Library/Ruby/Gems/2.3.0/gems/puma-3.6.2/lib/puma/server.rb:578:in handle_request' /Library/Ruby/Gems/2.3.0/gems/puma-3.6.2/lib/puma/server.rb:415:in process_client' /Library/Ruby/Gems/2.3.0/gems/puma-3.6.2/lib/puma/server.rb:275:in block in run' /Library/Ruby/Gems/2.3.0/gems/puma-3.6.2/lib/puma/thread_pool.rb:116:in `block in spawn_thread'

今サーバーを立ち上げたら以下のようなエラーメッセージに変わりました.ご確認よろしくお願いします。

LoadError in HomeController#about
cannot load such file -- coffee_script

<%= csrf_meta_tags %>

<%= stylesheet_link_tag    'application', media: 'all', 'data-turbolinks-track': 'reload' %>
<%= javascript_include_tag 'application', 'data-turbolinks-track': 'reload' %>

<!-- FontAwesomeを読み込むlinkタグを追加してください -->

Rails.root: /Users/mypc/Desktop/tweet_app

Application Trace | Framework Trace | Full Trace
app/views/layouts/application.html.erb:7:in `_app_views_layouts_application_html_erb__3621528497525677648_70092340496000'
This error occurred while loading the following files:
sprockets/autoload/coffee_script
coffee_script
Request

Parameters:

None
Toggle session dump
Toggle env dump
Response

Headers:

None
x

 

application.html.erbのなかの
<%= stylesheet_link_tag    'application', media: 'all', 'data-turbolinks-track': 'reload' %>
<%= javascript_include_tag 'application', 'data-turbolinks-track': 'reload' %>
の2行を削除すると、表示されることはされました
なぜこの2行を追加するとエラーが出るのかはわまりません

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+2

 まとめ

bundle exec を用いて、各プロジェクトに対応したバージョンの Rails サーバを立ち上げるようにしましょう

bundle e rails s

 バージョン番号について

os:mac Ruby 2.3.1 RoR 5.0.0

Rails のバージョンが 5.0.0 であると表記されていますが、エラーメッセージを見るとバージョンに関わる文字列に 5.0.3 という数字が並んでいるところが気になります(バージョン番号の食い違い?)

 バージョン間の違い

RailsDiff で両者の差分を確認してみると : http://railsdiff.org/5.0.0/5.0.3

関連の有りそうな情報として config/initializers/new_framework_defaults.rb というファイルに、 Rails.application.config.raise_on_unfiltered_parameters = true の行が追加されています

標準で利用されるrails コマンドのバージョンの違いで、何か問題が発生しているのかもしれません

 インストール済みRails のバージョンについて

スキャホルドを使って別のアプリを作成してサーバーで起動したことはあります これが何か関係しているのでしょうか

新しくRails プロジェクトを作成する際に(とくにGemfile の作成と bundle install 前後?)、より新しいバージョンがインストールされたのかもしれません

# インストールされたRails gem の一覧を確認
gem list -l "^rails$"

 指定バージョンを使う

bundler gem の機能として、Gemfile/Gemfile.lock に記述されているバージョン番号のgem を使用するコマンドが用意されています

それで、プロジェクトごとの指定 gem を使用してみるのがいいのかもしれません

Gemfile のあるディレクトリで:

bundle exec rails server

以上、かんたんに妄想してみましたが、何か参考になれば幸いです

 Links


投稿 2017/12/01 23:59

編集 2017/12/02 04:01

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/12/02 00:10

    bundle e rails sを試してみましたがダメでした。その後Gemfileのあるディレクトリでも試しましたが、やはりダメでした。また、gem version railsをターミナルで実行するとERROR: While executing gem ... (Gem::CommandLineError)
    Unknown command version
    と表示されてしまいます。
    昨日までは普通にアプリが立ち上がって居て、コードは一切弄っていないのに、なぜこうなったかが分かりません

    なぜかRubyのバージョンが2.3.3になっておりrailsのバージョンは5.0.6担っていました

    キャンセル

  • 2017/12/02 00:19

    エラーメッセージの内容が変わりました。ご確認お願いします。

    キャンセル

  • 2017/12/02 03:59

    すみません、gem のバージョン確認は 「gem list -l rails」でした

    キャンセル

  • 2017/12/02 04:10

    rake tmp:cache:clear を実行してみるなど、いくつか方法がありそうです
    エラーメッセージで検索してみると、解決に近付くかもしれません: 「cannot load such file -- coffee_script」

    キャンセル

  • 2017/12/02 04:10

    gem coffee scriptを追加したらうまく動きました!
    ありがとうございました

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.37%

関連した質問

同じタグがついた質問を見る

  • Ruby

    5166questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    5037questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 5

    76questions