質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.49%

  • Vim

    517questions

    VimとはUnix / Linux 系のOSに標準搭載されているターミナル上で動くテキストエディタです。

vimのvimrc NeoBundleとプラグイン

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 3,302

2634_x

score 1


mkdir -p ~/.vim/bundle
git clone git://github.com/Shougo/neobundle.vim ~/.vim/bundle/neobundle.vim
上記でneobundleをインストールしました。
下記で確認したところ、neobundle.vimが確認できました。
cd ~/.vim/bundle
ls

/usr/share/vim/vimrcをvimで次のように編集。
~//一部省略

 14 set number
 15 set tabstop=4
 16 set autoindent
 17 
 18 call neobundle#begin(expand('~/.vim/bundle'))
 19 let g:neobundle_default_git_protocol='https'
 20 
 21 NeoBundleFetch 'Shougo/neobundle.vim'
 22 
 23 NeoBundle 'kana/smartinput'
 24 
 25 NeoBundleCheck
 26 call neobundle#end()
 27 filetype plugin indent on
しかしErrorで
Error detected while processing /usr/share/vim/vimrc:
line   18:
E117: Unknown function: neobundle#begin
line   21:
E492: Not an editor command: NeoBundleFetch 'Shougo/neobundle.vim'
line   23:
E492: Not an editor command: NeoBundle 'kana/smartinput'
line   25:
E492: Not an editor command: NeoBundleCheck
line   26:
E117: Unknown function: neobundle#end
のようになり、うまくいっていません。
kana/smartinputのプラグインを導入し動作確認まで行いたいです。
原因と解決方法をご存知の方いらっしゃいましたら、ご教授お願いいたします。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

GitHub でのインストール手順と見比べてみたところ、

set runtimepath+=~/.vim/bundle/neobundle.vim/

runtimepath にプラグインを追加する記述が抜けているようです

そのほか、うまくいかない所があれば 一度、同ページのQuick start を参照してみてください

## Links

Shougo/neobundle.vim - GitHub
Shougo/neobundle.vim / Quick start - GitHub

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/05/25 10:27

    回答投稿ありがとうございます。
    回答いただいた上記コードを記述してもエラーがででました。
    ~/.vim/bundleディレクトリのパーミッションなども確認しましたが、問題ありませんでした。
    色々調べたところ、以下の
    set runtimepath += ~/.vim/bundle/neobundle.vim/  と
    call neobundle#begin(expand('~/.vim/bundle'))
    の2行のパスが、相対パスでなく絶対パスである必要がある記述を見つけたので
    絶対パスに変更してみたところ、うまくできました。

    ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.49%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Vim

    517questions

    VimとはUnix / Linux 系のOSに標準搭載されているターミナル上で動くテキストエディタです。