質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.36%

  • Android

    5156questions

    Androidは、Google社が開発したスマートフォンやタブレットなど携帯端末向けのプラットフォームです。 カーネル・ミドルウェア・ユーザーインターフェイス・ウェブブラウザ・電話帳などのアプリケーションやソフトウェアをひとつにまとめて構成。 カーネル・ライブラリ・ランタイムはほとんどがC言語/C++、アプリケーションなどはJavaSEのサブセットとAndroid環境で書かれています。

  • Android Studio

    2708questions

    Android Studioは、 Google社によって開発された、 Androidのネイティブアプリケーション開発に特化した統合開発ツールです。

android studio ビルド エラー

受付中

回答 1

投稿 2017/11/23 17:10

  • 評価
  • クリップ 0
  • VIEW 70

kazuyy14

score 1

android studioで新規プロジェクトをビルドした時に以下のエラーが出ます。

Failed to resolve: com.android.support:appcompat-v7:27.+


よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

最低でもAndroid Studioのバージョンは記してもらいたいのですが、3.0ではないようですね。3.0なら新規プロジェクト作成でそのような出力にはならないので。

build.gradle (Project:xxx)
(xxxはプロジェクト名)

というファイルにあるallprojectsというブロックに、

allprojects {
    repositories {
        jcenter()
        maven { url 'https://maven.google.com/' }
    }
}

のようにmavenという行を追加して再同期したら改善しないでしょうか?

投稿 2017/11/23 18:55

編集 2017/11/23 18:56

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/11/23 23:49

    バージョンは2.3.3です。ビルドはできました。しかし、MainActivity.javaのpackageにThe SDK platform-tools version (26.0.2) is too old to check APIs compiled with API 27と出ます。

    キャンセル

  • 2017/11/24 01:27

    なんだろう?と思って2.3.3をセットアップして確認してみましたが、確かに出ますね。どうもcompileSdkVersionが27だと消せないようです。API 27はまだ暫定リリースなので、何か問題があるのかもしれません。

    改善策ですが、SDK ManagerでAPI 26のSDK Platformと、SDK Build Tools 26.0.3をインストールしましょう。Build Toolsは、SDK Managerの右下の方にあるShow package detailsにチェックを入れればリスト展開できるようになり、リビジョンを指定してインストールできるようになるので、その中から選択します。

    インストールしたら、build.gradle (Module:app) を開いて、compileSdkVersionを26、buildToolsVersionを26.0.3、targetSdkVersionを26以下の値にし、下の方にあるdependenciesブロックで

    dependencies {
    // 略
    compile 'com.android.support:appcompat-v7:26.1.0'
    // 略
    }

    のようにサポートライブラリーのバージョンを指定してください。これでpackage文の赤波線を消せると思います。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.36%

関連した質問

同じタグがついた質問を見る

  • Android

    5156questions

    Androidは、Google社が開発したスマートフォンやタブレットなど携帯端末向けのプラットフォームです。 カーネル・ミドルウェア・ユーザーインターフェイス・ウェブブラウザ・電話帳などのアプリケーションやソフトウェアをひとつにまとめて構成。 カーネル・ライブラリ・ランタイムはほとんどがC言語/C++、アプリケーションなどはJavaSEのサブセットとAndroid環境で書かれています。

  • Android Studio

    2708questions

    Android Studioは、 Google社によって開発された、 Androidのネイティブアプリケーション開発に特化した統合開発ツールです。