質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.02%

  • Ruby on Rails 4

    2309questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

rails sでローカルサーバーを立ち上げたいのですが、以下のエラーが出てしまいます。

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 179

shumbow

score 1

初めての投稿で見にくいと思いますがご教授いただきたく思います。
rails sをすると以下のようにエラーが出てしまいます。
rubyとrailsはプロジェクトフォルダにローカルインストールしました。rubyのバージョンは2.3.0、railsは4.2.6です。
(https://qiita.com/emadurandal/items/e43c4896be1df60caef0の記事を参考にさせていただきました)

cat << EOS > Gemfile
source "http://rubygems.org"
gem "rails", "4.2.6”
EOS


そのあと記事の通りにbundle installして、’$ bundle exec rails server ’でサーバーを立ち上げたのですが、下のようなエラーが出てしまいます。SQLite3をインストールするということでよいのでしょうか?またローカル環境にインストールする方法を教えていただけないでしょうか?
イメージ説明
イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • gouf

    2017/11/19 20:09

    接続拒否の前にエラーで落ちてますね... Ruby 2.3 系にバージョンを下げるか、あるいはRails 4.2.8 以上にバージョンを設定する必要がありそうです。参照: * [Ruby 2.4 and Rails 4 stack level too deep (SystemStackError) - Stack Overflow]( https://stackoverflow.com/questions/41504106/ruby-2-4-and-rails-4-stack-level-too-deep-systemstackerror )

    キャンセル

  • shumbow

    2017/11/19 21:28

    rubyのバージョンを2.3.0に下げたところ上手くいきました!参照まで提示くださり本当にありがとうございました!

    キャンセル

  • gouf

    2017/11/19 21:51

    解決できた場合は、どのように解決されたのかをまとめて自己回答し、それをベストアンサーに設定して質問を終了してください

    キャンセル

回答 1

check解決した方法

0

ローカル環境に、特定のバージョンのrailsを作りたいときは、そのディレクトリにGemfileを作成し、bundle install -path vendor/bundleなどとして一時的ににインストールする(使い捨て用としてなので、このディレクトリに残ったGemfile関連は後で消去)。そこでGemfile.lockができるので、そうしたらbundle exec(←ローカルのgemを使うためのコマンド)rails new として、プロジェクトを立ち上げる。この時点で、最初のファイルで作った使い捨て用のGemfile関連は捨ててしまって良い。
さらに再びプロジェクト先でbundle install -path vendor/bundleして、プロジェクト先でGemをインストールする。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 91.02%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby on Rails 4

    2309questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。