質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.54%
SQLite

SQLiteはリレーショナルデータベース管理システムの1つで、サーバーではなくライブラリとして使用されている。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Q&A

解決済

1回答

1280閲覧

sqlightのインストールに関するエラーを解消したい

mimura15

総合スコア1

SQLite

SQLiteはリレーショナルデータベース管理システムの1つで、サーバーではなくライブラリとして使用されている。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

1グッド

1クリップ

投稿2023/01/26 04:02

前提

railsを使うにあたって必要なソフトウェアをインストールしようとした際にエラーが発生しました。

実現したいこと

ここに実現したいことを箇条書きで書いてください。

  • sqlightを使える状態にしたい

発生している問題・エラーメッセージ

インストールコマンドをまとめたファイルをダウンロードし、実行したところエラーが発生しました。

ERROR: Error installing sqlite3: The last version of sqlite3 (>= 0) to support your Ruby & RubyGems was 1.6.0. Try installing it with `gem install sqlite3 -v 1.6.0` sqlite3 requires Ruby version >= 2.7, < 3.3.dev. The current ruby version is 2.6.3.62.

該当のソースコード

# SQLiteをインストール wget https://www.sqlite.org/2021/sqlite-autoconf-3360000.tar.gz tar xzvf sqlite-autoconf-3360000.tar.gz cd sqlite-autoconf-3360000/ ./configure --prefix=/opt/sqlite/sqlite3 make sudo make install /opt/sqlite/sqlite3/bin/sqlite3 --version gem pristine --all gem install sqlite3 -- --with-sqlite3-include=/opt/sqlite/sqlite3/include --with-sqlite3-lib=/opt/sqlite/sqlite3/lib echo 'export LD_LIBRARY_PATH="/opt/sqlite/sqlite3/lib"' >> ~/.bash_profile

試したこと

エラーの内容から、gem install sqlite3をgem install sqlite3 -v 1.6.0に変更しインストールしなおしましたが、うまくいきませんでした。

補足情報(FW/ツールのバージョンなど)

以下が必要なソフトウェアのコマンドをまとめたenvironment.shです。

#!/bin/sh # Railsをインストール gem install rails -v 6.1.4 # Node.js, Yarnをインストール npm install -g yarn # ImageMagickをインストール sudo yum -y install libpng-devel libjpeg-devel libtiff-devel libxml2-devel gcc cd git clone https://github.com/ImageMagick/ImageMagick.git ImageMagick-7.1.0-5 cd ImageMagick-7.1.0-5 ./configure make sudo make install cd # SQLiteをインストール wget https://www.sqlite.org/2021/sqlite-autoconf-3360000.tar.gz tar xzvf sqlite-autoconf-3360000.tar.gz cd sqlite-autoconf-3360000/ ./configure --prefix=/opt/sqlite/sqlite3 make sudo make install /opt/sqlite/sqlite3/bin/sqlite3 --version gem pristine --all gem install sqlite3 -- --with-sqlite3-include=/opt/sqlite/sqlite3/include --with-sqlite3-lib=/opt/sqlite/sqlite3/lib echo 'export LD_LIBRARY_PATH="/opt/sqlite/sqlite3/lib"' >> ~/.bash_profile
shinoharat👍を押しています

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答1

0

ベストアンサー

エラーメッセージに

sqlite3 requires Ruby version >= 2.7, < 3.3.dev. The current ruby version is 2.6.3.62.

と出ているので、 ruby のバージョンが古すぎるのかなと思います。

ruby のバージョンを上げてみてはどうでしょう?

投稿2023/01/26 07:31

shinoharat

総合スコア1669

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

mimura15

2023/01/27 08:01

ありがとうございます! rubyのバージョンをあげたら、無事にインストールできました
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.54%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

同じタグがついた質問を見る

SQLite

SQLiteはリレーショナルデータベース管理システムの1つで、サーバーではなくライブラリとして使用されている。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。