回答編集履歴

1

誤字修正

2024/04/21 01:23

投稿

IT001
IT001

スコア620

test CHANGED
@@ -1,6 +1,9 @@
1
1
  Herokuに詳しくないのですが、OpenJDK 8 (1.8)で動いているように見えます。(Spring Boot 3はJDK17以上が必要となります)
2
2
  > Installing OpenJDK 1.8... done
3
3
  https://devcenter.heroku.com/ja/articles/java-support#supported-java-versions
4
+
5
+ 日本語版の方には記載がないのですが、OpenJDK 21も設定できるようです。
6
+ https://devcenter.heroku.com/articles/java-support#supported-java-versions
4
7
 
5
8
  ---
6
9
  尚、Herokuの方は21で動いておりますでしょうか。もし、エラーメッセージに1.8や8などの文字が含まれているなら、Herokuの方がOpenJDK 8で動いている可能性があります。