回答編集履歴

1 補足記載

tearoom6

tearoom6 score 10

2019/09/13 08:32  投稿

同じ問題に当たって、検索中に通りすがったので、もう解決済みとは思いますが、書いておきます。
dein.vim が依存している同じ開発者の方のライブラリのバグのようです。
dein.vim が依存している同じ開発者の方のライブラリのバグ(? Vim バージョンを上げたら起きたので、 Vim 仕様変更に伴うエラーかも)のようです。
最新にすれば直っているようなので、 rm -rf .vim/dein (心配なら mv でどこかに移しておいてください) して、 vim を開け直せばエラーは消えると思われます。
https://github.com/Shougo/neomru.vim/issues/47

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る