回答編集履歴

2 リンク修正

xenbeat

xenbeat score 4074

2018/04/18 13:42  投稿

> error creating **overlay mount** to **/var/lib/docker/overlay2**/94a0c0d4a7322430a2b1375c0cf42ac2c04bcb74a7f48b2ef24bc00177b58f62/merged
Dockerのバグ(仕様)かと思われます。
[https://github.com/moby/moby/issues/23930](https://github.com/moby/moby/issues/23930)
OverlayFS(overlay2)は、Docker CEの場合カーネルバージョンが4.0以上でしか正式にサポートされていないので、ストレージドライバをoverlay2からdevicemapperに変更するか、カーネルのバージョンを上げるしかなさそうです。。。
[https://docs.docker.com/storage/storagedriver/overlayfs-driver/#prerequisites](https://docs.docker.com/storage/storagedriver/overlayfs-driver/#prerequisites)
[https://docs.docker.com/storage/storagedriver/overlayfs-driver/](https://docs.docker.com/storage/storagedriver/overlayfs-driver/)
1 追記

xenbeat

xenbeat score 4074

2018/04/18 13:40  投稿

> error creating **overlay mount** to **/var/lib/docker/overlay2**/94a0c0d4a7322430a2b1375c0cf42ac2c04bcb74a7f48b2ef24bc00177b58f62/merged  
 
Dockerのバグ(仕様)かと思われます。
[https://github.com/moby/moby/issues/23930](https://github.com/moby/moby/issues/23930)
OverlayFS(overlay2)は、Docker CEの場合カーネルバージョンが4.0以上でしか正式にサポートされていないので、ストレージドライバをoverlay2からdevicemapperに変更するか、カーネルのバージョンを上げるしかなさそうです。。。
[https://docs.docker.com/storage/storagedriver/overlayfs-driver/#prerequisites](https://docs.docker.com/storage/storagedriver/overlayfs-driver/#prerequisites)

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る