回答編集履歴

1 追記

aro10

aro10 score 4004

2017/07/29 00:54  投稿

[Laravel 5.4 インストール](https://readouble.com/laravel/5.4/ja/installation.html)
> LaravelはComposerを依存パッケージの管理に使用しています。ですから、Laravelを始める前に、自分の開発機にComposerを確実にインストールしておいてください。
Laravelを利用する前提として、PHPのパッケージ管理システムのcomposerをまずはインストールする必要があります(Rubyのgemのようなものです)
CentOSへのインストールは下記記事などを参考にしてください
[CentOS7にComposerをインストールする](http://qiita.com/inakadegaebal/items/d370bcb1627fce2b5cd1)
/bootstrap/autoload.php on line 17エラーは
Laravelのプロジェクトディレクトリで、composer.jsonの情報を元にcomposer install コマンドを叩くことで、vendorにLaravelに必要なパッケージがインストールされて動くようになります。
Laravelのプロジェクトディレクトリで、composer.jsonの情報を元にcomposer install コマンドを叩くことで、vendorにLaravelに必要なパッケージがインストールされて動くようになります。
laravel newを行った場合は、インストールプログラムがcomposer install等も一緒にやってくれます

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る