質問編集履歴

2

takahayaboys

takahayaboys score 17

2017/10/01 08:18  投稿

import RxSwiftが出来ない
xcodeでプロジェクトを開きimport RxSwiftを書いてもNo such module 'RxSwift'
というエラーが出てしまいます。
cocoapodsをインストールして.xcodeprojファイルのあるフォルダにpod initしpodfileを作成しました。
ファイル内の内容を下記に変更
```ここに言語を入力
# Uncomment the next line to define a global platform for your project
# platform :ios, '9.0'
target 'Test' do
# Comment the next line if you're not using Swift and don't want to use dynamic frameworks
use_frameworks!
pod 'RxSwift', '~> 3.0'
pod 'RxCocoa', '~> 3.0'
target 'TestTests' do
inherit! :search_paths
# Pods for testing
end
target 'TestUITests' do
inherit! :search_paths
# Pods for testing
end
end
```
その後にpod install開始
Analyzing dependencies
Downloading dependencies
Installing RxCocoa (3.6.1)
Installing RxSwift (3.6.1)
Generating Pods project
Integrating client project
[!] Please close any current Xcode sessions and use `Test.xcworkspace` for this project from now on.
Sending stats
Pod installation complete! There are 2 dependencies from the Podfile and 2 total pods installed.
最後の方に
[!] Automatically assigning platform ios with version 11.0 on target Test because no platform was specified. Please specify a platform for this target in your Podfile. See `https://guides.cocoapods.org/syntax/podfile.html#platform`.
という、メッセージが黄色っぽい文字で書かれているので警告か何かでしょうか?
ちなみにcocoapodsのバージョンは1.3.1です
何が悪いのかさっぱりわからなくなってしまいました。
わかる方がいましたら教えて下さい!!
よろしくお願いします。
追記
podfileのplatformのコメントアウトを外したら正常にインストールされたっぽいん
ですけど、同じくソースコードでimport RxSwiftを記述してもエラーが出てしまいます。
ビルドするとエラーが7個ぐらい出てtoIntMax()のところにエラーが表示されています。
xcode9ではRxSwiftは使えないのでしょうか?
勉強したいのですが前に進めず.......
どなたか知ってる方いませんか??
  • RxSwift

    35 questions

    RxSwiftは、Reactive ExtensionsのSwift向けの実装です。iOS開発に用いられ、リアクティブプログラミングを可能にします。

1 追記

takahayaboys

takahayaboys score 17

2017/09/30 00:54  投稿

import RxSwiftが出来ない
xcodeでプロジェクトを開きimport RxSwiftを書いてもNo such module 'RxSwift'
というエラーが出てしまいます。
cocoapodsをインストールして.xcodeprojファイルのあるフォルダにpod initしpodfileを作成しました。
ファイル内の内容を下記に変更
```ここに言語を入力
# Uncomment the next line to define a global platform for your project
# platform :ios, '9.0'
target 'Test' do
 # Comment the next line if you're not using Swift and don't want to use dynamic frameworks
 use_frameworks!
 pod 'RxSwift',   '~> 3.0'
 pod 'RxCocoa',   '~> 3.0'
 target 'TestTests' do
   inherit! :search_paths
   # Pods for testing
 end
 target 'TestUITests' do
   inherit! :search_paths
   # Pods for testing
 end
end
```
その後にpod install開始
Analyzing dependencies
Downloading dependencies
Installing RxCocoa (3.6.1)
Installing RxSwift (3.6.1)
Generating Pods project
Integrating client project
[!] Please close any current Xcode sessions and use `Test.xcworkspace` for this project from now on.
Sending stats
Pod installation complete! There are 2 dependencies from the Podfile and 2 total pods installed.
最後の方に
[!] Automatically assigning platform ios with version 11.0 on target Test because no platform was specified. Please specify a platform for this target in your Podfile. See `https://guides.cocoapods.org/syntax/podfile.html#platform`.
という、メッセージが黄色っぽい文字で書かれているので警告か何かでしょうか?
ちなみにcocoapodsのバージョンは1.3.1です
何が悪いのかさっぱりわからなくなってしまいました。
わかる方がいましたら教えて下さい!!
よろしくお願いします。
よろしくお願いします。
追記
podfileのplatformのコメントアウトを外したら正常にインストールされたっぽいん
ですけど、同じくソースコードでimport RxSwiftを記述してもエラーが出てしまいます。
ビルドするとエラーが7個ぐらい出てtoIntMax()のところにエラーが表示されています。
xcode9ではRxSwiftは使えないのでしょうか?
勉強したいのですが前に進めず.......
どなたか知ってる方いませんか??
  • RxSwift

    35 questions

    RxSwiftは、Reactive ExtensionsのSwift向けの実装です。iOS開発に用いられ、リアクティブプログラミングを可能にします。

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る