質問編集履歴

1 付け足し

hiroppii

hiroppii score 34

2016/06/06 22:30  投稿

centos6にphp5.6のphp-gdをインストールしたい。
###前提・実現したいこと
centos6にphp5.6のphp-gdをインストールしたいです。
###発生している問題・エラーメッセージ
php5.4のphp-gdは、インストールできるのになぜ、5.6のphp-gdがインストール出来ないのかがわかりません。
下記の回答を見たのですが、調べても結局、具体的にはどういうコマンドでインストールしたら良いのか、わからなかったので新たに質問させて頂きました。
https://teratail.com/questions/19002
```
# yum install --enablerepo=remi --enablerepo=remi-php56 php-gd
読み込んだプラグイン:fastestmirror, security
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
* base: ftp.iij.ad.jp
* extras: ftp.iij.ad.jp
* remi: mirror.innosol.asia
* remi-php56: mirror.innosol.asia
* remi-safe: mirror.innosol.asia
* updates: ftp.iij.ad.jp
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package php-gd.x86_64 0:5.6.22-1.el6.remi will be インストール
--> 依存性の処理をしています: gd-last(x86-64) >= 2.1.1 のパッケージ: php-gd-5.6.22-1.el6.remi.x86_64
--> 依存性の処理をしています: libvpx.so.1()(64bit) のパッケージ: php-gd-5.6.22-1.el6.remi.x86_64
--> 依存性の処理をしています: libgd.so.3()(64bit) のパッケージ: php-gd-5.6.22-1.el6.remi.x86_64
--> トランザクションの確認を実行しています。
---> Package gd-last.x86_64 0:2.2.1-2.el6.remi will be インストール
--> 依存性の処理をしています: libwebp.so.5()(64bit) のパッケージ: gd-last-2.2.1-2.el6.remi.x86_64
---> Package libvpx.x86_64 0:1.3.0-5.el6_5 will be インストール
--> 依存性解決を終了しました。
エラー: パッケージ: gd-last-2.2.1-2.el6.remi.x86_64 (remi)
            要求: libwebp.so.5()(64bit)
問題を回避するために --skip-broken を用いることができません
これらを試行できます: rpm -Va --nofiles --nodigest
#
# yum install --enablerepo=remi --enablerepo=remi-php56 gd-last
読み込んだプラグイン:fastestmirror, security
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
* base: ftp.iij.ad.jp
* extras: ftp.iij.ad.jp
* remi: mirror.innosol.asia
* remi-php56: mirror.innosol.asia
* remi-safe: mirror.innosol.asia
* updates: ftp.iij.ad.jp
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package gd-last.x86_64 0:2.2.1-2.el6.remi will be インストール
--> 依存性の処理をしています: libwebp.so.5()(64bit) のパッケージ: gd-last-2.2.1-2.el6.remi.x86_64
--> 依存性解決を終了しました。
エラー: パッケージ: gd-last-2.2.1-2.el6.remi.x86_64 (remi)
            要求: libwebp.so.5()(64bit)
問題を回避するために --skip-broken を用いることができません
これらを試行できます: rpm -Va --nofiles --nodigest
#
# yum install libtiff
読み込んだプラグイン:fastestmirror, security
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
* base: ftp.iij.ad.jp
* extras: ftp.iij.ad.jp
* remi-safe: mirror.innosol.asia
* updates: ftp.iij.ad.jp
パッケージ libtiff-3.9.4-10.el6_5.x86_64 はインストール済みか最新バージョンです
何もしません
#
```
###試したこと
下記では、php5.4のphp-gdがインストール出来たのを確認出来ました。
その際、インストールしているphp5.6は削除し、php5.4をイントールし直しました。  
 
yum --enablerepo=remi,remi-php install php-gd
###補足情報(言語/FW/ツール等のバージョンなど)
centos6、php5.6
  • PHP

    37364 questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • CentOS

    4719 questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る