質問するログイン新規登録

質問編集履歴

1

修正

2020/09/30 06:54

投稿

ami613
ami613

スコア20

title CHANGED
@@ -1,1 +1,1 @@
1
- 【Tomcat】メモリ不足によるエラーの解消方法【EC2】
1
+ APサーバーが落ちた時の対処方法【再起動はトラブル予防の一環?】
body CHANGED
@@ -1,5 +1,5 @@
1
1
  # 前提
2
- SpringやAWS学習中の者です。
2
+ Java、AWS等を学習している者です。
3
3
  SpringBootで作成したwarを、EC2にインストールしたTomcatに載せています。
4
4
  catalina.outに下記の様なエラーが出ていて、サーバーにリクエストできなくなっていました。
5
5
 
@@ -14,11 +14,29 @@
14
14
  ```
15
15
 
16
16
  # 考えていること
17
- ざっと調べた感じ、メモリが足りていないのかな?と思いました(←この認識で合っているでしょうか?)
17
+ エラー文を読むと、メモリが足りなくなって落ちていることがわかりました。
18
- これを解消するために、以下2つのアプローチを考えたのですが、的外れではないでしょうか?
18
+ 根本原因は引き続き調査するとして、対処療法的な?回避策として、下記の様な記事がありました。
19
19
 
20
- **① Tomcatの設定をいじる**
21
- **② EC2のスペック上げる ※学習用なので、インスタンスタイプは無料枠のものです**
20
+ [システム監視における再起動の役割](https://www.sherpasuite.net/column/management/193/)
22
21
 
22
+ 曰く、**再起動は“トラブル予防の一環”** とのこと。
23
- インフラ、ミドルウェアに関する知識がほぼなく、問題解決のアプローチ方法の相談になります。
23
+ 毎日cronで再起動すれば、上記のエラーも解消されそうな気がしていて、試してみるつもりです。
24
+ このように定期的に再起動することは、実際の開発現場でもあることなのでしょうか?
25
+
26
+
27
+ また、更に調べると、
28
+
29
+ [Tomcatのサービスが異常終了していたら起動コマンドを実行するスクリプト](https://hacknote.jp/archives/295/)
30
+
24
- まとまりがなく申し訳ないのですが、何かお気づきの点ありましたらコメントいただけますと幸いです。
31
+ cronで毎分、Tomcatのステータスをチェックし、異常時には再起動するようです。
32
+ こういったことも、実際の開発現場であることでしょうか?
33
+
34
+ 個人的には、まずはAPサーバーを落ちないように設計することが第一と考え、
35
+ その保険として上記のような保険があると良いのかなと思いました。
36
+
37
+ しかし私は経験に乏しく、
38
+ 「これって本当に対処法としてありなのか?」
39
+ 「現実としてやっている開発現場はあるのか?」
40
+ といった疑問があり、質問させていただきました。
41
+
42
+ 何卒よろしくお願い致します。