質問編集履歴
1
エラーメッセージの追記
test
CHANGED
File without changes
|
test
CHANGED
@@ -5,6 +5,24 @@
|
|
5
5
|
componentWillReceivePropsは非推奨だから名前を変えてください。と書いてます。
|
6
6
|
|
7
7
|
![イメージ説明](c98682b4ab59c5952e012d3a15293bd0.png)
|
8
|
+
|
9
|
+
```ErrorMessage
|
10
|
+
|
11
|
+
react-dom.development.js:88 Warning: componentWillReceiveProps has been renamed, and is not recommended for use. See https://fb.me/react-unsafe-component-lifecycles for details.
|
12
|
+
|
13
|
+
|
14
|
+
|
15
|
+
* Move data fetching code or side effects to componentDidUpdate.
|
16
|
+
|
17
|
+
* If you're updating state whenever props change, refactor your code to use memoization techniques or move it to static getDerivedStateFromProps. Learn more at: https://fb.me/react-derived-state
|
18
|
+
|
19
|
+
* Rename componentWillReceiveProps to UNSAFE_componentWillReceiveProps to suppress this warning in non-strict mode. In React 17.x, only the UNSAFE_ name will work. To rename all deprecated lifecycles to their new names, you can run `npx react-codemod rename-unsafe-lifecycles` in your project source folder.
|
20
|
+
|
21
|
+
|
22
|
+
|
23
|
+
Please update the following components: DateInput
|
24
|
+
|
25
|
+
```
|
8
26
|
|
9
27
|
|
10
28
|
|