質問編集履歴

1 文章の追加

hana00033

hana00033 score 17

2019/01/19 16:09  投稿

UnityでGoogleVRを使用している際にビルドをするとでるエラーについて
UnityでVRを作りたかったので、GoogleVRを使用しているのですが、Androidビルドをしようとする際に、
Manifest merger failed : uses-sdk:minSdkVersion 16 cannot be smaller than version 19 declared in library [:gvr-keyboard:] /Users/usernama/.gradle/caches/transforms-1/files-1.1/gvr-keyboard.aar/68fa41e626a0b4019a52a440e5d348e1/AndroidManifest.xml as the library might be using APIs not available in 16 See the Console for details.
というエラーが出ます。
unity:  Version.2018.3.0f2 を使用しています。  
 
試したこと:
AndroidManifest.xmlというファイルを探して中を見てみたところ、
<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
   package="com.google.vr.keyboard"
   android:versionCode="1"
   android:versionName="1.0" >
   <uses-sdk
       android:minSdkVersion="19"
       android:targetSdkVersion="24" />
</manifest>
となっていました。試しに19になっているところを16に変えてみましたが全く同じエラーが出ました。
 
初心者なので、わかりにくい質問で申し訳ないですが、回答よろしくお願いします。
  • Android

    10460 questions

    Androidは、Google社が開発したスマートフォンやタブレットなど携帯端末向けのプラットフォームです。 カーネル・ミドルウェア・ユーザーインターフェイス・ウェブブラウザ・電話帳などのアプリケーションやソフトウェアをひとつにまとめて構成。 カーネル・ライブラリ・ランタイムはほとんどがC言語/C++、アプリケーションなどはJavaSEのサブセットとAndroid環境で書かれています。

  • Unity

    11886 questions

    Unityは、ユニティテクノロジーが開発したゲームエンジンです。 主にモバイルやブラウザ向けのゲーム製作に利用されていましたが、3Dの重力付きゲームが簡単に作成できることから需要が増え、現在はマルチプラットフォームに対応しています。 言語はC言語/C++で書かれていますが、C#、JavaScript、Booで書かれたコードにも対応しています。

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る