質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.76%

  • Ruby

    7033questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2381questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

  • Atom (テキストエディタ)

    481questions

AtomでRuby,Ruby on Railsのコード補完をできるようにしたい

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 324

kk123

score 103

タイトル通りですが、よろしくお願いします。

 環境

  • OS: Mac OS X(10.12.6)
  • Atom: 1.21.2
  • Ruby: 2.4.1
  • Ruby on Rails: 5.1.4

 実施したこと

  1. 下の記事を参考にautocomplete-rubyをインストール(補足①)
  2. http://localhost:47367/ に接続するもエラー画面
  3. rsenseを起動したが/tmp/rsense.logをみる感じだとエラーになってしまってて起動できていない?(補足②)
  4. /tmp/rsense.logにTry: gem pristine puma --version 3.10.0と記載されているのでgem pristine puma --version 3.10.0とかを実施
  5. rsenseを再起動してみるが同じようなエラーが表示される
  6. 下の記事を参考にjrubyをインストールして、gemでrsenseをインストールしようとしてもエラーになってしまう(補足③)
  7. 心が折れる ←いまここ
    どなたかお助けくださいm(_ _)m

 補足①

https://qiita.com/nishina555/items/d3690b057f4624d39d77

 補足②

エラー内容抜粋

Ignoring mysql2-0.4.9 because its extensions are not built.  Try: gem pristine mysql2 --version 0.4.9
Ignoring nio4r-2.1.0 because its extensions are not built.  Try: gem pristine nio4r --version 2.1.0
Ignoring nokogiri-1.8.0 because its extensions are not built.  Try: gem pristine nokogiri --version 1.8.0
Ignoring puma-3.10.0 because its extensions are not built.  Try: gem pristine puma --version 3.10.0
Ignoring rainbow-2.2.2 because its extensions are not built.  Try: gem pristine rainbow --version 2.2.2

 補足③

参考サイト
https://teratail.com/questions/67165

エラー内容

ERROR:  Error installing rsense:
    mustermann requires Ruby version >= 2.2.0.
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.76%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7033questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2381questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

  • Atom (テキストエディタ)

    481questions