質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Laravel 5

Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

解決済

\[Homestead\]vagrant upで起動しない

削除済ユーザー
削除済ユーザー

総合スコア0

Laravel 5

Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

2回答

0評価

0クリップ

2100閲覧

投稿2017/09/15 05:42

編集2022/01/12 10:58

昨日、仮想環境でのアクセスの為に
Homestead.yamlを編集しました。
日付が変わって今日vagrant upで起動しようとしたところ

There are errors in the configuration of this machine\. Please fix the following errors and try again: shell provisioner: \* Shell provisioner `args` must be a string or array\.

というエラーコードが返ってきて起動しません。
(今日の起動前はHomestead.yamlは編集していませんでした)

何が原因なのかわからなくなってしまったので
Laravel5.1フォルダのHomestead.yamlは

folders: - map: C:/Homestead/Laravel5\.1 to: /home/vagrant/Code/Laravel5\.1 sites: - map: homestead\.app to: /home/vagrant/Code/Laravel/public

だけに直しましたが、同じエラーのままです。
今日は他のファイルをいじったのでそちらが原因でしょうか?
自分でもやったところに戻ってみていますが、ご教示お願いします。

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Laravel 5

Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。