質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.09%

ownCloud(php) がインストールできない。

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 2,125
退会済みユーザー

退会済みユーザー

前提・実現したいこと

owncloudを正常にインストールしたいです。
サーバー環境: CentOS7 LAMP

LAMPはこちらを参考にインストールしました。
http://qiita.com/KaI_Qiita/items/6a085571e1a75c69fb4c

発生している問題・エラーメッセージ

https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-owncloud-on-centos-7?utm_content=how-to-install-and-configure-owncloud-on-centos-7
を参考にowncloudのインストールをしてみたのですがyum install owncloudでエラーになります。

[root@localhost ~]# sudo yum install owncloud
読み込んだプラグイン:fastestmirror, priorities
Repository ce_stable is listed more than once in the configuration
base                                                     | 3.6 kB     00:00
ce_9.0                                                   | 1.2 kB     00:00
ce_stable                                                | 1.2 kB     00:00
extras                                                   | 3.4 kB     00:00
mysql-connectors-community                               | 2.5 kB     00:00
mysql-tools-community                                    | 2.5 kB     00:00
mysql56-community                                        | 2.5 kB     00:00
updates                                                  | 3.4 kB     00:00
Loading mirror speeds from cached hostfile
 * base: ftp.jaist.ac.jp
 * extras: ftp.jaist.ac.jp
 * updates: ftp.jaist.ac.jp
8 packages excluded due to repository priority protections
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ owncloud.noarch 0:9.1.6-1.1 を インストール
--> 依存性の処理をしています: owncloud-files >= 9.1.6 のパッケージ: owncloud-9.1.6-1.1.noarch
--> 依存性の処理をしています: owncloud-deps >= 9.1.6 のパッケージ: owncloud-9.1.6-1.1.noarch
--> トランザクションの確認を実行しています。
---> パッケージ owncloud-deps-php5.noarch 0:9.1.6-1.1 を インストール
--> 依存性の処理をしています: php-zip のパッケージ: owncloud-deps-php5-9.1.6-1.1.noarch
--> 依存性の処理をしています: php-posix のパッケージ: owncloud-deps-php5-9.1.6-1.1.noarch
--> 依存性の処理をしています: policycoreutils-python のパッケージ: owncloud-deps-php5-9.1.6-1.1.noarch
--> 依存性の処理をしています: php-mysql のパッケージ: owncloud-deps-php5-9.1.6-1.1.noarch
--> 依存性の処理をしています: php-ldap のパッケージ: owncloud-deps-php5-9.1.6-1.1.noarch
--> 依存性の処理をしています: php-xml のパッケージ: owncloud-deps-php5-9.1.6-1.1.noarch
--> 依存性の処理をしています: php-process のパッケージ: owncloud-deps-php5-9.1.6-1.1.noarch
---> パッケージ owncloud-files.noarch 0:9.1.6-1.1 を インストール
--> トランザクションの確認を実行しています。
---> パッケージ owncloud-deps-php5.noarch 0:9.1.6-1.1 を インストール
--> 依存性の処理をしています: php-zip のパッケージ: owncloud-deps-php5-9.1.6-1.1.noarch
---> パッケージ php-ldap.x86_64 0:5.4.16-42.el7 を インストール
--> 依存性の処理をしています: php-common(x86-64) = 5.4.16-42.el7 のパッケージ: php-ldap-5.4.16-42.el7.x86_64
---> パッケージ php-mysql.x86_64 0:5.4.16-42.el7 を インストール
--> 依存性の処理をしています: php-pdo(x86-64) = 5.4.16-42.el7 のパッケージ: php-mysql-5.4.16-42.el7.x86_64
---> パッケージ php-process.x86_64 0:5.4.16-42.el7 を インストール
--> 依存性の処理をしています: php-common(x86-64) = 5.4.16-42.el7 のパッケージ: php-process-5.4.16-42.el7.x86_64
---> パッケージ php-xml.x86_64 0:5.4.16-42.el7 を インストール
--> 依存性の処理をしています: php-common(x86-64) = 5.4.16-42.el7 のパッケージ: php-xml-5.4.16-42.el7.x86_64
---> パッケージ policycoreutils-python.x86_64 0:2.5-11.el7_3 を インストール
--> 依存性の処理をしています: setools-libs >= 3.3.8-1 のパッケージ: policycoreutils-python-2.5-11.el7_3.x86_64
--> 依存性の処理をしています: libsemanage-python >= 2.5-5 のパッケージ: policycoreutils-python-2.5-11.el7_3.x86_64
--> 依存性の処理をしています: audit-libs-python >= 2.1.3-4 のパッケージ: policycoreutils-python-2.5-11.el7_3.x86_64
--> 依存性の処理をしています: python-IPy のパッケージ: policycoreutils-python-2.5-11.el7_3.x86_64
--> 依存性の処理をしています: libqpol.so.1(VERS_1.4)(64bit) のパッケージ: policycoreutils-python-2.5-11.el7_3.x86_64
--> 依存性の処理をしています: libqpol.so.1(VERS_1.2)(64bit) のパッケージ: policycoreutils-python-2.5-11.el7_3.x86_64
--> 依存性の処理をしています: libcgroup のパッケージ: policycoreutils-python-2.5-11.el7_3.x86_64
--> 依存性の処理をしています: libapol.so.4(VERS_4.0)(64bit) のパッケージ: policycoreutils-python-2.5-11.el7_3.x86_64
--> 依存性の処理をしています: checkpolicy のパッケージ: policycoreutils-python-2.5-11.el7_3.x86_64
--> 依存性の処理をしています: libqpol.so.1()(64bit) のパッケージ: policycoreutils-python-2.5-11.el7_3.x86_64
--> 依存性の処理をしています: libapol.so.4()(64bit) のパッケージ: policycoreutils-python-2.5-11.el7_3.x86_64
--> トランザクションの確認を実行しています。
---> パッケージ audit-libs-python.x86_64 0:2.6.5-3.el7_3.1 を インストール
---> パッケージ checkpolicy.x86_64 0:2.5-4.el7 を インストール
---> パッケージ libcgroup.x86_64 0:0.41-11.el7 を インストール
---> パッケージ libsemanage-python.x86_64 0:2.5-5.1.el7_3 を インストール
---> パッケージ owncloud-deps-php5.noarch 0:9.1.6-1.1 を インストール
--> 依存性の処理をしています: php-zip のパッケージ: owncloud-deps-php5-9.1.6-1.1.noarch
---> パッケージ php-ldap.x86_64 0:5.4.16-42.el7 を インストール
--> 依存性の処理をしています: php-common(x86-64) = 5.4.16-42.el7 のパッケージ: php-ldap-5.4.16-42.el7.x86_64
---> パッケージ php-mysql.x86_64 0:5.4.16-42.el7 を インストール
--> 依存性の処理をしています: php-pdo(x86-64) = 5.4.16-42.el7 のパッケージ: php-mysql-5.4.16-42.el7.x86_64
---> パッケージ php-process.x86_64 0:5.4.16-42.el7 を インストール
--> 依存性の処理をしています: php-common(x86-64) = 5.4.16-42.el7 のパッケージ: php-process-5.4.16-42.el7.x86_64
---> パッケージ php-xml.x86_64 0:5.4.16-42.el7 を インストール
--> 依存性の処理をしています: php-common(x86-64) = 5.4.16-42.el7 のパッケージ: php-xml-5.4.16-42.el7.x86_64
---> パッケージ python-IPy.noarch 0:0.75-6.el7 を インストール
---> パッケージ setools-libs.x86_64 0:3.3.8-1.1.el7 を インストール
--> 衝突を処理しています: php-mysql-5.4.16-42.el7.x86_64 は php-mysqlnd と衝突しています
Removing php-mysql.x86_64 0:5.4.16-42.el7 - u due to obsoletes from installed php-mysqlnd-7.0.23-1.el7.remi.x86_64
--> 新しい変更と依存性の解決を再開しています。
--> トランザクションの確認を実行しています。
---> パッケージ owncloud-deps-php5.noarch 0:9.1.6-1.1 を インストール
--> 依存性の処理をしています: php-zip のパッケージ: owncloud-deps-php5-9.1.6-1.1.noarch
--> 依存性の処理をしています: php-mysql のパッケージ: owncloud-deps-php5-9.1.6-1.1.noarch
---> パッケージ php-ldap.x86_64 0:5.4.16-42.el7 を インストール
--> 依存性の処理をしています: php-common(x86-64) = 5.4.16-42.el7 のパッケージ: php-ldap-5.4.16-42.el7.x86_64
---> パッケージ php-mysql.x86_64 0:5.4.16-42.el7 を インストール
--> 依存性の処理をしています: php-mysql のパッケージ: owncloud-deps-php5-9.1.6-1.1.noarch
---> パッケージ php-process.x86_64 0:5.4.16-42.el7 を インストール
--> 依存性の処理をしています: php-common(x86-64) = 5.4.16-42.el7 のパッケージ: php-process-5.4.16-42.el7.x86_64
---> パッケージ php-xml.x86_64 0:5.4.16-42.el7 を インストール
--> 依存性の処理をしています: php-common(x86-64) = 5.4.16-42.el7 のパッケージ: php-xml-5.4.16-42.el7.x86_64
--> 依存性解決を終了しました。
エラー: パッケージ: php-ldap-5.4.16-42.el7.x86_64 (base)
             要求: php-common(x86-64) = 5.4.16-42.el7
            インストール: php-common-7.0.23-1.el7.remi.x86_64 (@remi-php70)
                php-common(x86-64) = 7.0.23-1.el7.remi
            利用可能: php-common-5.4.16-42.el7.x86_64 (base)
                php-common(x86-64) = 5.4.16-42.el7
エラー: パッケージ: php-mysql-5.4.16-42.el7.x86_64 (base)
             要求: php-pdo(x86-64) = 5.4.16-42.el7
            インストール: php-pdo-7.0.23-1.el7.remi.x86_64 (@remi-php70)
                php-pdo(x86-64) = 7.0.23-1.el7.remi
            利用可能: php-pdo-5.4.16-42.el7.x86_64 (base)
                php-pdo(x86-64) = 5.4.16-42.el7
エラー: パッケージ: owncloud-deps-php5-9.1.6-1.1.noarch (ce_stable)
             要求: php-mysql
            利用可能: php-mysql-5.4.16-42.el7.x86_64 (base)
                php-mysql = 5.4.16-42.el7
            利用可能: php-mysqlnd-5.4.16-42.el7.x86_64 (base)
                php-mysql = 5.4.16-42.el7
            インストール: php-mysqlnd-7.0.23-1.el7.remi.x86_64 (@remi-php70)
                見つかりません
エラー: パッケージ: php-xml-5.4.16-42.el7.x86_64 (base)
             要求: php-common(x86-64) = 5.4.16-42.el7
            インストール: php-common-7.0.23-1.el7.remi.x86_64 (@remi-php70)
                php-common(x86-64) = 7.0.23-1.el7.remi
            利用可能: php-common-5.4.16-42.el7.x86_64 (base)
                php-common(x86-64) = 5.4.16-42.el7
エラー: パッケージ: owncloud-deps-php5-9.1.6-1.1.noarch (ce_stable)
             要求: php-zip
            利用可能: php-common-5.4.16-42.el7.x86_64 (base)
                php-zip
            インストール: php-common-7.0.23-1.el7.remi.x86_64 (@remi-php70)
                見つかりません
エラー: php-mysql conflicts with php-mysqlnd-7.0.23-1.el7.remi.x86_64
エラー: パッケージ: php-process-5.4.16-42.el7.x86_64 (base)
             要求: php-common(x86-64) = 5.4.16-42.el7
            インストール: php-common-7.0.23-1.el7.remi.x86_64 (@remi-php70)
                php-common(x86-64) = 7.0.23-1.el7.remi
            利用可能: php-common-5.4.16-42.el7.x86_64 (base)
                php-common(x86-64) = 5.4.16-42.el7
 問題を回避するために --skip-broken を用いることができます。
 これらを試行できます: rpm -Va --nofiles --nodigest

試したこと

yum install owncloud-filesだと成功しますがログイン画面で拡張phpが必要と言われ、インストールを試してもエラーがでます。

https://www.server-world.info/query?os=CentOS_7&p=initial_conf&f=6
こちらを参考にリポジトリを導入しました。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+2

yum -y --enablerepo=remi,remi-php70 install owncloudで出来ませんか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/02 18:08

    回答ありがとうございます。試してみましたがダメでした....

    エラー: パッケージ: php-xml-5.4.16-42.el7.x86_64 (base)
    要求: php-common(x86-64) = 5.4.16-42.el7
    インストール: php-common-7.0.23-1.el7.remi.x86_64 (@remi-php70)
    php-common(x86-64) = 7.0.23-1.el7.remi
    利用可能: php-common-5.4.16-42.el7.x86_64 (base)
    php-common(x86-64) = 5.4.16-42.el7
    エラー: パッケージ: php-process-5.4.16-42.el7.x86_64 (base)
    要求: php-common(x86-64) = 5.4.16-42.el7
    インストール: php-common-7.0.23-1.el7.remi.x86_64 (@remi-php70)
    php-common(x86-64) = 7.0.23-1.el7.remi
    利用可能: php-common-5.4.16-42.el7.x86_64 (base)
    php-common(x86-64) = 5.4.16-42.el7
    エラー: php-mysql conflicts with php-mysqlnd-7.0.23-1.el7.remi.x86_64
    エラー: パッケージ: php-ldap-5.4.16-42.el7.x86_64 (base)
    要求: php-common(x86-64) = 5.4.16-42.el7
    インストール: php-common-7.0.23-1.el7.remi.x86_64 (@remi-php70)
    php-common(x86-64) = 7.0.23-1.el7.remi
    利用可能: php-common-5.4.16-42.el7.x86_64 (base)
    php-common(x86-64) = 5.4.16-42.el7
    エラー: パッケージ: php-mysql-5.4.16-42.el7.x86_64 (base)
    要求: php-pdo(x86-64) = 5.4.16-42.el7
    インストール: php-pdo-7.0.23-1.el7.remi.x86_64 (@remi-php70)
    php-pdo(x86-64) = 7.0.23-1.el7.remi
    利用可能: php-pdo-5.4.16-42.el7.x86_64 (base)
    php-pdo(x86-64) = 5.4.16-42.el7
    問題を回避するために --skip-broken を用いることができます。
    これらを試行できます: rpm -Va --nofiles --nodigest

    キャンセル

  • 2017/09/02 18:39 編集

    rm -f /etc/yum.repos.d/ownCloud.repo を行ってから再度インストールしてみてください。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.09%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る