質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.59%

herokuにデプロイできません

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,009

sakas1231

score 42

Ruby on railsをrails tutorialで勉強中です。
昨日まではデプロイできたのですが、今日になってデプロイしようとすると

We're sorry, but something went wrong.
If you are the application owner check the logs for more information.


と出てきてしまいます。ただ、rails testはちゃんと通ります。

昨日から今日にかけてやったこととしては、仮想マシンを立ててそこにrailsを入れました。
そこでも同様に自分のherokuアカウントとつなぎ、無事デプロイできました。

経緯としては、最初にデプロイした際に

remote:        You have not declared a Ruby version in your Gemfile.
remote:        To set your Ruby version add this line to your Gemfile:
remote:        ruby '2.3.4'


と言われたのでGemfileにruby '2.3.4'を書き加えたところ

Your Ruby version is 2.3.1, but your Gemfile specified 2.3.4


と言われたのでruby '2.3.1'をGemfileに書き加えてデプロイしたらエラーを吐かなかったのですが上記のエラーが出てしまったという感じです。

今まではこのアプリでデプロイできていたのですが、仮想マシンを作った途端にできなくなってしまいました。

回答とも是非よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • gouf

    2017/07/29 20:58

    Gemfile に定義したRuby のバージョンを2.3.1 に変更した場合、双方の環境で動きますか?

    キャンセル

  • sakas1231

    2017/07/31 16:15

    2.3.1にするとbundle installは通るのですがherokuにデプロイするとエラー出てしまいます。

    キャンセル

回答 1

checkベストアンサー

0

おそらくの勘なので絶対あってるとは限らないのですが、そういうエラーが出てきた場合、rubyのバージョンの方で問題があるパターンもあるのですが、bundlerの方でエラーが起こっている場合があります。
とりあえず、herokuで使われているrubyのバージョンを確認するためにheroku run 'ruby -e "puts RUBY_VERSION"'を試してみてください。
それで、特に間違っていなかったら、gem install bundlerしてbundle installし直してみてください。

Rubyをインストールした時やアップデートした時(ファイルを他の環境に移した時も含め)は、必ずgem install bundlerをしたほうがいいです。基本的にはrailsはgemの管理をbundlerに依存しているので、rubyのアップデートやrailsのアップデートをした時にはbundlerのアップデートをしておかないと予期しないところで動かなる場合があります。

参考記事:
同じような事例
同じような事例2

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/07/31 16:13

    いろいろ試行錯誤したらバージョン確かに違いました
    $ ruby -v
    ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-linux]

    $ heroku run 'ruby -e "puts RUBY_VERSION"'
    ▸ heroku-cli: This CLI is deprecated. Please reinstall from https://cli.heroku.com
    2.4.1

    これは、PCのバージョンが2.3.1で、herokuで走らせようとしているバージョンが2.4.1
    という認識でいいのでしょうか?

    これの対処法は自分の持ってるrubyを2.4.1にバージョンアップさせるしかないのでしょうか?

    キャンセル

  • 2017/07/31 21:00

    その場合は、gemfileで2.3.1を指定した上で、ローカルの方のbundlerを再インストールしてみてください

    キャンセル

  • 2017/08/05 09:47

    できました!ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.59%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る