質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.11%

Androidアプリのバージョンアップで「アップロードした APK の署名が無効です」と出る。

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,494

Chumi

score 18

Androidアプリをバージョンアップしたく、新しいAPKを登録したいのですが、
「アップロードした APK の署名が無効です」と表示されます。
最初にリリースした証明書と同じものを使用しています。

以下のエラーが出ます。

アップロードできませんでした
アップロードした APK の署名が無効です(署名の詳細)。
apksigner のエラー: ERROR (Jar signer [アプリ名]_.RSA): JAR signature META-INF/[アプリ名]_.RSA uses digest algorithm 2.16.840.1.101.3.4.2.1 and signature algorithm 1.2.840.113549.1.1.1 which is not supported on API Levels [[14, 17]]

Titaniumを使用しており、コマンドラインからビルドすると、

[WARN]  The selected alias "[アプリ名]" uses the "SHA256withRSA" signature algorithm which will likely have issues with Android 4.3 and older.
[WARN]  Certificates that use the "SHA1withRSA" or "MD5withRSA" signature algorithm will provide better compatibility.


とでるので気になってはいました。

tiapp.xmlでは以下の記述をしています。

<android xmlns:android="http://schemas.android.com/apk/res/android">
<tool-api-level>14</tool-api-level>
<manifest android:versionCode="6" android:versionName="2.5.42">
<uses-sdk android:minSdkVersion="14" android:targetSdkVersion="23"/>

どこをどう変更したら今の証明書でバージョンアップが可能になるのでしょうか。
お知恵をお貸し下さい。
宜しくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

<android xmlns:android="http://schemas.android.com/apk/res/android">
<tool-api-level>19</tool-api-level>
<manifest android:versionCode="6" android:versionName="2.5.42">
<uses-sdk android:minSdkVersion="19" android:targetSdkVersion="23"/>


に変えたら通りました。
証明書のアルゴリズムがSHA256withRSA(4.3以前は対象外)だったため、
4.4以降に対応するAPIレベルに変更すれば良かったようです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.11%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる