zabbixエージェントを意図したバージョンでインストールしたい。

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,637

ringomilk

score 18

前提・実現したいこと

監視対象サーバに、zabbixサーバにインストールされているzabbixと同じバージョンのzabbixエージェント(2.4。最悪メジャーバージョンが同じであれば良い)をインストールしたい

発生している問題&試したこと

1.rpm -ivh http://repo.zabbix.com/zabbix/2.4/rhel/6/x86_64/zabbix-release-2.4-1.el6.noarch.rpm
2.yum install zabbix-agent

上記コマンドを行い、zabbix-agentをインストールしたいのですが、
現状3.0がインストールされてしまいます。

また、[1]を行った後
・/etc/yum.repos.d/zabbix.repo ファイルの「enabled = 1」を「enabled = 0」に編集する
上記手順を行ってから[2]を実行したときには、1.8がインストールされます。

[1][2]を実行すれば自動的に2.4がインストールされると思っていました。
いろいろ調べてみましたが自力で解決するのが難しいと判断しましたので
どうかご教授を宜しくお願い致します。

補足情報(言語/FW/ツール等のバージョンなど)

■監視対象サーバ
OS:CentOS6.8

■zabbixサーバ
OS:CentOS6.9
zabbix:2.4.1

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

/etc/yum.repos.d/zabbix.repo の[zabbix]のbaseurlは http://repo.zabbix.com/zabbix/2.4/rhel/6/$basearch/ になっていますでしょうか。

現在3.0がインストールされるなら何らかの理由で http://repo.zabbix.com/zabbix/3.0/rhel/6/$basearch/ になっている可能性が高いです。
(例えば事前に http://repo.zabbix.com/zabbix/3.0/rhel/6/x86_64/zabbix-release-3.0-1.el6.noarch.rpm がインストールされていた、とか)
もしそうなら 3.0 の箇所を 2.4 に修正し、yum clean allを実行してからyum install zabbix-agentを実行してみてください。

なお、1.8はEPELからインストールできるバージョンですね。
/etc/yum.repos.d/zabbix.repo をenabled=0にしてEPELがenabled=1なら1.8がインストールされることになります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/06/24 02:58

    ご回答ありがとうございます。

    ご指摘の通り、一度ミスで3.0をリポジトリ追加してしまいました。教えていただいたことに、非常に合点がいきました。
    週明けにでも試して、改めてご報告申し上げます。

    丁寧な解説、ありがとうございました!

    キャンセル

  • 2017/06/27 09:52

    本日、/etc/yum.repos.d/zabbix.repoの内容を確認した後
    yum clean all を実行したところ、
    無事バージョン2.4をインストールすることができました。
    大変感謝しております。ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.22%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る